Computers & Electronics

Anyone have any luck with setting up Freephoneline with Cisco SPA 122?

  • Last Updated:
  • Jun 15th, 2016 10:13 am
Tags:
None
[OP]
Member
Jun 18, 2010
406 posts
4 upvotes
Toronto

Anyone have any luck with setting up Freephoneline with Cisco SPA 122?

Hi, just wondering if anyone has had luck setting up Cisco SPA 122 on FreePhoneLine?

My problem is that the caller from Freephonline can not hear the receiving end, but the receiving end can hear the caller.

My set up is as follows:

SIP tab:
RTP Parameters
- RTP Packet Size: 0.020

NAT Support Parameters
- NAT Keep Alive Intvl: 20

Regional Tab:
Ring and Call Waiting Tone Spec
- Ring Waveform: Sinusoid
- Ring Voltage: 90
- Ring Frequency: 52

Line 1 Tab:
General
- Line Enable: Yes

SIP Settings
- SIP transport: UDP
- SIP Port: 5060

Proxy and Registration
- Proxy: voip.freephoneline.ca
- Register: Yes
- Register Expires: 3600

Subscriber Information
- User ID: 1647xxxxxxx (freephonline phone number)
- Password; provided by FreePhoneLine

Audio Configuration
- Preferred Codec: G711u
- Secondary Preferred Codec: G729a
- Third Preferred Codec: G711a
- Use Pref Codec Only: No

Dial Plan: (911|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xxxxxxxxxxxx.|98*|[6-7]x*xxxxxxxxxxx.)

I also put the ATA into bridged mode. Am I missing any settings?

Thanks
3 replies
Newbie
Aug 5, 2009
31 posts
3 upvotes
North York
I managed to fixed the problem installing dd-wrt "v24preSP2 Build 14896 - NEWD K2.6 VoIP Generic" onto my Asus RT-N16 wireless router and connected my SPA122 successfully, the one way voice issue is now solved.

http://www.voip-info.org/wiki/view/NAT+and+VOIP
http://www.dd-wrt.com/site/support/router-database

WARNING!!! Do not flash your router with dd-wrt if you don't know what you are doing, or please proceed with caution, because you can brick your router (unfunctional/not repairable)
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3277 upvotes
Before I begin, I'm recovering from surgery and dealing with other medical issues. I may not respond further.
Please do not PM me. Thank you for your consideration in this matter.

Btw, the official RFD Freephoneline thread is over here: merged-freephoneline-ca-free-local-soft ... oip-821229
lossless wrote:
Apr 21st, 2013 6:26 pm
My problem is that the caller from Freephonline can not hear the receiving end, but the receiving end can hear the caller.
This issue is due to RTP packets not being received by the ATA, so you can probably skip step 4 below.

FPL's server is likely sending RTP packets to the wrong I.P. address (possibly the local IP of your ATA--rather than your WAN IP). Another possible cause is the SIP ALG feature in whatever router you're using is mangling packet headers, which in turn causes RTP audio packets to be sent into the abyss.
And a third possible cause is that the NAT firewall in whatever router you're using is blocking RTP ports.

I would go through the steps listed at the bottom of this post.

Am I missing any settings?


Refer to the .pdf guide and also to what Mango wrote below at http://forum.fongo.com/viewtopic.php?f=15&t=16340

Voice>>Line 1>>SIP settings, change SIP Port to a random number between 30000 and 60000.
and, in particular, look at what Mango wrote in the post below.

That is, make sure that the following settings are enabled (Voice >> SIP):

"Handle VIA received: yes
Handle VIA rport: yes
Substitute VIA Addr: yes"

Ensure those are enabled.


Getting one way audio issues with an SPA122 and Freephoneline? Are incoming calls not ringing? Can you not hear one side of the conversation (you can hear the caller, but the caller can't hear you or vice versa)?

Try a different phone; check all cables and cords.

These instructions do not address "this account is not valid" messages (you would need to contact FPL/Fongo for that problem).
"If you’re getting an “invalid account” error messages, or if people trying to call you are hearing "invalid account" or a busy signal, please log in to your account online at https://www.freephoneline.ca/followMeSettings and reset your Follow Me settings (or disable it). Please ensure your temporary FPL number is not listed as one of the Follow Me numbers."

If you have calls going straight to voicemail, login at https://www.freephoneline.ca/voicemailSettings and ensure "Rings before voicemail" is greater than 1.

Hardware Specific Issues

A. Netgear R7000 routers

Update firmware. Disable SIP ALG in this router. Then reboot modem, router, and ATA in that order. Then test again.

If you have a Netgear R7000 router, you may need to install third party XWRT-Vortex firmware. I recommend doing this anyway to obtain easy access to both UDP Unreplied and UDP Assured timeout settings. Afterwards, turn off the router and the ATA. Turn on the router. Wait for it to be fully up and running (including Wi-Fi). Then turn on the ATA. Download XWRT-Vortex here: http://xvtx.ru/xwrt/download.htm. In your router, navigate to Advanced Settings–>WAN–>NAT Passthrough–>SIP Passthrough. Change SIP Passthrough to “Enabled + NAT helper.” Click “Apply.”

B. Nettis 4422 modem from Carry Telecom (click the "Internet" tab)
http://www.carrytel.ca/support.aspx
Q : DSL - My VoIP phone does not work with Netis 4422 modem.
A : Please download the newest Netis firmware at www.carrytel.ca/download/netis1228.zip. Unzip the netis1228.zip file and update the firmware file netis1228.img for your modem. The new firmware has been tested and working with most of Voip phone providers

C. Asus VLAN

A number of people have been trying to eliminate Bell Hubs from their setups by using this guide: http://blog.ngpixel.com/post/1044497475 ... own-router.
At the time of this guide being written, NAT acceleration must be disabled in this setup in order for SIP services, including Freephoneline, to work properly. In your router, navigate to Advanced Settings-->LAN-->Switch Control-->NAT Acceleration. Select "disable." Click "apply."Then reboot your modem, router (wait for Wi-Fi SSIDs to populate first before rebooting ATA), and your ATA, in that order.

To determine whether you need NAT Acceleration enabled, visit https://routerguide.net/nat-acceleration-on-or-off/. If you do require NAT Acceleration to be enabled, don’t use VLAN with Asus routers.

D. Hitron CGN series gateway modem/router combos (from Rogers, Shaw, or another ISP) or any modem/router combo from any ISP with SIP ALG forced on

If you don’t have your own router, and if you can’t get someone from Rogers or your ISP to disable SIP ALG for you in their modem/router combo, your ATA may need to register with voip4.freephoneline.ca:6060. The purpose of voip4.freephoneline.ca:6060 is to help circumvent faulty SIP ALG features in routers. So, if you’re experiencing one-way audio issues as a result of SIP ALG, this is the SIP server to try. Check to ensure that you can’t disable SIP ALG yourself (refer to point E below).

E. Hitron CGN3ACSMR and CODA-4582 series gateway modem/router combos from Rogers (and possibly other ISPs)
Open your web browser, and login at 192.168.0.1. Default username is cusadmin.
Select the “Basic” tab and disable “SIP ALG.” Click the “save changes” button.







Before you begin,

i)disable DMZ and all port forwarding in your router,

and

ii) make sure whatever modem/router combo your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to. For Bell Hubs, visit please-sticky-how-bypass-bell-hub-use-y ... r-1993629/



1) Make sure your ringer is enabled on your phone. Try a different phone; check all cables and cords.

2) Log into your SPA122

3) If you have your own router or are using a modem/router combo that's not in bridge mode and are connecting the SPA122 to the router or modem/router combo, stick your SPA122 in bridge mode:

a. Navigate to Network Setup menu tab-->Network Service menu (on the left)
b. Select Network Service drop-down box
c. Select Bridge
d. click Submit

The last thing you need with FPL is double NAT issues.


4.

A. Under Voice-->User 1 and User 2 (both of these)-->navigate to Supplementary Service Settings

Ensure

a) DND setting is set to NO
b) Block ANC Setting is set to NO
c) DND Activated is set to NO
d) Cfwd All Serv: no
e) Cfwd Busy Serv: no
f) Cfwd No Ans Serv: no


B. Under Voice-->User 1 and User 2 (both of these)
http://sbkb.cisco.com/CiscoSB/GetArticl ... onverted=0

Check Call Forward Settings


a) Cfwd All Dest:

That field should be blank. If there's a phone number there you don't recognize, you were hacked.
Make that field blank.

b) Cfwd Busy Dest

That field should be blank. If there's a phone number there you don't recognize, you were hacked.
Make that field blank.


c) Cfwd No Ans Dest

That field should be blank. If there's a phone number there you don't recognize, you were hacked.
Make that field blank.


5. In your SPA122, Navigate to Voice-->Line 1 (or whatever you're using for FPL)-->SIP settings, change SIP Port to a random number between 30000 and 60000.


6. In your SPA122, Navigate to the Voice-->SIP-->NAT Support Parameters, and make sure that the following settings are enabled:

a)Handle VIA received-->yes
b)Handle VIA rport-->yes
c)Substitute VIA Addr-->yes

save settings

7. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

8. If there are still problems, try disabling the SIP ALG feature in whatever router or modem/router combo it is that you're using:
http://www.obihai.com/faq/sip-alg/calling-out.

If you're using a modem/router combo issued by your ISP, contact your ISP. Be aware that most reps will have no clue what SIP ALG is, much less know how to disable it.
You may need to ask to speak to a tier 2 rep. SIP ALG features are sometimes hidden or blocked off to customers in modem/router combos issued by ISPs.

To understand why SIP ALG is often buggy in routers and causes horrible problems, visit https://www.voip-info.org/wiki/view/Routers+SIP+ALG.

I'm of the opinion Apple routers don't offer this feature, but you might as well check. If you manage to disable SIP ALG in the router, then retest.

DLINK router users may need to log into the admin page of their router, click the "Advanced" tab and then "Firewall Settings",
navigate to "Application Level Gateway (ALG) Configuration", and uncheck SIP: http://www.support.dlink.com/emulators/ ... dv_dmz.htm

For reference, this is how to disable SIP ALG in Asus routers, although I've never had to do this for Freephoneline: https://kb.intermedia.net/article/3024

If you received a modem/router combo, from your ISP ask your ISP. It is typically better to stick the modem/router combo from your ISP in bridge mode and use an external router.

See here for an example on how to disable SIP ALG in a router: http://www.obihai.com/faq/sip-alg/disable-alg

Image

Save settings.
Turn off both router and ATA. Turn on router. Wait for router to be fully up and transmitting data. Turn on ATA.
Then retest by calling your FPL phone number. If the problem is solved, don't continue.

9. Try Proxyserver voip4.freephoneline.ca:6060
http://forum.fongo.com/download/file.php?id=1742 (look at page 4 of the .pdf)


Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

voip4.freephoneline.ca:6060 is a SIP server whose purpose is to help those with SIP ALG issues (can't disable it in the user's router, for example).



10. Try this at your own risk: use voip3.freephoneline.ca as the proxyserver

voip3.freephoneline.ca is intended for testing purposes only--or for those who receive explicit permission to use it. Using it for an extended period may get your account banned. However, if using voip3.freephoneline.ca does work, you should open up a ticket with support and let them know that you can't get two-way audio any other way: https://support.fongo.com/anonymous_requests/new

If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

FPL configures its SIP servers differently than many other VoIP providers.
voip3.freephoneline.ca conforms more to the norm. But using it without permission can get your account banned.
If you'd like to avoid getting your account banned, use Proxyserver voip.freephoneline.ca, voip2.freephoneline.ca, or voip4.freephoneline.ca:6060 instead and skip to step #12.

11. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

12. If none of that helps, then, unfortunately, you're pretty much stuck with port forwarding your RTP (UDP) port range 16384-16482 from your router to your ATA. For reference, that range can be found under Voice-->SIP-->RTP Parameters-->RTP Port Min and RTP Port Max. You're going to want to double check those numbers in your ATA. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP.

13. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.


Then retest by calling your FPL phone number.

14. Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly
with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (Reg Retry Intvl)

“<“ means less than.

A problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in
consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server.
In turn, incoming calls may, intermittently, not reach the ATA. Again, NAT Keep-alive Interval is supposed to be 20 with
FPL.

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be
difficult, if not impossible. Asuswrt-Merlin, third party firmware for Asus routers, does offer easy access to these two
settings, which are found under General–>Tools-->Other settings. In part, for this reason, I tend to use Asus routers
that work with Asuswrt-Merlin. However, my understanding is that third party Tomato firmware has these two settings
as well. So if your router supports Tomato firmware, that may be another option.
The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time (Reg Retry Intvl setting in your ATA) is 120. I use 10 for UDP
Unreplied Timeout and 117 for UDP Assured Timeout.

15. If all else fails, try posting at http://forum.fongo.com/viewtopic.php?f= ... &start=300 and/or open a support ticket at https://support.fongo.com/anonymous_requests/new.
When creating a ticket, for the issue type select VoIP Unlock Key-->My account inquiry. Ask for a "forced registration."
If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Top