Cell Phones

Asus Zenfone 3 Revealed / Announced

  • Last Updated:
  • Sep 23rd, 2017 1:00 pm
Tags:
None
Member
May 30, 2017
343 posts
87 upvotes
Streetsville, Missis…
ManCaveGamer wrote:
Sep 19th, 2017 10:23 pm
so here's something... I have not rooted my Zenfone 3 at all. my phone was left on the stock OS, and guess what... so I went on vacation, just arrived to the airport after getting off the plane, and then I restarted my phone because my wi-fi wasn't working, except that after I restarted my phone it went into a bootloop and got bricked! every time I restarted my phone it would just keep trying to load up but would keep restarting again immediately after popping up the home screen. tried to get my data/passwords off it by flashing the recovery img but couldn't even do that! maybe it was a regular OS update that did it, or just arriving in another country and the roaming setting update, but I had to factory reset it to get it back.

.....

I'm really thinking of ditching Zenfone 3 and think everyone should do the same, and also avoid Zenfone 4... the company, Asus, doesn't even seem to have a tech support phone number for their phones but has a number for every other product that they do. what should I do? e-mail them and send back, or maybe just not waste money/time sending back, to instread try an fix it myself rooting it if it's potentially just a software / OS problem?

TLDR; i suggest you don't buy Zenfone 3 after my experience
I had a WiFi issue with my Zenfone a few weeks back (before I sold it). But only at a particular GO station. Every time I entered that GO station it would automatically connect to GO WiFi (but WiFi won't work there unless you go through their sign in page). For some reason the WiFi at this particular station caused my Zenfone 3 to get stuck on the "searching for WiFi" page. I had to do a full network reset but I never quite figured out if that fixed the issue or not.

So by WiFi not working, did you have the same issue as me? If so, I wonder why that was happening... ASUS bloatware is weird. I was completely stock and unrooted/locked bootloader as well. Anyway, your phone going into a bootloop like that means there are serious issues with this phone and I'm so glad I sold mine. I sold mine because the Canadian variant has an undervolted headphone jack (0.3v). Certain headphones sound fine (like the EarPods) but many others don't. No idea why. I guess you need extra bassy high impedance earphones (at least 40+ ohm). The 32ohm buds I tried sounded like crap with this phone. I think most phones in general need high impedance earphones if you want clarity at high sound levels.

But that wasn't all. There was also a really irritating hardware issue with the phone--the screen kept flickering from low to high brightness randomly. Wasn't all that visible from far away, but if you held the phone close to your face you could see it and could never unsee it. Probably some issue with the backlight. I bought it used, so I guess the last person who owned it dropped it or something.

But that's not why I ditched my ZF3. It was the awful audio. For me it was a decent phone, though I hated the slippery back and it heated up while gaming a bit, too. Plenty of application has stopped error messages too. Probably due to ASUS bloat. Right now I'm looking at the Mi A1 as a replacement. I don't think I'll ever bother with another ASUS phone in the future. Why on earth would you mess with the Canadian version's headphone jack like that. smh
i'm seriously never getting an Asus phone (didn't really like my Zenfone 2 that much also), and might just get an iPhone where you don't have these kinds of problems to begin with.
Actually I had serious issues with my iPhone before this... which is what got me to switch to the ZF3. :/ While listening to music via earphones, audio would stop playing, but the music file would continue playing... don't know how that happened. It's an issue with iOS 10 that has carried over to iOS 11. Basically I had no audio ANYWHERE even though apps would continue acting like audio was playing. Could have been a hardware issue related to the headphone jack but IDK. A reboot fixed it but only temporarily. It'd start up again a few hours later. I eventually got so sick of it that I sold my phone.

I have the worst luck with phones. Seriously.

Top