Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
shan52 wrote:
Mar 24th, 2016 12:54 pm
Hi, I tried to send a fax to the ATA, but is not working. I don't see any fax record in the FL.
You don't send a fax to the ATA. You send it to FPL's voicemail. Let FPL's voicemail pick up the fax call.



If you want to send faxes with your ATA...


For faxing with an OBi200/202 (and FPL),

1) Use firmware 3.1.0 (Build: 5110): http://fw.obihai.com/OBi202-3-1-0-5110.fw (also works with OBi200)
http://www.obitalk.com/forum/index.php?topic=8982.0

2) If you used the Obitalk web portal (www.obitalk.com) to configure your ATA, keep in mind that you must continue using it to configure your ATA. Otherwise whatever settings you change will eventually be overwritten by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour, dial ***1. Enter that IP address into a web browser. Navigate to System Management-->OBiTalk Provisioning-->select Disabled for the method. Save. Reboot ATA. Now obitalk.com won't overwrite whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not use both methods. Keep in mind that activating Google Voice requires using the Obitalk.com web portal.


3) Navigate to Codecs-->Codec Profile (A or whatever the VoIP service you're using is assigned to . . . you can determine this under Voice services-->SP[freephoneline] Service-->X_CodecProfile),

4)ensure FAX Event is enabled, and

5)ensure under Codec Settings--> that FaxPassThroughCodec is set to G711U

6)T38Enable should be checked

(4, 5, and 6 should be default settings)

7) T38ECM is checked for me (and seems to work). This is not a default setting.


(submit/save)

8. I would increase volume slightly:
Navigate to Physical Interfaces-->Phone Port-->

a) Change ChannelTxGain to -1
b) Change ChannelRxGain to 0


(submit/save/reboot)

9) On your fax machine, lower baud rate to 9600 bps (I'm able to fax at faster rates than 9600, but if you can't without outgoing faxes failing, lower your baud rate to 9600)

10) On your fax machine, turn off or disable ECM (both TX and RX)
http://www.voipmechanic.com/voip-fax-settings.htm


In your call status page, during T.38 protocol fax transmission, you'll see the following:
"Audio Codec = tx=; rx=G711U"
(which doesn't specifically state T.38, but this is the only indication OBi seems to provide)

If you're not using T.38, you'll see "Audio Codec = tx=G711U; rx=G711U" instead, which just means you're using the G.711u codec only.
Deal Addict
User avatar
Jul 26, 2005
3566 posts
17716 upvotes
Montreal
So after some time of everything working properly, I've now encountered a problem where the incoming calls go directly to voicemail, but all outgoing calls work fine. It started this past weekend.

FPL voicemail ring setting is at 5, followme settings are turned off. SIP AIG is turned off on my Netgear r7000 router(stock firmware).

I've rebooted the router + OBI202 and the problem still occurs.

I guess if there's no solution, I'll put XWRT-Vortex on the router.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
krazykanuck wrote:
Mar 30th, 2016 10:58 am
So after some time of everything working properly, I've now encountered a problem where the incoming calls go directly to voicemail, but all outgoing calls work fine. It started this past weekend.

FPL voicemail ring setting is at 5, followme settings are turned off. SIP AIG is turned off on my Netgear r7000 router(stock firmware).

I've rebooted the router + OBI202 and the problem still occurs.

I guess if there's no solution, I'll put XWRT-Vortex on the router.
I'm skeptical XWRT-Vortex is going to resolve this problem if you weren't having problems before, unless new firmware was pushed to your modem by your ISP--or unless you updated router firmware over the weekend. Double check to ensure your modem is in bridge mode.


If you used the Obitalk web portal (www.obitalk.com) to configure your ATA, keep in mind that you must continue using it to configure your ATA. Otherwise whatever settings you change will eventually be overwritten by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour, dial ***1. Enter that IP address into a web browser. Navigate to System Management-->OBiTalk Provisioning-->select Disabled for the method. Save. Reboot ATA. Now obitalk.com won't overwrite whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not use both methods. Keep in mind that activating Google Voice requires using the Obitalk.com web portal.

(In Obitalk.com, you will need to enable and enter expert settings to do the following, if you want to use Obitalk.com. You do this by selecting Edit Profile-->Advanced Options-->check Enable OBi Expert Entry from Dashboard-->submit)


1. Navigate to Voice Services-->SP (FPL) Service-->Calling Features

a) Ensure DoNotDisturbEnable is unchecked

b) Ensure CallForwardUnconditionalEnable is unchecked

c) Ensure CallForwardOnBusyEnable is unchecked

d) Ensure CallForwardOnNoAnswerEnable is uncheked

e) Ensure AnonymousCallBlockEnable is unchecked


2. If you've made any changes in #1, Save/reboot


3. (After logging into the ATA via its IP) Under Status-->System Status-->SP(FPL) Service Status
What does the status state for FPL?

If it's not registered, do step 4,5,6,7 and then stop. Make sure FPL is registered.
If it's not, that's the problem. If it's not registered after doing 4,5,6,7, you can try voip2.freephoneline.ca for your ProxyServer (Service Providers-->ITSP Profile FPL-->SIP-->ProxyServer)

If the problem is 1 b,c, or d you've probably been hacked and have a security issue.

You should do 4,5,6, and 7 anyway.


4. Double check your settings with the .pdf guide here: http://forum.fongo.com/viewtopic.php?f=15&t=16090
(Under Service Providers-->ITSP Profile FPL-->SIP . . . double check RegistrationPeriod is set to 3600; RegisterExpires is set to 3600; and
RegisterRetryInterval is set to 120)


5. In your Obihai ATA or at Obitalk.com, Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
Pick a random number between 30000 and 60000

(submit/save/reboot)

6. Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature

(submit/save/reboot ATA)

7. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.



Just mostly pasting the rest if I need to refer to it later.














-----


8. If that doesn't work, you can also try enabling X_DetectALG (Navigate to Service Providers-->ITSP Profile (FPL)-->SIP)

(submit/save/reboot ATA)

9. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

10. If that still doesn't work, disable X_DetectALG. And submit/save/reboot ATA.


11. Try Proxyserver voip4.freephoneline.ca:6060
visit http://forum.fongo.com/viewtopic.php?f=15&t=16196 (look at the .pdf)
(I'm of the opinion that step #8 makes this step redundant, but trying this is worth a shot anyway).
Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

voip4.freephoneline.ca:6060 is a SIP server whose purpose is to help those with SIP ALG issues (can't disable it in the user's router, for example).




12. Try this at your own risk: use voip3.freephoneline.ca as the proxyserver
voip3.freephoneline.ca is intended for testing purposes only--or for those who receive explicit permission to use it. Using it for an extended period may get your account banned. However, if using voip3.freephoneline.ca does work, you should open up a ticket with support and let them know that you can't get two-way audio any other way: https://support.fongo.com/anonymous_requests/new

If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

FPL configures its SIP servers differently than many other VoIP providers.
voip3.freephoneline.ca conforms more to the norm. But using it without permission can get your account banned.
If you'd like to avoid getting your account banned, use Proxyserver voip.freephoneline.ca, voip2.freephoneline.ca, or voip4.freephoneline.ca:6060 instead and skip to step #14.

13. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

14. If none of that helps, then, unfortunately, you're pretty much stuck with port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP.

15. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.


Then retest by calling your FPL phone number.

16. If all else fails, try posting at http://forum.fongo.com/viewtopic.php?f= ... &start=300 and/or open a support ticket at https://support.fongo.com/anonymous_requests/new
If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.
Deal Addict
User avatar
Jul 26, 2005
3566 posts
17716 upvotes
Montreal
Webslinger wrote:
Mar 30th, 2016 11:57 am
I'm skeptical XWRT-Vortex is going to resolve this problem if you weren't having problems before, unless new firmware was pushed to your modem by your ISP--or unless you updated router firmware over the weekend. Double check to ensure your modem is in bridge mode.
No updates done on my side.
3. (After logging into the ATA via its IP) Under Status-->System Status-->SP(FPL) Service Status
What does the status state for FPL?
Registered (server=208.65.240.44:5060; expire in 1745s)

I've done steps 1-7 that you mentioned. I'll have to reboot the router + ata at the house later and see if any of those changes fixed the problem.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
krazykanuck wrote:
Mar 30th, 2016 2:52 pm

I've done steps 1-7 that you mentioned.
Was step 1 all unchecked for you already? Or did you need to uncheck something?
Penalty Box
User avatar
Apr 21, 2004
49357 posts
14614 upvotes
That **2 to switch to the other line (Google Voice in our case) is neat.

At first I thought I needed a new set of handsets.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
alanbrenton wrote:
Mar 30th, 2016 3:01 pm
That **2 to switch to the other line (Google Voice in our case) is neat.

At first I thought I needed a new set of handsets.
You can change **2 to whatever you want, but that's the default.
To change this, navigate to Physical Interfaces-->PHONEx Port-->OutboundCallRoute
You'll see {(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Msp3)):sp3},{(<**4:>(Msp4)):sp4} listed in there.
You could change {(<**2:>(Msp2)):sp2} to {(<*2:>(Msp2)):sp2} if you want, for example. Then instead of dialing **2 + phone number to dial out on SP2, you would dial *2 + phone number.

Or you could do something similar to what X360 has done. Visit merged-freephoneline-ca-free-local-soft ... st20004155
Deal Addict
User avatar
Jul 26, 2005
3566 posts
17716 upvotes
Montreal
Webslinger wrote:
Mar 30th, 2016 2:59 pm
Was step 1 all unchecked for you already? Or did you need to uncheck something?
Everything was already unchecked. Infact, the only place I made changes was in regards to Step 6 of the PDF that was mentioned in Step4
"SP1 Service
X_KeepAliveEnable: [Checkmark]
X_KeepAliveExpires: 20
• SIP Credentials
AuthUserName: [Put your SIP User ID]
AuthUserPassword: [Put your SIP Password]"
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
krazykanuck wrote:
Mar 30th, 2016 3:08 pm
Everything was already unchecked. Infact, the only place I made changes was in regards to Step 6 of the PDF that was mentioned in Step4
"SP1 Service
X_KeepAliveEnable: [Checkmark]
X_KeepAliveExpires: 20


That wouldn't cause the problem. I know that's 15 when you select the FPL profile in Obitalk.com


• SIP Credentials
AuthUserName: [Put your SIP User ID]
AuthUserPassword: [Put your SIP Password]"


Did you need to enter your AuthUsername and Authpassword????
If so, that's very strange.
Deal Addict
User avatar
Jul 26, 2005
3566 posts
17716 upvotes
Montreal
Webslinger wrote:
Mar 30th, 2016 3:17 pm
That wouldn't cause the problem. I know that's 15 when you select the FPL profile in Obitalk.com



Did you need to enter your AuthUsername and Autherpassword????
If so, that's very strange.
Autherpassword only
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
krazykanuck wrote:
Mar 30th, 2016 3:24 pm
Autherpassword only
That may be normal for passwords not to show in Obitalk.com as well. I'm not sure.

Well, I'm at a bit of a loss to explain what happened. Try rebooting modem, router, and ATA in that order when you test again.

If it still doesn't work, try briefly testing with the ATA connected directly to the modem just to see if the problem goes away without the router involved.

You may need to hope that Pianoguy sees your problem.
Deal Addict
Jun 29, 2010
1153 posts
520 upvotes
Somewhere in Ontario
Is there a way to reduce the dial out delay?
Member
Jul 10, 2006
394 posts
91 upvotes
Toronto
DPyro wrote:
Mar 30th, 2016 9:07 pm
Is there a way to reduce the dial out delay?
Yes. You can add '#' after the number. On my OBI ATA this dials immediately.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
DPyro wrote:
Mar 30th, 2016 9:07 pm
Is there a way to reduce the dial out delay?
I can't remember if you're using an Obihai ATA.

But the answer is, probably, yes, and it's dependent upon your ATA and the dialplan that you're using.

With obihai ATAs anything with XX. in it is an indefinite variable that's subject to an interdigit timeout (typically 10s).

So, if you navigate to Service Providers-->ITSP Profile (FPL)-->General-->Digitmap

You'll probably see XX. and 011XX.

Chances are XX. is redundant (not needed) and can be removed.

You could change 011XX. to 011XX.S3
(which would reduce the amount of time the Obihai ATA waits for a phone number to be entered before dialing out)

XX. represents anything that can possibly be dialed
011XX. represents anything that can possibly be dialed starting with 011
XX. is an indefinite variable, and it's still an indefinite variable with combined with 011
S3 represents a digit timer of 3 seconds

Should you require further assistance, and if no one responds here (I just don't have time for dial plans), I would suggest asking for help at
https://www.obitalk.com/forum/index.php?board=3.0 (if you have an Obihai ATA).

You can also do what pocket1 wrote, if you have an Obihai ATA.
Deal Addict
Jan 1, 2004
1533 posts
75 upvotes
Have been using freephoneline with obihai 202 behind Asus RT N66U router. Often time people complaint that my voice very choppy on their end, yet I seem to hear them fine. Is there setting that I should tweak on ATA set up or on router? Thanks very much

Top