Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
Latest firmware for OBi200/202 is now 3.1.1 (Build: 5577): http://fw.obihai.com/OBi202-3-1-1-5577.fw

I have no idea what's changed. Update at your own risk
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Sr. Member
Feb 3, 2006
929 posts
16 upvotes
It looks like my ATA Linksys pap2T device is toast.

I'm looking for a new ATA. what would you gents suggest?
Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
fogo wrote:
Mar 2nd, 2017 9:21 pm
It looks like my ATA Linksys pap2T device is toast.

I'm looking for a new ATA. what would you gents suggest?
The most powerful ATAs for home use are Obihai OBi200 or OBi202 (if you need two phone or FXS ports), due to their powerful call routing features, sold by Newegg Canada.

OBi200 is currently on sale: http://forums.redflagdeals.com/newegg-o ... x-2083622/
Today (Sunday) is the last day of the sale.

Obihai ATAs were designed by the same people who engineered the PAP2T.
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Deal Addict
Aug 5, 2002
3244 posts
90 upvotes
Toronto
Can someone please help me? Trying to make sense of this thing.

I have a R7000 with XWRT Vortex and disabled ALG SIP and followed the instructions to the letter but I can't get incoming phone calls to work. Calling out works no problem.

I have also the Hitron Modem from Rogers CGN3ACR and have put it in Bridge mode, the last thing I haven't tried is port forwarding but I don't want to do that.

I've tried voip4.freephoneline.ca and same thing also. Each time I've rebooted the router, made sure it's fully up then ATA.

Forgot to mention I have a OBIHAI 200
Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
Jeff146 wrote:
Mar 8th, 2017 10:30 pm
Can someone please help me? Trying to make sense of this thing.

I have a R7000 with XWRT Vortex and disabled ALG SIP and followed the instructions to the letter but I can't get incoming phone calls to work. Calling out works no problem.

I have also the Hitron Modem from Rogers CGN3ACR and have put it in Bridge mode, the last thing I haven't tried is port forwarding but I don't want to do that.

I've tried voip4.freephoneline.ca and same thing also. Each time I've rebooted the router, made sure it's fully up then ATA.

Forgot to mention I have a OBIHAI 200
I bolded a section below where I mention opening a ticket and requesting a "forced registration." I suggest doing that. Mention your incoming audio issue.



Did you use this PDF guide: http://forum.fongo.com/viewtopic.php?f= ... 404#p74404 (version 1.30)? Refer to pages 35 and 36 in it.

1. I'm uncertain that SIP Passthrough (that's what SIP ALG might be called in XWRT Vortex) needs to be disabled. It shouldn't if Vortex does the same thing as Asus firmware. You might want to try testing with SIP Passthrough enabled. In Asus default firmware, that's found under Advanced Settings-->WAN-->NAT Passthrough.


2. In your Obihai ATA or at Obitalk.com, Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort

X_UserAgentPort should be a random port number between 30000 and 65535. Just pick a port number in that range.

By using a high random port you help to thwart SIP scanners and may also circumvent a faulty SIP ALG feature in your router.

3) Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature.

4. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

5. If that doesn't work, you can also try enabling X_DetectALG (Navigate to Service Providers-->ITSP Profile (FPL)-->SIP)

(submit/save/reboot ATA)

6. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

7. If that still doesn't work, disable X_DetectALG. And submit/save/reboot ATA.

8. Try voip4.freephoneline.ca:6060

Refer to the underlined notes in section 7c on page 17 of the setup guide. That is, try voip4.freephoneline.ca for the ProxyServer and 6060 for the ProxyServerPort

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

voip4.freephoneline.ca:6060 is a SIP server whose purpose is to help those with SIP ALG issues (can't disable it in the user's router or gateway, for example).

11. Try this at your own risk: use voip3.freephoneline.ca for ProxyServer and 5060 for the ProxyServerPort
Refer to step 7c on page 17 of the setup guide.

voip3.freephoneline.ca is intended for testing purposes only--or for those who receive explicit permission to use it. Using it for an extended period may get your account banned. However, if using voip3.freephoneline.ca does work, you should open up a ticket with support and let them know that you can't get two-way audio any other way: https://support.fongo.com/anonymous_requests/new. For the issue type, select VoIP Unlock Key–>My Account Inquiry. Ask for a “forced account registration.”

If no one responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

FPL configures its SIP servers differently than many other VoIP providers.
voip3.freephoneline.ca conforms more to the norm. But using it without permission can get your account banned. If you'd like to avoid getting your account banned, then just skip to step #12.

12. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

13. If none of that helps, then, unfortunately, you're pretty much stuck with port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP.

14. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

15. This really shouldn’t be necessary, but it’s possible you may need to also port forward (from your router to your ATA) the UDP port you randomly selected in step #4. Retest afterwards.
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Deal Addict
User avatar
Jan 30, 2004
3210 posts
244 upvotes
Toronto
What is the best app that works with freephoneline on android?
Heatware

Go Portugal Go
Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
rui wrote:
Mar 9th, 2017 1:32 pm
What is the best app that works with freephoneline on android?
Keep in mind that FPL only allows one device registration per account at any time. The most recently registered device will ring. Others will not.
I use Acrobits' Groundwire with iOS. If I were using Android, I'd probably still use Groundwire, but I don't have a lot of experience using it on Android.


You're using Vortex, right, with a R7000? Maybe you can help Jeff146: freephoneline-ca-free-local-soft-phone- ... #p27552809
Last edited by Webslinger on Mar 9th, 2017 1:56 pm, edited 1 time in total.
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Deal Addict
Aug 5, 2002
3244 posts
90 upvotes
Toronto
Hi Webslinger,

Followed every step. Just wondering if anyone has the same setup with R7000 XVortex with Obihai 200. How did they get it to work?

I've tried with it on too but that was in the beginning so I might try it again.

What's the different with the forced registration? Might have to go that route.

Thanks,
Jeff


Webslinger wrote:
Mar 9th, 2017 8:41 am
I bolded a section below where I mention opening a ticket and requesting a "forced registration." I suggest doing that. Mention your incoming audio issue.



Did you use this PDF guide: http://forum.fongo.com/viewtopic.php?f= ... 404#p74404 (version 1.30)? Refer to pages 35 and 36 in it.

1. I'm uncertain that SIP Passthrough (that's what SIP ALG might be called in XWRT Vortex) needs to be disabled. It shouldn't if Vortex does the same thing as Asus firmware. You might want to try testing with SIP Passthrough enabled. In Asus default firmware, that's found under Advanced Settings-->WAN-->NAT Passthrough.


2. In your Obihai ATA or at Obitalk.com, Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort

X_UserAgentPort should be a random port number between 30000 and 65535. Just pick a port number in that range.

By using a high random port you help to thwart SIP scanners and may also circumvent a faulty SIP ALG feature in your router.

3) Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature.

4. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

5. If that doesn't work, you can also try enabling X_DetectALG (Navigate to Service Providers-->ITSP Profile (FPL)-->SIP)

(submit/save/reboot ATA)

6. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

7. If that still doesn't work, disable X_DetectALG. And submit/save/reboot ATA.

8. Try voip4.freephoneline.ca:6060

Refer to the underlined notes in section 7c on page 17 of the setup guide. That is, try voip4.freephoneline.ca for the ProxyServer and 6060 for the ProxyServerPort

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

voip4.freephoneline.ca:6060 is a SIP server whose purpose is to help those with SIP ALG issues (can't disable it in the user's router or gateway, for example).

11. Try this at your own risk: use voip3.freephoneline.ca for ProxyServer and 5060 for the ProxyServerPort
Refer to step 7c on page 17 of the setup guide.

voip3.freephoneline.ca is intended for testing purposes only--or for those who receive explicit permission to use it. Using it for an extended period may get your account banned. However, if using voip3.freephoneline.ca does work, you should open up a ticket with support and let them know that you can't get two-way audio any other way: https://support.fongo.com/anonymous_requests/new. For the issue type, select VoIP Unlock Key–>My Account Inquiry. Ask for a “forced account registration.”

If no one responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

FPL configures its SIP servers differently than many other VoIP providers.
voip3.freephoneline.ca conforms more to the norm. But using it without permission can get your account banned. If you'd like to avoid getting your account banned, then just skip to step #12.

12. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

13. If none of that helps, then, unfortunately, you're pretty much stuck with port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP.

14. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

15. This really shouldn’t be necessary, but it’s possible you may need to also port forward (from your router to your ATA) the UDP port you randomly selected in step #4. Retest afterwards.
Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
Jeff146 wrote:
Mar 9th, 2017 2:19 pm

Followed every step. Just wondering if anyone has the same setup with R7000 XVortex with Obihai 200. How did they get it to work?
zoob and Rui use Vortex:
any-good-wireless-router-deals-1861105/#p24307187
newegg-ca-obi200-39-99cad-obi202-59-99c ... #p24757439

I have also switched R7000 (horrible router for FPL) users over to vortex, and they're not having problems.
I've probably done that for over 10 people who are using FPL.

recommend-wireless-router-80-120-range- ... #p26816352
What's the different with the forced registration? Might have to go that route.
Freephoneline's customer service has never stated publicly what it does for forced registrations, but the premise is that
for the user's account, RTP audio is now handled similarly to how voip3.freephoneline.ca works, which is how it should be.
So, if anything, it's advantageous to have your account working that way.

That's the first thing I would do in your case (asking for a forced registration), in addition to trying voip3.freephoneline.ca:5060 (briefly, just to test).
Then I would also probably try resetting your router back to factory defaults using Vortex.

I would recommend reading through Mango's posts at http://forum.fongo.com/viewtopic.php?f= ... 74&#p66930 (a lot of the replies are noise), but you should read what Mango wrote.

R7000s cause the biggest headaches with FPL.
Last edited by Webslinger on Mar 9th, 2017 2:37 pm, edited 6 times in total.
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Deal Addict
User avatar
Jan 30, 2004
3210 posts
244 upvotes
Toronto
Webslinger wrote:
Mar 9th, 2017 1:56 pm
Keep in mind that FPL only allows one device registration per account at any time. The most recently registered device will ring. Others will not.
I use Acrobit's Groundwire with iOS. If I were using Android, I'd probably still use Groundwire, but I don't have a lot of experience using it on Android.


You're using Vortex, right, with a R7000? Maybe you can help Jeff146: http://forums.redflagdeals.com/freephon ... #p27552809
Yeah,I'm using Vortex(merlin) with R7000,so far so good, I set up obihai 200 via its website, I got two of them, I can check my settings after work, could not remember what I did now, had issue at the time with stock firmware as I remember.

My brother using WRT54GP2 and his voice is not clearly recently, I thought it would be good to set up on his android phone as he is traveling a lot.
Heatware

Go Portugal Go
Deal Fanatic
User avatar
Mar 3, 2002
7415 posts
2003 upvotes
rui wrote:
Mar 9th, 2017 2:39 pm
had issue at the time with stock firmware as I remember
Yeah, Netgear firmware causes problems.
My brother using WRT54GP2 and his voice is not clearly recently, I thought it would be good to set up on his android phone as he is traveling a lot.

Other than the fact Fongo Mobile's software wrapper isn't very good with some Android firmwares, the VoIP portion in Fongo Mobile is basically the same as Freephoneline. He could try the Fongo Mobile app. Also visit https://support.fongo.com/hc/en-us/arti ... l-Android- and https://support.fongo.com/hc/en-us/arti ... o-quality-

Choppy audio?

Generally speaking it's best to have a decent router for VoIP with strong QoS features.
Stick your ISP's modem in bridge mode, use your own router, and properly enable QoS for your ATA. Refer to your router's manual or contact your ISP if your router was provided by your ISP.

I'm not a big fan of this site, but for a general QoS description, visit http://www.voipmechanic.com/qos-for-voip.htm (avoid anything it says about G729 codec).

When you test below, pick the location that is closest to your VoIP service provider's server location.

1) The typical reaction would be to try enabling QoS properly in your router for your ATA. Refer to your router's manual.

2) Another possibility is you're dealing with congestion during prime time (8p.m. to 11 p.m., especially on Sundays). That's an ISP issue (possibly oversold its service in your area). With Rogers or a cable ISP, you could very well be dealing with local node congestion.

Try running http://myspeed.visualware.com/index.php at 8p.m. (especially on a Sunday).
You may be required to install BCS: http://www.visualware.com/bcs/index.html.

After visiting the link, choose North America-->Canada-->VoiP Server hosted provice (Freephoneline is Ontario)-->closest city (for Freephoneline, that's probably Toronto). And then select VoIP in the dropdown box on the right. A MOS score below 4.0 is bad news. It means call quality will not be good. The advanced (+) tab provides interesting info.

You should also try the winmtr test I mention in step 7c ii of the setup guide around 8 p.m. to the server you're using.

If the problem only occurs during prime time (as opposed to weekday mornings), then I would probably start thinking your ISP is to blame.

3) Another possibility is that your ISP uses poor routing tables to Freephoneline’s SIP servers. This usually causes pings to increase (not necessarily jitter). Large ISPs typically won’t do anything if you complain. Smaller ones might.


But no other devices are being used when I experience choppy audio!

A lot of people say that without realizing other devices and/or programs may actually be using bandwidth in the background. It's really not a good idea, in general, to be using a router that doesn't have a good QoS feature for VoIP.

But if what you claim is really true, then you may be dealing the possibility of congestion during prime time (8p.m. to 11 p.m., especially on Sundays). That's an ISP issue (possibly oversold its service in your area/local node congestion).

You should also try the winmtr test (or if you're on a MAC, maybe this helps): https://www.reddit.com/r/TagPro/comment ... tr_on_mac/

Again, if the problem only occurs during prime time (as opposed to weekday mornings) and especially Sunday evenings, then I would probably start thinking your ISP is to blame. Sunday evening is when everyone in your neighbourhood is home.
Last edited by Webslinger on Mar 9th, 2017 2:43 pm, edited 1 time in total.
Please do not PM me for assistance unless it's to reply to a PM I sent. I try to help when I can on the forums. Thank you. OBi200/202 Freephoneline setup guide can be found here (v. 1.32). Related OBi200 discussion can be found here. For OBi202, click here.
Deal Addict
User avatar
Jan 30, 2004
3210 posts
244 upvotes
Toronto
Jeff146 wrote:
Mar 9th, 2017 2:19 pm
Hi Webslinger,

Followed every step. Just wondering if anyone has the same setup with R7000 XVortex with Obihai 200. How did they get it to work?

I've tried with it on too but that was in the beginning so I might try it again.

What's the different with the forced registration? Might have to go that route.

Thanks,
Jeff
How did you set up your OBIhai 200? What's current problem now?I can check my settings after work as I'm using the same router,firmware(380.65) and obihai 200 with FPL.
Heatware

Go Portugal Go
Deal Addict
Aug 5, 2002
3244 posts
90 upvotes
Toronto
rui wrote:
Mar 9th, 2017 2:43 pm
How did you set up your OBIhai 200? What's current problem now?I can check my settings after work as I'm using the same router,firmware(380.65) and obihai 200 with FPL.
I setup the Obihai following the PDF. The problem is when I dial in, it waits a bit and then goes to voicemail. Did pretty much all the troubleshooting all the pdf other then forwarding.

I also have 380.65 and I have turned off SIP ALG. Do you have it off or on?

Thanks,
Jeff
Deal Addict
User avatar
Jan 30, 2004
3210 posts
244 upvotes
Toronto
Jeff146 wrote:
Mar 9th, 2017 4:00 pm
I setup the Obihai following the PDF. The problem is when I dial in, it waits a bit and then goes to voicemail. Did pretty much all the troubleshooting all the pdf other then forwarding.

I also have 380.65 and I have turned off SIP ALG. Do you have it off or on?

Thanks,
Jeff
Here is my settings
Images
Heatware

Go Portugal Go
Deal Addict
Aug 5, 2002
3244 posts
90 upvotes
Toronto
rui wrote:
Mar 9th, 2017 7:36 pm
Here is my settings
Ok I will try that setting when I get a chance tonight. Thank you.

And which server and settings did you use for the Obihai?
× < >
Rotate image Save Cancel

Top