Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Fanatic
Jun 7, 2005
8049 posts
513 upvotes
Thanks again.

Sorry, typo. I meant cordless phone set not "headset"
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
There appears to be have been an outbound call issue between 11:23 a.m. and 11:40 a.m. EST today. The problem has been resolved, or, at least, I can make calls.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
Jun 7, 2005
8049 posts
513 upvotes
My FPL is not ringing for incoming calls again........

I guess I need to try checking section B below. I am in my Network Router admin login page, how.where do I find "UDP Unreplied Timeout" ? Thanks
Webslinger wrote:
Nov 20th, 2018 1:35 pm
I mean that's one possibility (amongst a bunch of others that I touched on in my replies) you should check for. Login in at https://www.freephoneline.ca/showSipSettings, and check SIP Status and SIP User Agent.

If you see a device listed for SIP User Agent that you don't recognize, you've been hacked.
Registered devices ring for incoming calls. Unregistered devices don't, and the failover is having the call drop to FPL's voicemail system.

Regardless, I doubt that's the problem since you mentioned call logs. As I stated previously, "to me that sounds like a UDP timeout or NAT issue. I suspect point B below applies (the section I bolded). If you are unable to adjust UDP timeouts, then step D below probably, temporarily, resolves the problem."


B. Ideally, these conditions should be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)


< means less than

A problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often
180 by default in consumer routers): the NAT hole will close due to the ATA not communicating
frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA.


If you can't adjust UDP timeouts in whatever router it is that you're using, you can probably temporarily fix the issue by rebooting your devices in the order I outlined in Step D, in particular if FPL was working fine for incoming calls for you before (without you having made any changes to device settings in the interim).

D. That is, reboot your modem–>router (wait for it to be fully up and transmitting
data and for Wi-Fi SSIDs to populate)–>ATA (in that order).


I can't remember what brand and model router it is that you're using. I do remember that you're using an OBi200 ATA.
Typically it's far better to have your own router that allows you to adjust UDP timeouts, offers strong QoS functions, has a restricted cone NAT firewall, and
allows you to disable whatever SIP ALG feature is enabled in the router. Then, you can stick whatever modem/router combo your ISP gave you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers Hitron devices, visit https://www.rogers.com/customer/support ... ridgemodem.
Last edited by rdx on Nov 23rd, 2018 8:21 pm, edited 1 time in total.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
rdx wrote:
Nov 23rd, 2018 7:37 pm
My FPL is ringing again........

I guess I need to try checking section B below. I am in my Network Router admin login page, how.where do I find "UDP Unreplied Timeout" ? Thanks
There may not be that option in your router. Not all router firmwares offer the option to change UDP timeouts. Refer to #4 below.

What brand and model modem are you using? What brand and model router are you using?

Typically, for VoIP SIP services, you want

1) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed: https://asuswrt.lostrealm.ca/about.

2) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
http://www.voip-info.org/wiki/view/Routers+SIP+ALG (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

3) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and 4) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 10, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates.


Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well:
https://forums.redflagdeals.com/recomme ... #p28056619 (I've never used them and can't advise buying them or answer questions about them.)

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 10 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit please-sticky-how-bypass-bell-hub-use-y ... r-1993629/. For Rogers Hitron, visit https://www.rogers.com/customer/support ... ridgemodem.
Last edited by Guest1284983 on Nov 26th, 2018 12:21 pm, edited 1 time in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
Jun 7, 2005
8049 posts
513 upvotes
I am using the CGN3 Modem from CarryTel and my own old Netgear RangeMax Wireless Router
Webslinger wrote:
Nov 23rd, 2018 7:45 pm
There may find that option. Not all router firmwares offer the option to change them. Refer to #4 below.

What brand and model modem are you using? What brand and model router are you using?

Typically, for VoIP SIP services, you want

1) a router that does not have a full cone NAT,

Visit https://www.think-like-a-computer.com/2 ... es-of-nat/.
Mango from the Obitalk.com forums writes,
“Use a restricted cone NAT router, and do not use port forwarding or DMZ. Restricted cone NAT will only permit
inbound traffic from the service provider you're registered to. If you have a full cone NAT router, it will allow traffic
from any source. This is probably not what you intend.
If you have a Windows computer, you can test your router using the utility here:
http://www.dslreports.com/forum/remark,22292023. To run it, use stun stun.ekiga.net from a command prompt.”
Essentially, you download the stun-test.zip file; extract the stun.exe file from within the zip file to an easily
accessible location; use an elevated command prompt (visit
http://www.thewindowsclub.com/how-to-ru ... inistrator); change directory (cd) to the
directory or location where you extracted stun.exe (visit
http://www.digitalcitizen.life/command- ... c-commands); and type “stun stun.ekiga.net” without
the quotation marks followed by the enter/return button on your keyboard.
Asus routers, at the time of this writing, produce port restricted cone NAT routers, for example and are fine,
provided you’re using one with Asuswrt-Merlin, third party firmware installed: https://asuswrt.lostrealm.ca/about.

2) a router that lets you disable SIP ALG if it's buggy,

To understand why SIP ALG often causes horrible problems, please visit
http://www.voip-info.org/wiki/view/Routers+SIP+ALG (scroll down to the section on SIP ALG problems).

If you're dealing with a modem/router combo issued by an ISP or a router with SIP ALG forced on, you may have
to use voip4.freephoneline.ca:6060 for the Proxy Server. The purpose of voip4.freephoneline.ca:6060 is to circumvent
faulty SIP ALG features in routers.

3) a router that allows you to set QoS or assign highest priority to your ATA or IP Phone over all other devices on your LAN (local area network),

For a very general description of what QoS can do for you, visit https://www.voipmechanic.com/qos-for-voip.htm.
The basic idea is if you're torrenting or have a bunch of other computers, smartphones, tablets, etc. downloading and uploading (hogging all your available bandwidth), you don't want
your ATA not to have access to enough bandwidth to make or receive calls properly. So QoS or a Bandwidth Monitor feature (which is just another form of QoS) is a really good idea for VoIP users.

I often get an occasional relative complaining to me, "Hey my calls sound choppy." And then when I go visit, some kids are playing MMOs on a computer, while another person is downloading a huge file,
and another person is backing up files to a cloud service all at the same time someone else is trying to talk on the phone. All those devices, without QoS enabled, are fighting over available bandwidth along with the ATA.

and 4) A router that lets you adjust both Unreplied and Assured UDP timeouts.

Thanks to Mango, many of us now understand that in order for ATAs to remain registered and working properly with a VoIP SIP provider like Freephoneline, in particular after power failures, the following conditions must be met:

UDP Unreplied Timeout (in your router) < NAT Keep-alive Interval (in your ATA; for Obihai ATAs this is X_KeepAliveExpires) < UDP Assured Timeout (in your router) < SIP Registration Failure Retry Wait Time (or RegisterRetryInterval in Obihai ATAs)

“<“ means less than.

When a modem leases a new IP address, a problem can arise where prior associations using the old IP address are maintained in the router. When the ATA attempts to communicate using the old IP address, the response is unreplied, and then if the UDP Unreplied timeout is greater than the Keep Alive Interval (and UDP Unreplied timeout is often set to 30 by default in consumer routers) a problem arises where the corrupted connection persists. If UDP Unreplied timeout is, for example, 10, and the NAT Keep Alive Interval is 20, then the corrupted connection will timeout or close. A new connection will be created, and everything will work fine.

Another problem can occur when the Keep-Alive interval is greater than UDP Assured Timeout (often 180 by default in consumer routers): the NAT hole will close due to the ATA not communicating frequently enough with the SIP server. In turn, incoming calls may, intermittently, not reach the ATA. Again, X_Keepalives expires is supposed to be 20 with FPL.

(the above settings are making reference to those in Obihai ATAs)

Getting access to both UDP Unreplied Timeout and UDP Assured Timeout settings in consumer routers may be difficult, if not impossible. Asuswrt-Merlin (I would avoid any model below an RT-AC68U), third party firmware for Asus routers, does offer easy access to these two settings, which are found under General–>Tools-->Other settings. My understanding is that third party Tomato firmware has these two settings as well. So if your router supports Tomato firmware, that may be another option. Note that I will not be held accountable any damage resulting from failed firmware updates.


Apparently, Mikrotik routers also allow users to change both Assured and Unreplied UDP timeout settings as well:
recommendations-new-router-2115672/2/#p28056619 (I've never used them and can't advise buying them or answering questions about them.)

The keep alive interval for FPL is 20. The SIP Registration Failure Retry Wait Time is 120. I use 10 for UDP Unreplied Timeout and 117 for UDP Assured Timeout.



ISPs do not issue customers routers that can do all four things I just listed. Typically it's far better to have your own router with strong QoS functions and a restricted cone NAT firewall,
disable whatever SIP ALG feature is enabled in the router, and stick whatever modem/router combo your ISP gives you into bridge mode. For Bell Hubs, visit http://forums.redflagdeals.com/please-s ... r-1993629/. For Rogers Hitron, visit https://www.rogers.com/customer/support ... ridgemodem.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
Follow the steps 1-12 below, carefully in the order they are listed. Beyond this, there's nothing further that I am able to suggest until you get a decent router that meets the criteria I mentioned previously. I don't even see that QoS is an available feature in your router based on the manual: http://www.downloads.netgear.com/files/ ... 2Aug07.pdf. If that's true, your router is not ideal for SIP services.

Obviously step 12 appears to temporarily fix your problem. When you turn on devices, make sure you always turn them on in that order.
You may have to keep reboot when you have this problem until you get a router that does what you need.

CGN3 doesn't allow you to adjust UDP timeouts either.


Always check Registration Status in your ATA and at https://www.freephoneline.ca/showSip when you have problems with not receiving incoming calls. If your ATA is not registered with Freephoneline, it won't receive calls.

1.
a)Dial ***1. Enter the IP address you hear into a web browser.
b)Log into the ATA (default username and password are "admin" without quotation marks).
c)Navigate to Status-->System Status-->SP(FPL) Service Status

What does the registration status indicate?

2) Login in at https://www.freephoneline.ca/showSipSettings, and check SIP Status and SIP User Agent.

What does the registration status indicate?
If you see a device listed that you don't recognize, you've been hacked.


Your ATA needs to be registered, the SIP status needs to be connected, and if you see a SIP User Agent in your FPL account portal that you don't recognize, you've been hacked.


rdx wrote:
Nov 23rd, 2018 8:44 pm
I am using the CGN3 Modem from CarryTel

3. Put that in bridge mode: click https://www.rogers.com/customer/support ... emode-cgn3 (these instructions might also apply, but I'm not sure).
Enter the CGN3’s IP address (default 10.0.0.1) in the URL bar. The default login username is
admin, and the default password is password. Contact your ISP if need be.

"Select Basic.
Select the Gateway Function tab.
Select Residential Gateway Function.
Select Disable.
To finish, select OK when prompted."

and my own old Netgear RangeMax Wireless Router
Unfortunately, I'm unable to locate third party firmware that would allow you to adjust UDP timeouts in that router, and if the default firmware allows it, I don't don't see the option listed in the manual.
http://www.downloads.netgear.com/files/ ... 2Aug07.pdf

4. There's 3 different versions of that router. Select the right one at https://www.netgear.com/support/product/WPN824v3.aspx, and ensure that you're using the latest firmware for it.

5. Is SIP ALG disabled in your router? Please ensure that it is: https://www.obitalk.com/info/faq/sip-alg/disable-alg or https://kb.netgear.com/30796/How-to-dis ... -interface. If it's forced on in the router and impossible for users to disable, that's pretty bad.

6. . If you used the Obitalk web portal (www.obitalk.com) to configure your ATA, keep in mind that you must continue using it to configure your ATA. Otherwise whatever settings you change will eventually be overwritten by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour, dial ***1. Enter that IP address into a web browser. Navigate to System Management-->OBiTalk Provisioning-->select Disabled for the method. Save. Reboot ATA. Now obitalk.com won't overwrite whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not use both methods. Keep in mind that activating Google Voice requires using the Obitalk.com web portal.


Image
(In Obitalk.com, you will need to enable and enter expert settings to do the following, if you want to use Obitalk.com. You do this by selecting Edit Profile-->Advanced Options-->check Enable OBi Expert Entry from Dashboard-->submit)


Keep in mind too, that if you're using the Obitalk.com web portal, after you submit a new setting, it takes several minutes before Obitalk.com pushes the changes you've made to your ATA. Your ATA should reboot automatically after the changes are submitted.

7. Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
Pick a random number between 30000 and 60000

(submit/save/reboot)

8. Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature


(submit/save)

9. Navigate to Service Providers-->ITSP Profile (FPL)-->SIP
Try voip4.freephoneline.ca:6060 for ProxyServer

Refer to the underlined notes in section 14 of the PDF guide located here: http://forum.fongo.com/viewtopic.php?f= ... 805#p73839.
Also refer to the pic on page 21.

10. Ensure RegisterExpires is 3600

11. Ensure RegisterRetryInterval is 120

12. Proper device reboot order is always modem (wait for it to be fully up and running)-->router(wait for it to fully up and running with Wi-Fi SSIDs populated)-->ATA (in that order).
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Addict
User avatar
Feb 9, 2012
3531 posts
350 upvotes
Toronto
If I'm traveling out of the country and want to call from my phone via my FPL line.. Is it possible to?
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
cessnabmw wrote:
Nov 26th, 2018 4:13 pm
If I'm traveling out of the country and want to call from my phone via my FPL line.. Is it possible to?
There’s two methods:

1. Use a SIP app, like Groundwire, on your smartphone, and use regular cellular data (or use Wi-Fi) to make the call using your FPL account. You would need to configure/provision your FPL account in Groundwire (in this example).

This method may not be ideal since FPL’s servers are in Southern Ontario (pings and jitter may increase if you’re far away from southern Ontario).

You can't have your FPL account simultaneously registered in a SIP app (Groundwire) and in your ATA. Only the most recent registration will be valid. The older registration will not.

You may only register your FPL account on one device at any given time. Only one registration per FPL account is allowed at any time. The most recently registered device will ring for incoming calls. The previously registered device will not. Registration is required for incoming calls. Registration is not required for outgoing calls.


What I typically do is choose to not register my FPL account using Groundwire (I have the FPL account set to "Off -- Do Not Register" for incoming rings in Groundwire). I can then make then make an outbound call using Groundwire. But during that call period, inbound calls to the ATA will not work. When I end the call in Groundwire, inbound calls to the ATA work again. In Groundwire, under advanced settings for your FPL account, ensure you have disabled "Outgoing calls need registration."


You can also disconnect your ATA and just use Groundwire (register your FPL account in Groundwire) while traveling. Incoming calls to your FPL number would ring in Groundwire.



2. Dial into Obihai’s Auto Attendant, as described in the PDF guide, using regular cellular minutes to make outbound calls: http://forum.fongo.com/viewtopic.php?f= ... 805#p73839

You will be calling your FPL (or GV or any other number you have provisioned on your Obihai ATA) number and incurring any long distance fees with your cellular plan for the portion of the call between your cellphone and the Auto Attendant.
Last edited by Guest1284983 on Nov 29th, 2018 8:05 pm, edited 1 time in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
May 23, 2003
9377 posts
956 upvotes
GTA
I am using Freephoneline and having issues with using Obitalk200 to make outgoing calls. It works ok for 647 and 416 numbers but it doesn't seem to work for 905 number. I am using the dialplan from your PDF:

(1xxxxxxxxxx|011XX.S3|[2-9]xxxxxxxxx|*98|[2-9]11)

Any suggestion? When I call a 905 number it is silence and then after like 10 seconds it is a busy sound. It works fine to make calls on Zoiper or on Groundwire on two different devices.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
YLSF wrote:
Nov 29th, 2018 6:10 pm
it doesn't seem to work for 905 number . . . I am using the dialplan from your PDF:

That works perfectly fine at default settings, and 905 numbers are matched by [2-9]xxxxxxxxx



What does the ATA's call history indicate for the 905 number?

Also what does FPL's call history indicate?
https://www.freephoneline.ca/doGetCallLogs

Sigh, I hate dealing with people's Phone Port DigitMap's and Outboundcallroute's, but unless there's some issue involving Groundwire's push or Zoiper that I'm not aware of, that may be where your problem is. It takes forever for me to go through them.

Under Physical Interfaces-->Phone Port-->Digitmap and under Physical Interfaces-->Phone Port-->Outboundcallroute, what do you have listed?

You mention Obitalk. Have you been messing around with it lately? Is that what you use to configure your ATA?




It should make zero difference if you dial a 905 number. Are you positive that's the issue?
What happens if you dial (905) 896-2500 after completely disabling Groundwire (you shouldn't have to, but disable registration--and definitely disable push) and disabling Zoiper?


It really doesn't make any sense that you're suddenly having issues dialing 905 numbers after all these years. You must have changed something--or something happened with Obitalk (did 7 digit dialing enabled by accident?). Or it's something weird involving Groundwire or Zoiper. Actually, in Groundwire, in advanced settings for your FPL account, ensure you have disabled "Outgoing calls need registration." I'm not going to download Zoiper to check, but if there's a similar setting, ensure it's disabled as well.

For testing purposes, I would completely disable Groundwire and Zoiper, reboot the ATA, and then try dialing the 905 number again. Especially try dialing 905-896-2500 (Shopper's Drug Mart)
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
May 23, 2003
9377 posts
956 upvotes
GTA
Webslinger wrote:
Nov 29th, 2018 7:56 pm
That works perfectly fine at default settings, and 905 numbers are matched by [2-9]xxxxxxxxx
Thanks for the responses. I am at home now and don't have the device with me (was using it at work because my new internet service ported over my number prior to the new internet working correctly for our regular office lines!).

I checked the Freephoneline logs and those calls to the 905 numbers don't show up. To clarify, the calling to 905 numbers work fine on Groundwire and Voiper. I did try to exit out of both apps (I am running them on two different phones) before using the ATA. I meant that my ATA is a OBi200. I accidently said Obitalk but I don't use the Obitalk interface for any settings.

I had a different call plan in there before but today I changed it to yours because I thought maybe there was something messed up with that when I couldn't call the 905 numbers. I did reboot as per the instructions on the interface just in case. I tried 4 different 905 numbers and none of them worked but the 416 and 647 numbers worked (when calling from the ATA). Tomorrow I will try the Shoppers Drug mart number you provided. I also have an old Linksys ata so I might try to see if that one will register and work.

I haven't used the ATA a lot so there is a possibility that there has been an issue for a while (I.e. I can't confirm the last time calling a 905 number worked.. usually I use it more for incoming calls or when I am using voip software).

I will check through the other items you mentioned in the morning. Thanks again for replying!
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
YLSF wrote:
I checked the Freephoneline logs and those calls to the 905 numbers don't show up.
Then the call isn't even being sent through/reaching FPL.

The call history in the ATA may be more useful.
To clarify, the calling to 905 numbers work fine on Groundwire and Voiper.
I understand that.

I did try to exit out of both apps (I am running them on two different phones) before using the ATA.
That's not good enough if push is enabled and/or if "outgoing calls need registration" is also enabled. Again, disable push, and in Groundwire, in advanced settings for your FPL account, ensure you have disabled "Outgoing calls need registration." If Zoiper has a similar setting, also disable it. I would completely disable registration for both apps. Make sure neither can receive incoming calls while you're having this problem.
(I would also delete Zoiper, if you own Groundwire; I fail to see the need to have both installed, at least).

I had a different call plan in there before but today I changed it to yours
Mine works at default settings. The PDF guide is based on the ATA being at factory defaults. I doubt your settings were at defaults.
yours because I thought maybe there was something messed up with that when I couldn't call the 905 numbers
I wonder whether you needed to do that. Instead, I wonder if it's an issue with having "Outgoing calls need registration" enabled in Groundwire and/or Zoiper while having push/registration enabled in both apps. Only one registration per FPL account is allowed at any time. I suspect registration is being traded back and forth between Groundwire and the ATA at each registration interval, and with "outgoing calls need registration" enabled in Groundwire's advanced settings--even if you have "Off - Do Not Register" selected for FPL's account in Groundwire--each time you try to make a call using Groundwire, you're forcing Groundwire to register your FPL account again even if you don't want to use Groundwire for incoming calls. I could see port associations becoming corrupted between a router and the ATA.


Regardless, when you dial 905-123-4567, it first must be matched properly (or validated) in the Phone Port's digitmap. So, your Phone Port's digitmap needs [2-9]xxxxxxxxx in it.

Then remember that the outboundcallroute is processed from left to right.

Let's say the Phone port's outboundcallroute is (just as an easy example)
{(Msp1:sp1},{(Msp2):sp2}

M stands for Digitmap

Let's say SP1 is FPL.

So, the ATA first checks the phone port's digitmap (FPL's digitmap is an extension of the phone port's digitmap), which needs [2-9]xxxxxxxxx in it.
Once 905-123-4567 is also validated/matched by FPL's digitmap, the call is sent out over SP1, which, in this case is FPL.

But let's say FPL's digitmap (Msp1) doesn't contain [2-9]xxxxxxxxx or any rule that matches 905-123-4567. Then the call can't go out over (won't be completed by) SP1.
The ATA will then check if 905-123-4567 can be matched by ITSP Profiles B's digitmap (Msp2). If 905-123-4567 is matched by a rule ([2-9]xxxxxxxxx), then the call goes out over SP2.

And so on, down (or across, I guess) your outboundcallroute from left to right. So when you dial any phone number, 3 things need to be correct: the phone port's digitmap, the phone port's outboundcallroute, and the ITSP's digitmap. Again, I absolutely hate troubleshooting other people's dialplans; it's a lot of work for me. If you have some dialplan where you have 905 calls being sent out via another ITSP, that may also be a problem.

Oh, and also check under Physical Interfaces-->Phone Port to ensure the PrimaryLine is set to FPL.


So, I see two potential issues: Groundwire/Zoiper or your dialplan. It seems less probable that you've had issues calling 905 numbers all this time, but sure, that's possible (and harder for me to fix). The only thing new being introduced, I would guess, is Groundwire, and in that case, "Outgoing calls need registration" needs to be disabled.
Last edited by Guest1284983 on Dec 7th, 2018 6:01 am, edited 6 times in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
May 23, 2003
9377 posts
956 upvotes
GTA
Webslinger wrote:
Nov 29th, 2018 8:44 pm

So, I see two potential issues: Groundwire/Zoiper or your dialplan. It seems less probable that you've had issues calling 905 numbers all this time, but sure, that's possible (and harder for me to fix). The only thing new being introduced, I would guess, is Groundwire, and in that case, "Outgoing calls need registration" needs to be disabled.
Ok, I have read the whole post, thanks for the detailed explanation. I have Groundwire on one device and Zoiper still on another phone just to compare the two but I don't have either run in the background right now. I will do as you suggested to disable both of them though. I was thinking I will try to call another area code that starts with a 9 tomorrow just out of curiosity. Worse case, I have a second OBI200 new in box that I haven't setup yet so I could try to reset it up with FPL following your guide from start to finish and see what happens on that one.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3275 upvotes
YLSF wrote:
Nov 29th, 2018 11:12 pm
I have Groundwire on one device and Zoiper still on another phone just to compare the two but I don't have either run in the background right now.
When Push is enabled in a SIP app, your SIP account (FPL) is still being registered on third party servers even when the app isn’t running. With push enabled, you can completely exit the app and incoming calls with still ring.

1. In Groundwire, for the account(s) (edit account menu) in question, select "Off -- Do Not Register" for incoming calls.

2. There's also a global setting (found under settings-->Incoming calls), which will affect your accounts if they're set to use to the global setting for incoming calls. So you may need to change that to “Off — Do Not Register” as well.

3. Additionally, "Outgoing calls need registration" needs to be disabled in Groundwire (Edit Account—>Advanced Settings).

If you attempt more than 5 registrations within 5 minutes, you may be temporarily IP banned from the FPL SIP server you are attempting to register with:

https://community.freepbx.org/t/trunk-s ... ca/22479/8

"As May 2013, our servers will rate limit REGISTER requests to a maximum of 10 requests per 5 minutes. Each authentication round usually consumes 2 requests (digest auth), so it is a fair number given our guidelines. Also, it does not affect INVITES (which are also authenticated)...

This rate limit is applied per IP address as our service is tailored to residential Canadian users (ADSL/Cable). "


With SIP, registration is a requirement for incoming calls. Without registration, incoming calls simply don't work. While strict SIP compliance allows for multiple account registrations, for call flow troubleshooting and treatments, some of the better known SIP service providers in North America only allow one registration per account and require the use of sub accounts (VoIP.ms, for example) if you want to register multiple devices (FPL doesn’t offer sub accounts).
Regardless, each new registration using the exact same SIP credentials overwrites the previous registration (this is also true with FPL). That is, only the most recent, successful active registration is valid--and, in turn, only the most recently registered device or app will ring for incoming calls. When two devices or apps are configured with the same SIP credentials, in this example, registration attempts will occur independently between them, forcing registration (that's valid as reported by the service provider) to swap back and forth between devices or apps, based on registration timers. The device or app that rings is the one that has most recently registered. It may not be apparent when registration occurs with a SIP app (many users may erroneously feel that the most recently opened app, or one where settings have just been saved, equates to the app that has made the most recent registration attempt), but the one that rings is the one that has the most recent, successful (active) registration with the account in question.

With “Outgoing calls need registration” enabled, you’re now making registration a requirement for outbound calls as well. Each time you make a call in Groundwire, you’re forcing a registration attempt if FPL isn’t already registered in Groundwire.

And then with Push enabled, your FPL account is still being registered even if the app isn’t running.




If you discover the problem still occurs after completely disabling Groundwire and Zoiper, then we need to look at your call status in the ATA (and possibly the call history after the call attempt is made) while the call is occurring. And you'd need to provide the ITSP digitmap, the phone port's digitmap, and the phone port's outboundcallroute. Lastly I would want to see what the SIP status and SIP user agent indicates after logging in at https://www.freephoneline.ca/showSipSettings.
Last edited by Guest1284983 on Nov 30th, 2018 10:36 am, edited 1 time in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
May 23, 2003
9377 posts
956 upvotes
GTA
Webslinger wrote:
Nov 30th, 2018 2:45 am
When Push is enabled in a SIP app, your SIP account (FPL) is still being registered on third party servers even when the app isn’t running. With push enabled, you can completely exit the app and incoming calls with still ring.
Thanks again for the response. I was aware that FPL coiuld only be registered to one account at a time and I had it set not to register on both apps when making outgoing calls but it turns out that I had activated the "push" servivce for incoming calls on Groundwire so I changed that and I actually disabled that account for now too as an added check. I also disabled the account in Zoiper. I found out that the problem with my ATA went behind calling 905 numbers because went I called a 902 Shopper's Drug mart (good idea for test numbers BTW!) it didn't work and then I tried other 416 numbers beside my cell and it didn't work but 647 numbers worked. So I hooked back up my Linksys Pap2 and it is working fine for the outgoing calls I tested including the Halifax/902 number. I waited a bit and tried again and seems fine for outgoing calls. So, I am going to setup my 2nd brand new in box OBI200 which I bought ages ago from Newegg and see if I can get it working from scratch. I must have messed something up bad with the config file on the original one and not noticed or thought it was a temp glitch when I tried to infrequently use the actual phone for outgoing calls (it was backup for my office landline and cell). BTW, the call didn't even show up as "last time" dialed. I didn't get around to finding where the full call logs were but I will try to remember to check that out of curiosity before I flash that one.

I am confused by one thing in your various posts. The PDF guide you have for FPL doesn't mention the latest firmware but mentions some other firmwares where the guide will work in. I assume it will work fine with 3.2.2 (Build: 5921EX) and it just hasn't been updated yet. Is that what you recommend people to use for firmware on the OBI200? I see there is a modded version available as well but I don't think I need anything on the modded version right now (i.e. sounds like it is for Google Voice use but I don't even know if that works on the obi200). On this post - 3.2.2 (Build: 5921EX) there is mention of OBI not allowing people to manually update to the latest firmware on the devices. Does that mean you can updated to 3.22 build 5921EX but not beyond that ? Or does it mean that updating to this build even doesn't work. I wasn't sure what that meant. Before I flash anything I wanted to check with you. After I get this brand new in box one up and running I will probably go and factory reset/firmware flash the other one.

Top