Cell Phones

Google call screening now works for Canada!

  • Last Updated:
  • Mar 19th, 2019 2:55 pm
Tags:
None
[OP]
Deal Expert
User avatar
May 22, 2005
18987 posts
4099 upvotes
Thornhill

Google call screening now works for Canada!

Have to opt into the Phone dialer beta but it works really well.
13 replies
Member
User avatar
Aug 19, 2018
445 posts
391 upvotes
coriolis wrote:
Mar 15th, 2019 12:36 pm
Have to opt into the Phone dialer beta but it works really well.
Which phone are you using?
[OP]
Deal Expert
User avatar
May 22, 2005
18987 posts
4099 upvotes
Thornhill
Cucumference wrote:
Mar 15th, 2019 1:41 pm
Which phone are you using?
Pixel 2 xl

Looks like it's only available for Google Pixel phones. Sorry I got too excited!
Member
User avatar
Aug 19, 2018
445 posts
391 upvotes
coriolis wrote:
Mar 15th, 2019 2:09 pm
Pixel 2 xl

Looks like it's only available for Google Pixel phones. Sorry I got too excited!
Figured as much, it still counts as available. You are not wrong.
Deal Expert
User avatar
Mar 18, 2005
18367 posts
1805 upvotes
Niagara Falls
Crap, looks my original pixel doesn't get it. Booo. Oh well, back to my S9 I suppose
[OP]
Deal Expert
User avatar
May 22, 2005
18987 posts
4099 upvotes
Thornhill
Evil Baby wrote:
Mar 15th, 2019 4:58 pm
Crap, looks my original pixel doesn't get it. Booo. Oh well, back to my S9 I suppose
Try it anyways.

Opt in here: https://play.google.com/apps/testing/co ... n?hl=en-GB

Make sure under Languages in settings that English (Canada) is on the list

Uninstall your phone dialer app.

Restart phone.

Install phone updates in play store, make sure it says (beta)

Restart phone.

Go to settings in the phone app, see if call screening shows up. If not , wait an hour or so as try again.

Hope it works for you
Deal Expert
User avatar
Mar 18, 2005
18367 posts
1805 upvotes
Niagara Falls
coriolis wrote:
Mar 15th, 2019 5:32 pm
Try it anyways.

Opt in here: https://play.google.com/apps/testing/co ... n?hl=en-GB

Make sure under Languages in settings that English (Canada) is on the list

Uninstall your phone dialer app.

Restart phone.

Install phone updates in play store, make sure it says (beta)

Restart phone.

Go to settings in the phone app, see if call screening shows up. If not , wait an hour or so as try again.

Hope it works for you

Got the beta installed. Nothing yet, but will give it a better look tonight when I have more time.

Thanks for the links.
Deal Expert
User avatar
Dec 12, 2009
17686 posts
6228 upvotes
Toronto
How is this different from caller ID and spam screening in the android dialer?
Koodo $40/6GB
Public Mobile 2016 fall promo, $23/1GB, $40/5GB
Fido $7.50/3GB+tablet
Rogers $25 500U home internet
Tangerine Bank
Deal Expert
User avatar
Mar 18, 2005
18367 posts
1805 upvotes
Niagara Falls
will888 wrote:
Mar 16th, 2019 12:26 am
How is this different from caller ID and spam screening in the android dialer?
This is very much different. It actually answers the phone for you and will have a basic convo. It will display on your screen what the other caller is saying.



Sadly it's still not working on my Pixel.
Member
User avatar
Sep 23, 2013
361 posts
274 upvotes
Vancouver, BC
Thanks for intel OP. Never woulda known if it werent for this thread. Here's hoping it works
[OP]
Deal Expert
User avatar
May 22, 2005
18987 posts
4099 upvotes
Thornhill
Evil Baby wrote:
Mar 16th, 2019 4:04 pm
This is very much different. It actually answers the phone for you and will have a basic convo. It will display on your screen what the other caller is saying.



Sadly it's still not working on my Pixel.
Have you tried making English (Canada) the main language? It's in settings/language input/language

Make sure it's the 1st one, restart phone.


I've used it a handful of times and it's super useful for unknown callers.

Top

Thread Information

There is currently 1 user viewing this thread. (0 members and 1 guest)