Site Comments & Suggestions

'Keep me logged in' does not work?

  • Last Updated:
  • Feb 14th, 2018 11:19 am
Tags:
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto

'Keep me logged in' does not work?

Hello,

What I've noticed is that when I'm using an actual computer with Google Chrome and I click 'Keep me logged in' it retains my information and I don't have to login once again to post on RFD.

However, when I'm using Safari on an iPhone or iPad and click 'Keep me logged in' it never seems to remember and I always have to re-enter my login information.

Any ideas other than using the RFD app?

Thanks.
11 replies
Moderator
User avatar
Aug 20, 2009
6540 posts
1202 upvotes
Grimsby
Are you browsing in Private Mode? It sounds like it. I've seen cases where it gets set by default somehow, so every tab session opened is a Private session. This prevents sites from setting cookies and/or clears them when you exit.

Here is a link with pics on how to fix it. My GF had this problem on her Macbook. We don't have an iPad so I can't help with that one.
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
Redmask wrote:
Feb 12th, 2018 3:19 pm
Are you browsing in Private Mode? It sounds like it. I've seen cases where it gets set by default somehow, so every tab session opened is a Private session. This prevents sites from setting cookies and etc.

Here is a link with pics on how to fix it. My GF had this problem on her Macbook. We don't have an iPad so I can't help with that one.
Thanks for the reply.

I am pretty sure I am not browsing in private mode as the interface looks different (all black) however I will look into it to make sure.
Moderator
User avatar
Aug 20, 2009
6540 posts
1202 upvotes
Grimsby
Does it let you login OK and it just resets after you exit? Or you can't login at all on those machines?

Edit: Here is a link with some stuff to try with regards to cookie settings.
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
Yes correct.

Of course now when I try to replicate the problem on my iPhone it works with no issues. :facepalm:

I will try at home on my iPad.
Administrator
User avatar
Jun 17, 2013
9487 posts
14205 upvotes
Scarborough
Do you have any other browsers on your mobile devices to try? If yes do they also experience this issue?
RFD Staff [Forum Rules] [Facebook] [Twitter].
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
TomRFD wrote:
Feb 12th, 2018 4:35 pm
Do you have any other browsers on your mobile devices to try? If yes do they also experience this issue?
I haven't given any other browser a try... just Safari in iOS

I had indicated earlier that I couldn't replicate the issue, however I can confirm that I loaded up RFD again on my iPhone and I had to input my login & pw once again.

So odd.
Administrator
User avatar
Jun 17, 2013
9487 posts
14205 upvotes
Scarborough
marcsterr wrote:
Feb 12th, 2018 5:17 pm
I haven't given any other browser a try... just Safari in iOS

I had indicated earlier that I couldn't replicate the issue, however I can confirm that I loaded up RFD again on my iPhone and I had to input my login & pw once again.

So odd.
If you don't mind installing another mobile browser that could help tell us whether it's a Safari issue or not.
RFD Staff [Forum Rules] [Facebook] [Twitter].
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
TomRFD wrote:
Feb 13th, 2018 12:04 pm
If you don't mind installing another mobile browser that could help tell us whether it's a Safari issue or not.
No problem, I'll do that and report back.
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
TomRFD wrote:
Feb 13th, 2018 12:04 pm
If you don't mind installing another mobile browser that could help tell us whether it's a Safari issue or not.
I installed Firefox for iOS... it seems to be okay in retaining my login information.

My guess is it seems to be only Safari on iOS. Just to recap it happens on my iPhone & iPad both running iOS 11.2.5.

The RFD app works fine though.

Wonder if anyone else can replicate the issue through Safari?
[OP]
Deal Addict
User avatar
Apr 24, 2003
2244 posts
334 upvotes
Toronto
So I ended up restoring my iPhone and can confirm all is well. I don’t think this is a widespread issue but specific to my device. Thanks anyway for the help!
Administrator
User avatar
Jun 17, 2013
9487 posts
14205 upvotes
Scarborough
marcsterr wrote:
Feb 14th, 2018 12:15 am
So I ended up restoring my iPhone and can confirm all is well. I don’t think this is a widespread issue but specific to my device. Thanks anyway for the help!
Glad to hear that fixed the problem. Not entirely sure what was causing the problem but it does give us something to go off of at least.
RFD Staff [Forum Rules] [Facebook] [Twitter].

Top