Site Comments & Suggestions

New "Dark Mode" for RFD Forums

  • Last Updated:
  • Jan 5th, 2018 11:11 pm
Tags:
None
Sr. Member
Feb 8, 2015
870 posts
340 upvotes
North York, ON
Also noticed last 2 days Store logo is a white blank. Previous 3? weeks was getting Post #39 error. Have now disabled Dark Mode.
As far as Blue Light I use https://en.wikipedia.org/wiki/F.lux Really does help when night arrives.
Deal Addict
User avatar
Sep 13, 2006
2354 posts
1058 upvotes
Muskoka
^^^ +1 ^^^
Koodo
Public Mobile
RFD Alumnus
User avatar
Mar 8, 2015
66 posts
35 upvotes
Toronto, ON
Hey, I've just updated Dark Mode with a few fixes; you can find it here.
  • Fix the retailer filter links being white on white
  • Lighten the UCP hidden topics for more readability
  • Darken the hide topic button

FYI the multiple arrows bug (#39) is the result of a problem on the main stylesheet. A fix has already been prepared, but won't be released until at least next week. In the meantime, Peroxide's fix should work in the interim. Sorry for the inconvenience!
For inquiries, please message TomRFD.
Deal Expert
User avatar
May 22, 2005
18833 posts
3949 upvotes
Thornhill
dsinnyp wrote:
Jul 26th, 2017 5:59 pm
Hey, I've just updated Dark Mode with a few fixes; you can find it here.
  • Fix the retailer filter links being white on white
  • Lighten the UCP hidden topics for more readability
  • Darken the hide topic button

FYI the multiple arrows bug (#39) is the result of a problem on the main stylesheet. A fix has already been prepared, but won't be released until at least next week. In the meantime, Peroxide's fix should work in the interim. Sorry for the inconvenience!
Image
Deal Fanatic
Apr 8, 2013
8060 posts
279 upvotes
This is amazing. Smiling Face With SunglassesSmiling Face With SunglassesSmiling Face With Sunglasses
#Torontostrong
Diversity Is Our Strength 😎
Sr. Member
Feb 8, 2015
870 posts
340 upvotes
North York, ON
Working perfectly now. Thanks very much.
Member
User avatar
Mar 2, 2008
407 posts
325 upvotes
BC
Just updated to the latest version of Firefox and started experiencing a minor issue. Sometimes the dark mode stylesheet doesn't load and I get the standard white screen. If I refresh the screen, it almost always does load properly. This consistently occurs if I right click a link in a forum and 'open link in new tab'.

Firefox 57.0, 64-bit
Windows 10 OS
Stylish 3.0.1

Anyone else with this issue?
Member
User avatar
Mar 2, 2008
407 posts
325 upvotes
BC
After further testing, I can recreate this issue 100% of the time.

1. Click refresh page (or F5) and immediately switch to another tab (doesn't work if you switch windows)
2. Wait for that page to load before going back to it, and the page will show the default white style

Another way is to right click on a link and open in a new tab. Step 2 must also be done in this case.

If you refresh a page and stay on that page, it will render the dark mode style. Same if you open a new tab, immediately switch to that tab and wait until it loads.
Member
User avatar
Mar 2, 2008
407 posts
325 upvotes
BC
aviador wrote:
Nov 17th, 2017 12:56 pm
Does the navigation protocol remain the same either http all the time / https all the time? or are your pages loading some in http and others in https?
Stays the same. I can recreate on http and https
Newbie
Dec 7, 2017
1 posts
Very nice features, it's nice to not strain my eyes when I look through some deals at night, good job :)
Deal Addict
Jun 12, 2015
1958 posts
568 upvotes
Ontario
Can the rfd app get dark mode yet? (not the forum app)
Deal Addict
User avatar
Dec 28, 2007
4255 posts
878 upvotes
Alberta
MrDisco wrote:
Sep 15th, 2016 3:43 pm
Please consider making this a forum setting in the future! :) (for those of us who can't install web scripts)
...or don’t want to.
Deal Addict
Jun 12, 2015
1958 posts
568 upvotes
Ontario
My dark mode gets the following colours when I use the middle of my mouse to open one a new tab (forums etc).

To get it back to normal dark mode, I have to refresh the page.

Is there a patch or fix for this? Anyone else get this as well?

Using Firefox version 7.0.3 (64-bit)
Images
  • Capture.JPG

Top