Expired Hot Deals

[Lenovo Canada] Not sure Price Error? ThinkPad: T series upgrade to Intel Core i7-2860QM Processor

  • Last Updated:
  • Dec 8th, 2015 4:59 pm
Tags:
None
Member
Oct 31, 2006
455 posts
146 upvotes
xla4life wrote:
Mar 5th, 2012 2:39 pm
I am using a brand new OCZ Agility 3 120GB SSD and a fresh install of Win7.

Everything is blazing fast until I started using uTorrent. During downloads, the system would get "jittery" (freeze for a few seconds at a time).

Anybody have any ideas of what this means?

Same here....
Sr. Member
Feb 15, 2007
511 posts
45 upvotes
Toronto
goodfortune wrote:
Mar 5th, 2012 6:17 pm
Just download Daz Windows Loader v2.1.1 to activate your Windows 7:

http://forums.mydigitallife.info/thread ... nformation

The Daz Windows Loader will only insert the official Lenovo Win7 key and certificate to your system, just like Lenovo does. If yours T520 is Windows 7 Home Premium, it will insert the following key: 27GBM-Y4QQC-JKHXW-D9W83-FJQKD

All our T520 with Windows Home Premium were pre-installed using this key: 27GBM-Y4QQC-JKHXW-D9W83-FJQKD, not the key (COA) from the windows sticker beneath the battery.

Read the Super Moderator - urie's explanation here:
http://forums.mydigitallife.info/thread ... remium-OEM

Waoooo thanks goodfortune,

did use the Daz Windows Loader and bam Windows sure shows as activated now.
Thanks for the help, saved me a lot of time doing the UEFI thing all over again with different iso file and who knows if it would have worked this time...
Thanks given as well!!!
Deal Addict
Oct 5, 2008
1443 posts
498 upvotes
chocho111 wrote:
Mar 5th, 2012 6:49 pm
Waoooo thanks goodfortune,

did use the Daz Windows Loader and bam Windows sure shows as activated now.
Thanks for the help, saved me a lot of time doing the UEFI thing all over again with different iso file and who knows if it would have worked this time...
Thanks given as well!!!

Glad it helped.
Deal Addict
Jul 3, 2001
1334 posts
38 upvotes
customer1 wrote:
Mar 5th, 2012 3:50 pm
Have you added extra 4GB memory? They are related.

Upgraded to 16GB of RAM and my WEI is now:

Processor Intel(R) Core(TM) i7-2860QM CPU @ 2.50GHz 7.6
Memory (RAM) 16.0 GB 7.6
Graphics Intel(R) HD Graphics Family 6.5
Gaming graphics 1696 MB Total available graphics memory 6.5
Primary hard disk 57GB Free (112GB Total) 7.9
Sr. Member
Feb 15, 2007
511 posts
45 upvotes
Toronto
OK after installing my new mSATA as primary drive and finishing Win7 install on it here are my updated WEI results:


CPU - 7.5
RAM - 7.8
Graphics - 6.5
Gaming graphics - 6.5
HDD - 7.2


Same as before with only the HDD jumping from 5.9 to 7.2
I've update my Nvidia driver to 295.73
Quite happy with those results....now onto customizing my machine :D
Member
Sep 1, 2006
340 posts
14 upvotes
Toronto
davewxw wrote:
Mar 5th, 2012 5:13 pm
have you tried this ultrabay? and do u mind posting a link? thank you!

Haven't received it yet.
Pictures are here :
http://forum.notebookreview.com/lenovo- ... ad-62.html
Ebay store is here :
http://www.ebay.com/sch/ny-compu-tek/m. ... ksid=p3686

I got that model specifically because it is supposedly SATA 3 compatible. I'm thinking of just waiting for it to put the SSD in there instead of switching the HDD with the SSD in the main bay.

Another company called newmodeus makes a recommended one as well but it's 40$+.
Newbie
Mar 14, 2008
23 posts
4 upvotes
Kevin31415 wrote:
Feb 29th, 2012 8:21 pm
aircobra wrote:
Feb 29th, 2012 11:25 am
maybe the deal for CORSAIR 16GB (2 x 8G) 204-Pin DDR3 SO-DIMM DDR3 1333 Laptop Memory in this NE's promotion is better?
http://promotions.newegg.ca/NEemail/pro ... -PromoWord
I received an email today from newegg with this promotion as well. I couldn't resist and placed an order. Total comes to $129.71 (including taxes & free shipping with this promo). I hope this memory is compatible with the T520, returning stuff bought online is always a big pain.
I received my 16GB of RAM from Newegg today. So far so go. Windows booted fine with 16GB and everything seemed okay after a short test. I am currently running a memtest86+ test and so far there are no errors there either. :)
Deal Addict
Jul 3, 2001
1334 posts
38 upvotes
Kevin31415 wrote:
Mar 5th, 2012 9:16 pm
I received my 16GB of RAM from Newegg today. So far so go. Windows booted fine with 16GB and everything seemed okay after a short test. I am currently running a memtest86+ test and so far there are no errors there either. :)

Same here. It was a bit scary getting the keyboard off to replace the existing 4GB module though. :)
Deal Fanatic
User avatar
Jul 18, 2003
6267 posts
58 upvotes
Etobicoke
rycckor wrote:
Mar 4th, 2012 10:17 pm
Why did they take off another $10?

I told the cashier she's really hot. :razz:

But seriously. The BB offier is $20 off of a WiDi receiver or $30 off WiDi receiver if you by an Ultrabook as well. The cashier glanced at the deal description really quickly and told me I get another $10 off.

How can I refuse???
Deal Addict
Oct 5, 2008
1443 posts
498 upvotes
Is there an official receipt or invoice we will get for the Lenovo T520?
Member
May 25, 2007
388 posts
82 upvotes
Edmonton
goodfortune wrote:
Mar 5th, 2012 9:30 pm
Is there an official receipt or invoice we will get for the Lenovo T520?

Received an envelope in the mail today with the invoice.
Newbie
Oct 22, 2009
14 posts
2 upvotes
antonbrk wrote:
Mar 5th, 2012 1:17 am
Same. Have run all updates and reran WEI with BIOS setting at "Discreet Video Card" as well as "Optimus", always the same 5.2 and 6.5 for the 2 graphics scores. No idea why 5.2 for Windows Aero graphics score but others 6.5. However, what I haven't done is download NVS4200 driver from NVidia website. Have to try that next.
Same here. I've installed the newest driver though and still not getting the 6.5 for windows aero for some reason. I've uninstalled/reinstalled the driver ccleaner in between and no love. Not sure why.
Deal Addict
May 13, 2005
2921 posts
2881 upvotes
Montreal
bhazard1 wrote:
Mar 5th, 2012 10:00 pm
Same here. I've installed the newest driver though and still not getting the 6.5 for windows aero for some reason. I've uninstalled/reinstalled the driver ccleaner in between and no love. Not sure why.
Are you guys having FHD 1920x1080 LCD screen?

May be we should ask if anyone able to get 6.5 for this T520 FHD 1920x1080 LCD screen...

Or if you get 6.5 for graphic then what is your system like

RAM 4GB or >= 8GB
Hard disk slow 5400RPM, 7200RPM or SSD...
Newbie
Oct 22, 2009
14 posts
2 upvotes
X360 wrote:
Mar 5th, 2012 10:10 pm
Are you guys having FHD 1920x1080 LCD screen?

May be we should ask if anyone able to get 6.5 for this T520 FHD 1920x1080 LCD screen...

Or if you get 6.5 for graphic then what is your system like

RAM 4GB or >= 8GB
Hard disk slow 5400RPM, 7200RPM or SSD...
1600 by 900 screen
Hard disk SSD upgrade from lenovo Intel 160 GB
Stock 4gb ram
× < >

Top