Cell Phones

Speakout Now Sucks. Recommendations?

  • Last Updated:
  • Jan 12th, 2019 12:29 am
Deal Guru
User avatar
Jun 12, 2007
14212 posts
3557 upvotes
London
Philbert wrote:
Oct 13th, 2018 9:56 am
I’ve spoken Apple and Speakout numerous times. Apart from a complete reset and restore no one has a solution that works. I can send messages to non-iPhones no problem. Ican put my Koodo sim in the nonworking phone and it then works.
I’m going to switch my sons to Koodo. $15 a month plus $20 bonus and 100 booster minutes. What bugs me, though, is that it cannot be linked with current my account because it’s prepaid.
You have to go thru the existing threads on iMessage activation on Speakout/Petro Can.

From what I remember at the time, SMS short codes are needed. Speakout/Petro does not support these, therefore iMessage can't be used on Speakout/Petro (even on WiFi because SMS short Codes are still needed)

A phone reset is not required. The phone can't automatically switch iMessage between SIMs because it needs SMS short codes.

1) Put the koodo sim into the phone to clear out iMessage
2) activate/ regester on iMessage (using the koodo number)
3) deactivate/ deregister iMessage to clear it out (so no phone number is associated with iMessage)
4) remove the Koodo SIM
5) Install the Speakout SIM
6) *DO NOT ACTIVATE* iMessage anytime the Speakout SIM is in the phone (even on wifi)
7) SMS should work normally now on Speakout
[OP]
Deal Addict
Dec 20, 2009
1042 posts
215 upvotes
l69norm wrote:
Oct 13th, 2018 10:11 am
You have to go thru the existing threads on iMessage activation on Speakout/Petro Can.

From what I remember at the time, SMS short codes are needed. Speakout/Petro does not support these, therefore iMessage can't be used on Speakout/Petro (even on WiFi because SMS short Codes are still needed)

A phone reset is not required. The phone can't automatically switch iMessage between SIMs because it needs SMS short codes.

1) Put the koodo sim into the phone to clear out iMessage
2) activate/ regester on iMessage (using the koodo number)
3) deactivate/ deregister iMessage to clear it out (so no phone number is associated with iMessage)
4) remove the Koodo SIM
5) Install the Speakout SIM
6) *DO NOT ACTIVATE* iMessage anytime the Speakout SIM is in the phone (even on wifi)
7) SMS should work normally now on Speakout
Brilliant! It worked! I may still switch to Koodo, but at least I can wait a few weeks before I decide.
Newbie
Jan 9, 2019
2 posts
l69norm wrote:
Oct 13th, 2018 10:11 am
You have to go thru the existing threads on iMessage activation on Speakout/Petro Can.

From what I remember at the time, SMS short codes are needed. Speakout/Petro does not support these, therefore iMessage can't be used on Speakout/Petro (even on WiFi because SMS short Codes are still needed)

A phone reset is not required. The phone can't automatically switch iMessage between SIMs because it needs SMS short codes.

1) Put the koodo sim into the phone to clear out iMessage
2) activate/ regester on iMessage (using the koodo number)
3) deactivate/ deregister iMessage to clear it out (so no phone number is associated with iMessage)
4) remove the Koodo SIM
5) Install the Speakout SIM
6) *DO NOT ACTIVATE* iMessage anytime the Speakout SIM is in the phone (even on wifi)
7) SMS should work normally now on Speakout
I'm having this same problem, but I find it weird that my phone worked fine with iMessage and texting using Speakout (no data) previously. Both iPhone and the carrier had updates and since that time, no more texting to iPhone users. I am having all the exact same problems the poster has had.

Also my niece uses Speakout with an iPhone plus and she is able to both text and use iMessage. So Speakout's response about needing to have a data plan and needing to disable iMessage don't completely make sense.

I emailed Speakout and they said:

"If you do not plan on having a data plan, you need to disable iMessage. This will mean every message you send and receive will be a text message.

Currently, MMS on iPhones does not work with SpeakOut.

Again, your best option to turn off iMessaging and leave it off."

But like the poster, I can't receive or send any texts at all with iMessage off.

I don't have another SIM card. Is there any other fix that doesn't require a SIM card?

I'm stuck with Speakout for the next year. I prepaid for the year, not realizing this would be an issue, since, as I mentioned, I didn't have this problem before.
Deal Guru
User avatar
Jun 12, 2007
14212 posts
3557 upvotes
London
JanetL36732 wrote:
Jan 10th, 2019 11:05 pm
I'm having this same problem, but I find it weird that my phone worked fine with iMessage and texting using Speakout (no data) previously. Both iPhone and the carrier had updates and since that time, no more texting to iPhone users. I am having all the exact same problems the poster has had.

Also my niece uses Speakout with an iPhone plus and she is able to both text and use iMessage. So Speakout's response about needing to have a data plan and needing to disable iMessage don't completely make sense.

I emailed Speakout and they said:

"If you do not plan on having a data plan, you need to disable iMessage. This will mean every message you send and receive will be a text message.

Currently, MMS on iPhones does not work with SpeakOut.

Again, your best option to turn off iMessaging and leave it off."

But like the poster, I can't receive or send any texts at all with iMessage off.

I don't have another SIM card. Is there any other fix that doesn't require a SIM card?

I'm stuck with Speakout for the next year. I prepaid for the year, not realizing this would be an issue, since, as I mentioned, I didn't have this problem before.
I haven’t used Speakout for a while so things might have changed. Buried in those already existing threads was an answer that goes something like this:

What happens is that periodically, either Rogers or Speskout leak/ enable sms short codes. During one of those windows, it’s possible to successfully initialize iMessage and it will continue to work afterwards until a configuration change is made on the phone.

Nobody knows when, where or why short codes are sometimes enabled and likewise no one knows when these windows are closed. Sometimes those windows will be open for weeks, sometimes only hours. For example, one time Speakout looked like it mistakenly enabled unlimited data for several weeks, then mysteriously shut it off. (Advice - Don't change any of the settings any of the iMessage settings on the iphone that is already working because it will end up with the same problem)

This might work, I'm not sure:
1. take the sim card from the iphone and install into a different phone (non-apple)
2. https://selfsolve.apple.com/deregister-imessage/
3. Go to the section on "No longer have your iPhone?" and deregister IMessage
4. Apple will send a txt message to the non-apple phone. Enter the code into the web page
5. With wifi, see if you can turn off iMessage on the iPhone (no SIM installed)
6. Take the SIM from the non apple phone and reinstall into the iPhone
7. See if the phone can now send and receive text messages
8. Never re-enable iMessage with the Speakout SIM
Newbie
Jan 9, 2019
2 posts
Thank you for all that information.

It's just strange that I used it with iMessage and texting successfully for years with this plan and now it doesn't work.

I don't have an extra android phone. Is it necessary to put the SIM in another phone? Or can I just de-register?

I wonder if there is any other iPhone app that I could use for texting so that I could continue using iMessage with Wi-Fi?

Speakout 7-11 says: "Apple changed how they handle MMS settings during the iPhone 6 launch cycle. If you haven't updated since then, it would work. The update affected everyone." But it hasn't affected my niece and her iPhone is up to date.

The rest of my family is using iMessage for daily family updates and I'd really like to find a workaround so that I can continue to use iMessage for this group chat. It seems I have to choose between texting or iMessage, but I don't understand the logic in this change for either 7-11 or for Apple - it turns me off both the iPhone and the 7-11 service. iMessage is the main reason I chose an iPhone. I'm not sure my 82 year old mother is going to be willing to learn another app to replace iMessage. Ugh. I wish there was another solution.

Top