Travel

Unconditionally forward all cellphone calls to voicemail on Rogers?

  • Last Updated:
  • Mar 18th, 2019 5:04 pm
[OP]
Newbie
May 4, 2006
18 posts
Vancouver

Unconditionally forward all cellphone calls to voicemail on Rogers?

Hi,

I unconditionally forward all my cellphone calls to voicemail so that I don't answer them by accident when roaming (while still getting text messages). I used to do this with Fido using the GSM code: *21*3436# (3436 being the short phone number for Fido's voicemail receiver). I can't figure out what number to use for my Dad on Rogers. Does anyone know? It's an Android... the call/no answer setting shows "voicemail:internal" which I can't enter into the all calls box.

Thanks.
9 replies
Newbie
Nov 20, 2016
69 posts
14 upvotes
Hi , I do this when I travel also .

Activate Unconditional Call Forwarding

Dial *21*(phone number)#

Deactivate Call Forwarding

Dial #21#
[OP]
Newbie
May 4, 2006
18 posts
Vancouver
Thanks. I've got that part. It's the actual Rogers # to put in the blank that I need. :)
Newbie
Jul 24, 2018
0 posts
I can't set it back to voicemail : internal either, other guys post gives me landline number to access voicemail, how did you set it back?
Member
Oct 10, 2012
371 posts
66 upvotes
London
I'm having the same problem. Did you ever figure it out?
Penalty Box
User avatar
Jun 24, 2015
2258 posts
448 upvotes
Woodbridge, ON
*21*your voicemail deposit number# <SEND> can't get any easier

if you want to know your voice mail deposit number, dial *#61# and write down the number or call your carrier. if this does not work, your carrier does not allow this.
Hi
Newbie
User avatar
Aug 14, 2011
1 posts
KITCHENER
I had some fun working out the limitations with this cellular forwarding feature and ended up needing Rogers support to fix.
If you use Conditional busy/unanswered forwarding via *67*number# or *61*number# it will set the forwarding to a 10 digit number but it will remove the default roll to voicemail destination from your phone. So when callers call you it won't go to voicemail, it will just ring. Sure you can set it to forward busy to a landline or another number, but it will no longer use VM as default
The Call Forwarding setting on Android phones typically shows as voicemail:internal).
Even if you set the conditional forwarding to your cell VM retrieval number eg *67*8776437786# it will not work, as Rogers does not pass the cell number as the source, so the caller will be prompted to login to a mailbox, and will not be able to leave you a message.

The only way to get that reset is to have Rogers Support remove and readd the voicemail.
Once I had reinitialized the mailbox it flashed down fresh conditional call forward (and even removed the number i had set for the call forward all field).

Hope that helps someone else...
Newbie
Mar 17, 2019
1 posts
Thx Squirrelmasher, You got me on the right track but when I contacted Rogers support and explained the issue they didn't need to remove voicemail and add to reset. They asked which phone I had and when I said Android 8 they said I just needed go to settings, general, reset, reset network settings, reset them and then power off phone. Once I did this and powered on it had "Forward when unreachable" set back to "voicemail:internal".
Newbie
Sep 17, 2014
1 posts
Woodbridge, ON
Hi,

The number to conditionally forward the calls would be the Voicemail Depositing number, which is different than the Voicemail Retrieving number (which is currently used for retrieving voicemail messages by pressing long on "1").

So make sure you use this number for conditional call forwarding: +16475301009 or use the following code to set all conditional call forwarding: *004*+16475301009#

Hope that helps!

Thanks,

Gabe
Squirrelmasher wrote:
Jan 3rd, 2019 10:50 pm
I had some fun working out the limitations with this cellular forwarding feature and ended up needing Rogers support to fix.
If you use Conditional busy/unanswered forwarding via *67*number# or *61*number# it will set the forwarding to a 10 digit number but it will remove the default roll to voicemail destination from your phone. So when callers call you it won't go to voicemail, it will just ring. Sure you can set it to forward busy to a landline or another number, but it will no longer use VM as default
The Call Forwarding setting on Android phones typically shows as voicemail:internal).
Even if you set the conditional forwarding to your cell VM retrieval number eg *67*8776437786# it will not work, as Rogers does not pass the cell number as the source, so the caller will be prompted to login to a mailbox, and will not be able to leave you a message.

The only way to get that reset is to have Rogers Support remove and readd the voicemail.
Once I had reinitialized the mailbox it flashed down fresh conditional call forward (and even removed the number i had set for the call forward all field).

Hope that helps someone else...

Top