Cell Phones

xiaomi Mi A3 not showing LTE on Rogers

  • Last Updated:
  • Feb 8th, 2020 11:49 am
[OP]
Newbie
Jan 2, 2012
57 posts
16 upvotes

xiaomi Mi A3 not showing LTE on Rogers

I have a global version Mi A3. I'm seeing 3G on the lock screen and h+ under the mobile data icon in the drop down. Can this phone connect to Rogers LTE?
8 replies
Deal Addict
Nov 1, 2009
1573 posts
784 upvotes
Have you checked your APN settings?
Also if you see 4G, got nothing to worry about. 4G=LTE
Deal Guru
Dec 10, 2004
12175 posts
1684 upvotes
Kanata
Yes, but only using Bands 4 and 7. Are you in a rural area? Perhaps you need to be on Band 12 in your area, which your phone does not support.
Deal Expert
User avatar
Nov 28, 2013
16917 posts
6697 upvotes
Oakville
Looks like it supports B4 and B7, so you should be able to get LTE, as long as you have B4 and B7 towers in your area. If memory serves, Rogers has a lot of B7 (2600mhz) towers, but you can check the cell tower map to see exactly what they have in your area.
Lucky Koodo $40/6GB (with $15/10GB add-on) recipient
[OP]
Newbie
Jan 2, 2012
57 posts
16 upvotes
jay-em wrote: Have you checked your APN settings?
Also if you see 4G, got nothing to worry about. 4G=LTE
Yes but I'm not seeing 4G. I'm seeing 3G or H+. My APN name is Rogers LTE, and APN is ltemobile.apn.
[OP]
Newbie
Jan 2, 2012
57 posts
16 upvotes
goofball wrote: Yes, but only using Bands 4 and 7. Are you in a rural area? Perhaps you need to be on Band 12 in your area, which your phone does not support.
I'm in Ottawa.
Deal Addict
Nov 1, 2009
1573 posts
784 upvotes
Perhaps check your setting again, under "sim card & mobile networks"
Images
  • upload.jpg
  • upload.jpg
[OP]
Newbie
Jan 2, 2012
57 posts
16 upvotes
jay-em wrote: Perhaps check your setting again, under "sim card & mobile networks"
Images
  • Screenshot_20200207-184846.png
Deal Addict
Nov 1, 2009
1573 posts
784 upvotes
@bezumnik
Do you have any other sim card(Roger) & phone.

That way you can rule out the possibility of either, faulty sim card & issue with your Xiaomi.

Top