Black Friday & Cyber Monday Deals 2018

[Staples] ASUS AC2900 RT-AC86U Router ($270-120=$150) Nov 23-25 Only

  • Last Updated:
  • Dec 10th, 2018 2:10 pm
Deal Addict
Oct 3, 2012
1208 posts
348 upvotes
Hamilton, Ontario
ToniCipriani wrote:
Nov 23rd, 2018 10:06 am
But based on my research, it's officially unsupported and will break a few things since it conflicts with some Merlin changes, and unfixable due to the AiMesh code being closed source.

Are you just using the node in AP / Repeater mode?

https://www.snbforums.com/threads/merli ... ost-407116
You are probably right. I use:

nvram set amas_force=1; nvram commit

Works for me. But I don't use all of Merlin's features. I would not be surprised if some of those features I don't use are broken.
Deal Fanatic
User avatar
Jun 3, 2006
7993 posts
3080 upvotes
Markham
facebook259 wrote:
Nov 30th, 2018 12:57 am
You are probably right. I use:

nvram set amas_force=1; nvram commit

Works for me. But I don't use all of Merlin's features. I would not be surprised if some of those features I don't use are broken.
Just because it shows up in the UI doesn't mean it works. This is word for word straight from the firmware author.
Member
Nov 17, 2006
415 posts
24 upvotes
Richmond Hill
Coming from the roger's Coda modem router to this is a day and night difference,

no longer I have issues with the house getting good connection, the 5g range is ridiculous and I love it. So far no issues and definitely worth the BF price I got it for. Overall I am super happy.
Jr. Member
Jun 29, 2016
119 posts
46 upvotes
+1 good coverage and no dropped connections. Much better then my Archer C7 which in retrospect sucked.
Sr. Member
Dec 24, 2007
608 posts
166 upvotes
Kingston
redmondflagger wrote:
Nov 29th, 2018 7:16 pm
problem is ASUS writes shit software that is full of stupid bugs that they never fix. The portion of the software that Merlin can change gets smaller and smaller with every release. AI Mesh from ASUS will be a closed source bag of rocks.
AI mesh is a great marketing tool that sucks people in... Other than the possibility of automatically healing (if you have 3 or more nodes) and broadcast updates, there's really nothing you can't accomplish through manually assigning AP or repeater nodes. So I wouldn't base my purchase solely on aimesh, unless you really don't trust yourself with setting up the very basics.
Deal Addict
User avatar
Aug 17, 2004
1280 posts
31 upvotes
Toronto
Is anyone else's UPS tracking stuck for over a week at "Shipment Ready for UPS Label Created 11/23/2018 Order Processed: Ready for UPS"

Called Staples and the phone rep just repeatedly saying it's on its way. I'm thinking they ran out of stock or lost the package... any thoughts??
"Life is short, running makes it seem longer."
"Nothing tastes as good as skinny feels"
Dogs aren't our whole lives......they just make our lives whole.
Sr. Member
User avatar
Jul 25, 2008
909 posts
94 upvotes
Ottawa
Finally, I opened mine yesterday after a week.

Setup is easy but I can't put a full string of web page in the url filter.

Yes, higher power transmitting. I got full 5 bars., but the receiving end of AC2900 is not as good as my old cheapy router under 2.4ghz . I think ASUS 2.4ghz on this unit is not very stellar on reception. But great in broadcast.

Just my opinion after one day using.
Deal Guru
User avatar
Feb 24, 2003
14719 posts
1953 upvotes
Toronto
cf7777 wrote:
Dec 2nd, 2018 11:42 am
Finally, I opened mine yesterday after a week.

Setup is easy but I can't put a full string of web page in the url filter.

Yes, higher power transmitting. I got full 5 bars., but the receiving end of AC2900 is not as good as my old cheapy router under 2.4ghz . I think ASUS 2.4ghz on this unit is not very stellar on reception. But great in broadcast.

Just my opinion after one day using.
Are you using the latest firmware?

Mine is still in the box. I bought mine to use with Windscribe for USA Netflix to get higher download in place of a Netgear r7000.

With Windscribe/USA Netflix enabled on the Netgear, I can maintain a speed of 7.15 Mbps for over an hour and then, for no apparent reason, the speed will drop to less than 3 Mbps and slowly rise again to 7.15. Now I'm wondering if the 86u can maintain a higher speed. I'm only using 1 device at a time to watch USA Netflix.
Last edited by audit13 on Dec 3rd, 2018 8:53 am, edited 1 time in total.
Sr. Member
User avatar
Jul 25, 2008
909 posts
94 upvotes
Ottawa
Yes, OTA updated to the latest firmware.

I had a laptop plugged into ethernet. I got 7mb as well for download.
Not sure if it the ISP, Rogers isdue or equipment issue.
Deal Guru
User avatar
Feb 24, 2003
14719 posts
1953 upvotes
Toronto
cf7777 wrote:
Dec 2nd, 2018 12:40 pm
Yes, OTA updated to the latest firmware.

I had a laptop plugged into ethernet. I got 7mb as well for download.
Not sure if it the ISP, Rogers isdue or equipment issue.
If you got 7 Mbps with Windscribe's USA Netflix server, I doubt my 86u will be faster than my Netgear r7000.

I am also on Rogers 500u and I can hit 500 over wired and wireless without the VPN.
Sr. Member
User avatar
Jan 3, 2008
842 posts
182 upvotes
W.GTA
Really happy with this router, I can get weak signal down the street.
Public Mobile
Deal Addict
Oct 3, 2012
1208 posts
348 upvotes
Hamilton, Ontario
ToniCipriani wrote:
Nov 30th, 2018 7:35 am
Just because it shows up in the UI doesn't mean it works. This is word for word straight from the firmware author.
And just because something is not 100% functional does not mean it won't work well enough to meet your needs.

So here are some of the problems I have noticed with AIMesh:
1. Once in a while, the wifi will turn off for one or more of the routers. (Both Asus and Merlin)
2. The fall over between wired and wifi for the backbone may be one of the things that can cause wifi to turn itself off...
3. If the internet connection goes down, I usually have to reboot all the nodes to get all the devices in the house back online.

I don't know which problems Merlin noticed, as he won't discuss that. I'm guessing it is problem #1. He probably doesn't use AIMesh at all and so he didn't realize that is just an Asus bug...

A problem that is resolved by using Merlin instead of Asus firmware is the allocation of IP addresses. In the Asus firmware the initial DHCP requests take a very long time to complete, and the main AIMesh router, won't show all the addresses allocated by the nodes. Merlin seems to solve this issue.

Now for my uses I could turn AIMesh off and just use router extension mode. As most of the time I have the LAN cable plugged it. But I had already configured everything for AIMesh, and I've never seen a problem significant enough to want to change it. I like the convenience of being able to unplug the LAN cable going into the router, and not having to configure three different routers individually.
Deal Expert
User avatar
Nov 28, 2013
15476 posts
5788 upvotes
Oakville
Hrmm. Looks like mine is starting to show some 2.4GHz issues. I was trying to set up my Sengled hub on the weekend, having some issues with it so I decided to try setting my router to 2.4GHz only for a minute (because the hub only works on 2.4GHz) - can't connect to the router at all over wifi (I can see it, but can't connect with any client), have to connect via lan to get the 5ghz network turned back on. Grrrrr.
Lucky Koodo $40/6GB (with $15/10GB add-on) recipient
Deal Guru
User avatar
Feb 24, 2003
14719 posts
1953 upvotes
Toronto
wearysky wrote:
Dec 3rd, 2018 10:09 am
Hrmm. Looks like mine is starting to show some 2.4GHz issues. I was trying to set up my Sengled hub on the weekend, having some issues with it so I decided to try setting my router to 2.4GHz only for a minute (because the hub only works on 2.4GHz) - can't connect to the router at all over wifi (I can see it, but can't connect with any client), have to connect via lan to get the 5ghz network turned back on. Grrrrr.
How long was it running before it started exhibiting this behaviour?

Read some posts on snb about problems with 2.4. Some people solved it by an RMA and others solved it by changing the 2.4 wireless settings.
Deal Expert
User avatar
Nov 28, 2013
15476 posts
5788 upvotes
Oakville
audit13 wrote:
Dec 3rd, 2018 10:33 am
How long was it running before it started exhibiting this behaviour?

Read some posts on snb about problems with 2.4. Some people solved it by an RMA and others solved it by changing the 2.4 wireless settings.
I've had it about a month. Haven't messed around with my settings on it too much yet (because it was working fine pretty much out of the box). Hoping I don't have to RMA it just yet.
Lucky Koodo $40/6GB (with $15/10GB add-on) recipient

Top