Computers & Electronics

Bell Home Hub 3000 poor ethernet performance

  • Last Updated:
  • Jul 5th, 2020 12:14 am
[OP]
Newbie
Nov 7, 2013
67 posts
48 upvotes

Bell Home Hub 3000 poor ethernet performance

Hey everyone;
Just had Bell Fibe 1GB installed yesterday, and I'm having issues with the ethernet speeds. Was on the phone with a Bell tech who could only offer to wait 24 hours.

Problem:

I'm getting poor (max 150Mbps from Ookla, fast, Google, etc) downloads. My uploads hit around 400Mbps to 700Mbps in the same tests, so uploads seem fine. These numbers are consistent no matter how often I try. same results on my Desktop PC (2.5GB capable Intel nic), and my Google Wifi network test (the Wifi pod is wired to the HH3000).

Steps I used to test:

- I still have Rogers 1GB installed here. I run the same tests on the Hitron modem for Rogers and my download speeds hit 700Mbps download consistently on both my PC and the Google Wifi network test
- I manually set the ethernet speeds in the HH3000 to 1000Mbps, and also set to full duplex. Same results as the default "Auto" (I changed these settings one at a time).
- If I use wireless on the HH3000, my downloads hit about 500-700Mbps, which is much faster than ethernet
- tried a variety of Cat5e and Cat 6 cables, or varying lengths of 20ft to 3ft in length
- changed the ethernet adapter settings in Windows manually to 1000Mbps and full duplex (I don't think my Google wifi pod has this ability so I could only test on the PC).
- tried different ethernet ports on the HH3000
- ensured Win10 PC drivers up to date.

Am I missing anything obvious? It seems like the HH3000 is running at 10Mpbs or lower on the ethernet ports. Using my Rogers Hitron modem/router alleviates there issues, so I think something is up on the HH3000 and how its negotiating the ethernet speeds. I think I have ruled out issues with my network cards and cables.
3 replies
Sr. Member
Apr 18, 2017
626 posts
1192 upvotes
Try unplugging the Fiber line in the wall and re plugging it back in. Solved my issue that was exactly like what you are having.
Deal Addict
Jul 26, 2018
1157 posts
1489 upvotes
Canada, eh?
If you're still having issues after trying out the recommendation above, I'd suggest you contact the tech again. The fiber line might have been tugged or ripped partially.

Had this happen to me right after installation, the optic cable is very fragile.
Deal Addict
May 13, 2005
3462 posts
3313 upvotes
Montreal
Try to log into your modem and do the speed test there. If you don't get the expected download/upload speed then call Bell.

http://192.168.2.1/?c=speedtest

For example, Bell Fibe 300 (300Mbps up / 300Mbps down)
Image

Top