Expired Hot Deals

ON - Carrytel Cable 75M plan (Rogers), $24.99 first month then $34.99 per month, modem rental included, no install fee

  • Last Updated:
  • Jun 17th, 2019 2:09 pm
Deal Addict
User avatar
Oct 20, 2004
3183 posts
30 upvotes
Just FYI, Carrytel charges $59 as "fake" installation fees, if you rent their modem (instead of buying), even if there is no installation involved as I transfer from Cogeco.
HEATWARE 47+ : BST 27+ : EBAY 212+ (links on request)
Newbie
Dec 1, 2014
30 posts
9 upvotes
Toronto
Been with them for about three months now. Overall I'd say I'm moderately satisfied, but still annoyed at times. When it's good, it's good - currently testing my speed from upstairs computer (wireless router on the main floor) and consistently hitting 67-72 mbps, which is about advertised. However, many times throughout the day the speed will crawl down to 1-2mbps, or just cut off completely. This usually doesn't last longer than a few minutes, but it's the intermittent nature that gets annoying. Not sure if it's our router/modem or if they are throttling the service, but this was never an issue with Acanac or start.ca. It's still a great price, but Fido is also offering a 75 mbps for 12 months at 32.50 right now, and I am tempted to switch over if the inconsistent speeds continue, but I will give them another chance for the rest of the month.
Deal Addict
Mar 27, 2004
3237 posts
627 upvotes
Toronto
the service disconnects intermittently for me as well. any solutions?
Cash Rebate Realtor
Full-time & Full Service
Homelife Bayview

President Award 2018
Deal Guru
User avatar
Mar 25, 2003
13871 posts
2961 upvotes
Markham
dinesh_zee wrote:
Jul 10th, 2018 11:51 am
Just FYI, Carrytel charges $59 as "fake" installation fees, if you rent their modem (instead of buying), even if there is no installation involved as I transfer from Cogeco.
@dinesh_zee
it is "$59.00(Modem rent to own option)"
is not installation fees
you better ask them to clarify how this rent to own works
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Member
Aug 12, 2017
467 posts
91 upvotes
oasis100 wrote:
Jul 18th, 2018 9:33 pm
the service disconnects intermittently for me as well. any solutions?
Change providers. This is what I had done and no more problems.
Banned
Mar 13, 2018
1385 posts
666 upvotes
IAmBatman wrote:
Jul 18th, 2018 6:16 pm
Been with them for about three months now. Overall I'd say I'm moderately satisfied, but still annoyed at times. When it's good, it's good - currently testing my speed from upstairs computer (wireless router on the main floor) and consistently hitting 67-72 mbps, which is about advertised. However, many times throughout the day the speed will crawl down to 1-2mbps, or just cut off completely. This usually doesn't last longer than a few minutes, but it's the intermittent nature that gets annoying. Not sure if it's our router/modem or if they are throttling the service, but this was never an issue with Acanac or start.ca. It's still a great price, but Fido is also offering a 75 mbps for 12 months at 32.50 right now, and I am tempted to switch over if the inconsistent speeds continue, but I will give them another chance for the rest of the month.
Sounds like a router/modem problem. They don't throttle and if it's a line issue, won't be just randomly few minutes. Try a new router and if that don't work, modem swap

My old router (only 1.5yrs old) was causing issues like you are having and I swapped it and it's been great since
Deal Addict
User avatar
May 8, 2008
1216 posts
205 upvotes
I got intermittent drops as well ... got the modem replaced (another CGN3) ... haven't had any issues yet
Deal Fanatic
User avatar
Apr 9, 2006
8797 posts
10766 upvotes
GT-EH
oasis100 wrote:
Jul 18th, 2018 9:33 pm
the service disconnects intermittently for me as well. any solutions?
I've been experiencing this too, BUT, all my lights on my Cable modem are solid and nothing indicates a signal drop.
which leads me to believe it could be my router... or my google devices are flooding my network with crap again.

My disconnects started happening within the week... but only briefly - down for 30 seconds and then it reconnects.

You might want to try rebooting your router and possibly your cable modem.
What's the best credit card for...
Behold, true glory. #PCMasterRace!
Sr. Member
Aug 26, 2004
712 posts
13 upvotes
GTA
Are the disconnects still happening?
Sr. Member
Oct 13, 2008
506 posts
309 upvotes
Toronto
Got my cable internet installed today but I am disappointed with their service. I had Start and Cogeco as my previous providers. With the previous providers never had an issue streaming with Netflix or Youtube. For the same 40Mbps package I have constant buffering with a brand new Tplink modem even though the TV is hard wired. If they can't help with the buffering issue I will go back to Start.

Btw my Start service has been disconnected since August 31st.
Newbie
Sep 24, 2018
5 posts
I got my cable in July, and everything was fine.
Now I notice I am getting slower speeds in the evening from 7:45 to 10:15pm. This is happening every single day now.
I did a speed test to a Canadian server during this time and it was 65 Mbps (which is good), but to a US server I was getting 5-7Mbps.

I called them and the tech support was not helpful at all. He told me that they can do nothing about it.
I am starting to look for another provider.
Newbie
User avatar
Jun 11, 2008
75 posts
30 upvotes
Toronto
I signed up with Carrytel about 6 months ago.
the internet service has been good so for.
However I noticed that since I signed up , I have been getting an unusually high number of robocalls , and 9 out of 10 they are in Chinese !!
I start suspecting that Carrytel (being a company run by Chinese people) may have something to do with this.
Could they have sold to telemarketing compagnies their subscribers' phone numbers?
I am wondering wether it is plausible and if any of you guys have experienced this?
thx
Deal Fanatic
User avatar
May 5, 2007
5282 posts
1135 upvotes
416
Nitrocide wrote:
Sep 25th, 2018 11:50 pm
I got my cable in July, and everything was fine.
Now I notice I am getting slower speeds in the evening from 7:45 to 10:15pm. This is happening every single day now.
I did a speed test to a Canadian server during this time and it was 65 Mbps (which is good), but to a US server I was getting 5-7Mbps.

I called them and the tech support was not helpful at all. He told me that they can do nothing about it.
I am starting to look for another provider.
Have you checked your modem power levels and if any errors? I was getting slow speeds and disconnects. I sent an email to Carrytel with a screenshot of my power levels and errors I was getting about 3 weeks ago. They called me daily for a week, but I never picked up as I didn't know the number. I finally picked up and they sent a tech 3 days later.
He added a booster and now things are running smoothly for me.
Newbie
Sep 24, 2018
5 posts
Have you checked your modem power levels and if any errors? I was getting slow speeds and disconnects. I sent an email to Carrytel with a screenshot of my power levels and errors I was getting about 3 weeks ago. They called me daily for a week, but I never picked up as I didn't know the number. I finally picked up and they sent a tech 3 days later.
He added a booster and now things are running smoothly for me.
I didn't do a modem power check. Sorry I don't know how to do that.

My modem is working good in the morning and afternoon, and anytime before 7:45 with good speeds.
During the peak evening hours from 7:45 to 10:15 my internet drops in speed. So far it has been predictable. At first, I thought it was several days coincidence, but now it is certain.

I have read on the forum some people had this issue, and it is just unfortunate I guess.
I signed up with Carrytel about 6 months ago.
the internet service has been good so for.
However I noticed that since I signed up , I have been getting an unusually high number of robocalls , and 9 out of 10 they are in Chinese !!
I start suspecting that Carrytel (being a company run by Chinese people) may have something to do with this.
Could they have sold to telemarketing compagnies their subscribers' phone numbers?
I am wondering wether it is plausible and if any of you guys have experienced this?
thx
Yes I got a few call too, that were Chinese. I think you are right about our info was given to other parties.

Top