Expired Hot Deals

ON - Carrytel Cable 75M plan (Rogers), $24.99 first month then $34.99 per month, modem rental included, no install fee

  • Last Updated:
  • Oct 10th, 2018 9:58 am
Newbie
Mar 18, 2007
51 posts
3 upvotes
Just got the 75/10 service. I am using the provided CGN3 modem. With wired Ethernet connection, speed test shows 75/10 exactly as advertised. Using wireless on one laptop with only 2.4G support, Speed test shows 20/10. Another laptop with 5G support, the 5G connection speed test shows 39.5/10.
The wireless client list shows bandwidth 20M and 40M for my 2 laptops. Under the wireless configuration, I can only see WMM enabled for both 2.4G and 5G. Looks like the wireless connection is restricted by WMM (I may be wrong) . But I can't see anywhere that I can disabled WMM. The manual shows under 2.4G or 5G configuration, I should see WMM with the enable/disable switch. But in my case it only shows enabled and no switch. Does anyone out there have similar restriction and know how to fix it ? BTW my modem shows: HW Version 1A, SW Version 4.2.4.11
Deal Guru
Mar 22, 2004
11200 posts
1652 upvotes
RFD
Finally experiencing problems the past few days it has been slow, and now the modem signal cut off for about 20 minutes and came back on.

And also my other family member in the same city Brampton/Mississauga has had their Carrytel down for the past two days. Submitted a ticket to Carrytel and they said they would open a ticket with Rogers but Rogers has not done anything yet.

Looked on Twitter and I noticed many other people had issues with Rogers the past few weeks.
Newbie
Jun 8, 2012
12 posts
Montreal
blexann wrote:
Jun 18th, 2018 10:57 pm
With a total of 9 posts your going to have to do alot better than that.
OK, my details:
They either charge you $39 for an install with your own modem, or $49 for a modem purchase and a free install.

I used my own modem that was functioning just fine with E-box on one day, and paid the $39 install fee. Bell technician comes by to do the "install" and magically my existing modem won't work with carrytel. I had given them the model number, serial number and MAC address to confirm my modem would work. So I now pay another $49 for their modem (that should come with a free install), on top of the $39 install fee I've already paid. Notice the double charging here, which they refused to refund.

New modem arrives, and even though I paid for 50 MB/s service (which E-box supplied just fine) I never get more than 25 MB/s service with carrytel, normally closer to 20 MB/s.

Through all this, tech support has been less than helpful. So I've now been double charged my install fee, and am paying for a 50 MB/s service while they can only supply half of that.
Deal Guru
User avatar
Mar 25, 2003
12857 posts
2315 upvotes
Markham
QuantM wrote:
Jul 2nd, 2018 10:51 pm
OK, my details:
They either charge you $39 for an install with your own modem, or $49 for a modem purchase and a free install.

I used my own modem that was functioning just fine with E-box on one day, and paid the $39 install fee. Bell technician comes by to do the "install" and magically my existing modem won't work with carrytel. I had given them the model number, serial number and MAC address to confirm my modem would work. So I now pay another $49 for their modem (that should come with a free install), on top of the $39 install fee I've already paid. Notice the double charging here, which they refused to refund.

New modem arrives, and even though I paid for 50 MB/s service (which E-box supplied just fine) I never get more than 25 MB/s service with carrytel, normally closer to 20 MB/s.

Through all this, tech support has been less than helpful. So I've now been double charged my install fee, and am paying for a 50 MB/s service while they can only supply half of that.
@QuantM
When did you get Carrytel ?
I guess you were still using E-Box or you cancelled E-box less then 14 days before Carrytel?
because their use Own modem Conditions is:

Your modem needs to be inactive for at least 14 days in order to be used with Carry Telecom.

If your modem is currently active with another provider, we will not be able to process the order until it becomes deactivated with your current provider

Which modem you got now and your speed test of 20 Mbps is wired? or wifi?
and which speed test website you used?
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Newbie
Jun 8, 2012
12 posts
Montreal
Keigotw wrote:
Jul 5th, 2018 11:03 am
@QuantM
When did you get Carrytel ?
I guess you were still using E-Box or you cancelled E-box less then 14 days before Carrytel?
because their use Own modem Conditions is:

Your modem needs to be inactive for at least 14 days in order to be used with Carry Telecom.

If your modem is currently active with another provider, we will not be able to process the order until it becomes deactivated with your current provider

Which modem you got now and your speed test of 20 Mbps is wired? or wifi?
and which speed test website you used?
I cancelled my service with E-Box and tried to activate it on Carrytel the next day. I called their technical support team three times in three days, and they never mentioned the modem needed to be inactive for 14 days. That may be completely true, but their support team is unaware of it. Instead they only said I need to buy a new modem for $$$ and wait another week without internet.

I've been running speed tests with fast.com and speedtest.net wired. Getting speeds of 21.43 Mbps on speedtest.net and 20 Mbps on fast.com. Wireless in the same room give comparable results.
Deal Guru
User avatar
Mar 25, 2003
12857 posts
2315 upvotes
Markham
QuantM wrote:
Jul 5th, 2018 11:16 am
I cancelled my service with E-Box and tried to activate it on Carrytel the next day. I called their technical support team three times in three days, and they never mentioned the modem needed to be inactive for 14 days. That may be completely true, but their support team is unaware of it. Instead they only said I need to buy a new modem for $$$ and wait another week without internet.

I've been running speed tests with fast.com and speedtest.net wired. Getting speeds of 21.43 Mbps on speedtest.net and 20 Mbps on fast.com. Wireless in the same room give comparable results.
When did you get Carrytel installed?
which modem they send you?
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Newbie
Jun 8, 2012
12 posts
Montreal
Keigotw wrote:
Jul 5th, 2018 11:24 am
When did you get Carrytel installed?
which modem they send you?
Install was done on June 15th. They shipped me a TP-Link TD-W9970 modem which I began using on June 23rd.

I just ran a new speed test from a wired connection on fast.com a got a (fastest ever for Carrytel) 28 Mbps. Still on the 50 Mbps plan.
Deal Guru
User avatar
Mar 25, 2003
12857 posts
2315 upvotes
Markham
QuantM wrote:
Jul 5th, 2018 8:23 pm
Install was done on June 15th. They shipped me a TP-Link TD-W9970 modem which I began using on June 23rd.

I just ran a new speed test from a wired connection on fast.com a got a (fastest ever for Carrytel) 28 Mbps. Still on the 50 Mbps plan.
oh, you are using their DSL service (not cable)
don't you get a log in and password? that you have to enter to your modem or router ( PPPoE )
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Sr. Member
Jan 27, 2016
964 posts
354 upvotes
Toronto, ON
anyone know how their home phone is? My parents still use home phone and need decent reception
Deal Guru
User avatar
Mar 25, 2003
12857 posts
2315 upvotes
Markham
loopy1984 wrote:
Jul 6th, 2018 10:49 am
anyone know how their home phone is? My parents still use home phone and need decent reception
is voip.
I would recommend going with Fongo Home Phone as you can use with any ISP
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Deal Addict
User avatar
Oct 20, 2004
3176 posts
14 upvotes
Just FYI, Carrytel charges $59 as "fake" installation fees, if you rent their modem (instead of buying), even if there is no installation involved as I transfer from Cogeco.
HEATWARE 47+ : BST 27+ : EBAY 212+ (links on request)
Newbie
Dec 1, 2014
18 posts
6 upvotes
Toronto
Been with them for about three months now. Overall I'd say I'm moderately satisfied, but still annoyed at times. When it's good, it's good - currently testing my speed from upstairs computer (wireless router on the main floor) and consistently hitting 67-72 mbps, which is about advertised. However, many times throughout the day the speed will crawl down to 1-2mbps, or just cut off completely. This usually doesn't last longer than a few minutes, but it's the intermittent nature that gets annoying. Not sure if it's our router/modem or if they are throttling the service, but this was never an issue with Acanac or start.ca. It's still a great price, but Fido is also offering a 75 mbps for 12 months at 32.50 right now, and I am tempted to switch over if the inconsistent speeds continue, but I will give them another chance for the rest of the month.
Deal Addict
Mar 27, 2004
2790 posts
346 upvotes
Toronto
the service disconnects intermittently for me as well. any solutions?
Realtor - Platinum award winner
Deal Guru
User avatar
Mar 25, 2003
12857 posts
2315 upvotes
Markham
dinesh_zee wrote:
Jul 10th, 2018 11:51 am
Just FYI, Carrytel charges $59 as "fake" installation fees, if you rent their modem (instead of buying), even if there is no installation involved as I transfer from Cogeco.
@dinesh_zee
it is "$59.00(Modem rent to own option)"
is not installation fees
you better ask them to clarify how this rent to own works
96TB Mediasonic H82-SU3S2 / 72TB Raid 50 on Mediasonic H8R2-SU3S2
48TB Node 304 / i5-3570 / Server 2016 Essentials
12TB HP Mediasmart EX 495 (E8400, 3.0GHZ, 4GB Mushkin), with Server 2016 Essentials
16TB Qnap TS-459 Pro
Member
Aug 12, 2017
363 posts
60 upvotes
oasis100 wrote:
Jul 18th, 2018 9:33 pm
the service disconnects intermittently for me as well. any solutions?
Change providers. This is what I had done and no more problems.

Top