Computers & Electronics

connected to home network, but no internet

  • Last Updated:
  • Jul 8th, 2015 9:08 am
Tags:
None
[OP]
Deal Addict
Aug 20, 2007
1564 posts
44 upvotes
usa

connected to home network, but no internet

All of our devices (desktop, laptop, smart tv, smartphone) are able to connect to the home network, but cannot connect to the internet. I've tried connecting to the wifi router (2.4ghz and 5ghz), wifi powerline adapter, but still no connection to the internet.

For my laptop, I cannot even use my iphone's hotspot via wifi, only able to connect via usb. For my smart tv, I can connect to the internet via iphone's hotspot.

I did not try the tablets, so no idea.
5 replies
Newbie
Mar 29, 2007
30 posts
9 upvotes
Ottawa
gta1216 wrote: All of our devices (desktop, laptop, smart tv, smartphone) are able to connect to the home network, but cannot connect to the internet. I've tried connecting to the wifi router (2.4ghz and 5ghz), wifi powerline adapter, but still no connection to the internet.

For my laptop, I cannot even use my iphone's hotspot via wifi, only able to connect via usb. For my smart tv, I can connect to the internet via iphone's hotspot.

I did not try the tablets, so no idea.
I assume you configured DHCP to give your devices IP addresses. Make sure that you configure a DHCP gatweway to be your router IP address.

Hope it helps
Deal Fanatic
User avatar
Mar 20, 2009
8862 posts
2689 upvotes
Vancouver
Several things can prevent internet access when you have a good connection to the LAN:

1. Your router can't get an IP address from your ISP. Check your router's status page.
2. There's something wrong with your DNS settings and you can't look up domain names. See if you can ping external IP addresses directly (e.g., Google DNS at 8.8.8.8).
3. There's something wrong with the internet gateway value being provided by your router (should be the LAN address of the router itself)
[OP]
Deal Addict
Aug 20, 2007
1564 posts
44 upvotes
usa
I power cycled the modem and router and is working now. Strange thing is, I've tried power cycling it before posting, but didn't work the last few times.
Deal Guru
User avatar
Oct 24, 2012
11638 posts
2613 upvotes
Montreal
gta1216 wrote: I power cycled the modem and router and is working now. Strange thing is, I've tried power cycling it before posting, but didn't work the last few times.
Maybe it was an outside factor, such as maintenance being done on the lines (Cable or telephone) so your modem wasn't able to get network access.

Top