Automotive

Dome Z7 1080p Dashcam Review (NOW $37.99USD)

  • Last Updated:
  • Oct 13th, 2019 5:21 pm
Tags:
None
Deal Addict
Apr 23, 2014
1102 posts
423 upvotes
GTA, ON
Penrose wrote: I tried bringing it inside the house and video taping and the same noise was present. then I decided to maybe reset to factory default. when I did this, the entire menu language changed to something very foreign looking. I am unable to now return the menu to English, since I cannot read the menu in whatever the default language is, maybe russian? can somebody help navigate me to find the language back to English please.
My camera is in the car..Will try and locate the language option for u and post it tomm (I reset to factory settings once, and just clicked buttons and figured out how to choose english again). Give it a shot and play around with the buttons. if it does not work out, I will check and post tomm.
Member
Jan 27, 2008
439 posts
149 upvotes
GTA
Penrose wrote: I tried bringing it inside the house and video taping and the same noise was present. then I decided to maybe reset to factory default. when I did this, the entire menu language changed to something very foreign looking. I am unable to now return the menu to English, since I cannot read the menu in whatever the default language is, maybe russian? can somebody help navigate me to find the language back to English please.
It's easy. press "M" twice and look for "abc" icon. that's your language setting.
Deal Addict
User avatar
Dec 27, 2006
1611 posts
212 upvotes
Toronto
Anyone has the car charger around? How long is the charger cable? 6 or 9 feet?
Deal Addict
Apr 23, 2014
1119 posts
213 upvotes
josb0513 wrote: It's easy. press "M" twice and look for "abc" icon. that's your language setting.
ok, it's back to normal. thanks guys.
[OP]
Deal Addict
User avatar
Jul 18, 2012
2850 posts
879 upvotes
max88 wrote: Anyone has the car charger around? How long is the charger cable? 6 or 9 feet?
3 meters -ish
Deal Addict
User avatar
Jun 9, 2011
1547 posts
956 upvotes
Toronto
max88 wrote: Anyone has the car charger around? How long is the charger cable? 6 or 9 feet?

Closer to 15ft. I recently bought a 15ft micro usb cable, since the one came with the camera splitted
Sr. Member
Aug 8, 2010
818 posts
627 upvotes
GTA
Im having trouble with my suction mount staying on the glass. Worked fine for a couple days, but now it just keeps falling.
Any suggestions?

Thanks
Sr. Member
Jun 9, 2006
851 posts
237 upvotes
Yes, I do have a suggestion!

I ditched the suction cup and I am using a mirror holder.

Look up "Mirror Holder Mount For GT680W" on ebay. It's around 5 bucks. It's a solid buy. You will have peace of mind that the cam will never fall. It's also more discreet than a suction cup!

[IMG]http://i.ebayimg.com/00/s/NzAwWDcwMA==/ ... Q/$_35.JPG[/IMG]
Member
User avatar
May 22, 2013
466 posts
40 upvotes
VIIVIIIXIII wrote: I don't think you can house a dashcam inside the rearview mirror, wouldn't be worth the hassle.

Those are both good choices, here's how I see it:
A118 = generic china dashcam with good performance and form factor. Battery-based dashcam with average build quality and reliability. Good plug and play discrete unit for $62.

Mobius = Not your typical chinese dashcam. Ongoing developer and community support for new feature and firmware updates. Battery-based action cam with capacitor-mod available. Compatible with various suction and tape mounts via tripod screw.
It looks like Mobius has a greater developing community, but I don't want to mount it using a suction cup. It'd not be discreet anymore.
I'll be checking out dashcamtalk forums.
Sr. Member
Aug 8, 2010
818 posts
627 upvotes
GTA
intelmic wrote: Yes, I do have a suggestion!

I ditched the suction cup and I am using a mirror holder.

Look up "Mirror Holder Mount For GT680W" on ebay. It's around 5 bucks. It's a solid buy. You will have peace of mind that the cam will never fall. It's also more discreet than a suction cup!

[IMG]http://i.ebayimg.com/00/s/NzAwWDcwMA==/ ... Q/$_35.JPG[/IMG]
Thanks, will order one.
Deal Addict
Jun 5, 2004
1807 posts
1626 upvotes
Calgary
VIIVIIIXIII wrote: Another cheap dashcam alternative:

Dome GF100
Link: http://www.********.com/car-dvr/pp_63850.html
Coupon: DGFLLG
Price: $38.99 w/ free shipping.

No experience with it, but it uses the Ambarella A2 chip and has all the features of a decent dashcam.
Tempting since dash cams with the Ambarella A2 are usually more expensive than the Novatek 96650, but there's absolutely no reviews anywhere on this device. Wonder how long ******** will keep the sale until.
Member
User avatar
Apr 1, 2009
286 posts
138 upvotes
I have been having problems with mine, the screen flashes also it sometimes stay at hello screen... Bought two and put one in the wife's car same issue.
Deal Addict
Apr 30, 2002
1738 posts
144 upvotes
North
sta11ion wrote: I have been having problems with mine, the screen flashes also it sometimes stay at hello screen... Bought two and put one in the wife's car same issue.
Cut your loss - return them asap ( ~$12 - http://www.canadapost.ca/cpotools/apps/ ... ution=e1s2 ).

A better one for CAD $65 shipped ( Novatek 96650/AR0330, ~ 5.2-5.7-3.8 cm )

https://www.joovuu.com/gb/new-products/ ... u-850.html
Sr. Member
Nov 30, 2006
869 posts
35 upvotes
Richmond Hill
Just got my dome Z7 (ordered early december). Camera is DOA. Battery is dead (no matter how long I charge it with different chargers). It stops recording for no apparent reason (driving on a highway in medium traffic, for example). I tried a few sdcards (4x, 10x, etc). It stops recording alltogether even on strong motions when card is 10% full, etc. I played with settings a lot. Not a newbie (had my 2 other older dashcams die of old age)

Long story short, never ever saw such a glitchy and useless dashcam, and I bought a couple of $50 dashcams years ago. Any recourse against the seller?

Thanks!
[OP]
Deal Addict
User avatar
Jul 18, 2012
2850 posts
879 upvotes
jimmi1977 wrote: Just got my dome Z7 (ordered early december). Camera is DOA. Battery is dead (no matter how long I charge it with different chargers). It stops recording for no apparent reason (driving on a highway in medium traffic, for example). I tried a few sdcards (4x, 10x, etc). It stops recording alltogether even on strong motions when card is 10% full, etc. I played with settings a lot. Not a newbie (had my 2 other older dashcams die of old age)

Long story short, never ever saw such a glitchy and useless dashcam, and I bought a couple of $50 dashcams years ago. Any recourse against the seller?

Thanks!
You have to keep it plugged it, it's not meant to run on battery alone. The battery is only there to keep settings and save files when you turn off the car.
Member
Apr 9, 2012
469 posts
385 upvotes
jimmi1977 wrote: Just got my dome Z7 (ordered early december). Camera is DOA. Battery is dead (no matter how long I charge it with different chargers). It stops recording for no apparent reason (driving on a highway in medium traffic, for example). I tried a few sdcards (4x, 10x, etc). It stops recording alltogether even on strong motions when card is 10% full, etc. I played with settings a lot. Not a newbie (had my 2 other older dashcams die of old age)
Mine was like yours upon first use. I tried a Class 10 card vs. the Class 6 that I bought with it but it was still glitchy. Then I turned off some settings such as the Auto On/Off timer, G sensor, Motion Detection & also Sound recording, etc.. Anything that might cause it to turn off I kept off (turned off the sound in case the card could not handle the recording). Then I tried it again with the Class 10 card & it worked fine. I reinserted the Class 6 card & since then it's been fine too on long trips, even though the website says not to use a Class 10 card but in the box was a notice that one should now use a Class 10 card & not anything slower! I have not yet tested which setting that I turned off might have been the cause of it acting strange, but so far it's working fine.

The battery never seems to stay charged for long but still works fine for saving files after the vehicle is turned off. Manual says it will take 2-3 hours to charge, but after that, it's life is still short. It works okay but I would not buy another one as I find that the screen is too distracting & cannot be hidden behind the mirror as it hangs down too far. I also don't like the mounts connector to the camera. I would next get something like a Mobius or Innova with no screen & maybe no battery. I doubt that I'll ever shop ********, TMart etc. again as delivery takes too long & I no longer trust the quality of their products. I have bought a couple of other itmes that just weren't of great quality.
Sr. Member
Nov 30, 2006
869 posts
35 upvotes
Richmond Hill
VIIVIIIXIII wrote: You have to keep it plugged it, it's not meant to run on battery alone. The battery is only there to keep settings and save files when you turn off the car.
Camera shuts off immediately after I unplug it (my car happens to have an "always on" socket) and when connected to power, "power" icon blinks as if battery is damaged. Is this normal?
Member
Apr 9, 2012
469 posts
385 upvotes
jimmi1977 wrote: Camera shuts off immediately after I unplug it (my car happens to have an "always on" socket) and when connected to power, "power" icon blinks as if battery is damaged. Is this normal?
By Power icon, do you mean the tiny tiny Blue light at the top back of the unit above the screen is blinking? If it's a solid Blue light then that means that it is powered on (mine isn't blinking blue, not sure what blinking blue would mean). If Blinking Red it means that it is Charging. If you mean Power Icon to be the battery symbol at the bottom right of the screen, then mine is also always blinking. This battery symbol is the battery capacity indicator, not the power on indicator.

If your unit powers off immediately when you pull it out of the 12 volt socket, then try going to Settings>Delayed Shutdown & yours may be set to turn your unit OFF immediately when power is turned off. I have my "Delayed Shutdown" function set to 5 seconds & indeed there is a 5 second delay once the power is removed from the unit, by pulling it out from the 12 volt socket. I just tried it for you. My key also controls my 12 volt socket for on / off & again powering the socket off via the key has the DZ7 delay 5 seconds before shutting down. If I change the Delayed Shutdown setting to Off, then my D7Z turns off immediately when power is removed, same as yours.

Top