Cell Phones

Fido account password reset doesn't work

  • Last Updated:
  • Jan 16th, 2018 2:05 pm
[OP]
Deal Expert
Mar 23, 2009
19980 posts
6213 upvotes
Toronto

Fido account password reset doesn't work

www.fido.ca account info password reset option doesn't work for me at all. Clicking on the link does nothing. I've tried multiple browsers on both macOS and Windows 10 and nothing happens.

Does the same happen for you?

I'm talking about the "Forgot username and/or password?" or "Forgot your password?" link in the account login box.

https://www.fido.ca/consumer/easyloginr ... Modal=true
4 replies
[OP]
Deal Expert
Mar 23, 2009
19980 posts
6213 upvotes
Toronto
Weird. I just tried Edge in Windows 10 and still nothing. Clicking the "Forgot..." link does absolutely nothing.
Deal Addict
User avatar
Jul 15, 2003
3386 posts
817 upvotes
Ontario, Canada
When you click that link it doesn't open a new page. it just opens a different overlay or popup. There is no indication that you clicked the link until that new overlay magically shows up. I assume the windows and mac computers are both on your network? maybe your home internet connection for some reason has issues contacting whatever authentication service they are using. so you click the link and it fails to communicate to the backend and also fails to inform you of this failure.

Try it on a computer that is not connected to your home internet.
[OP]
Deal Expert
Mar 23, 2009
19980 posts
6213 upvotes
Toronto
Kevinck wrote: When you click that link it doesn't open a new page. it just opens a different overlay or popup. There is no indication that you clicked the link until that new overlay magically shows up. I assume the windows and mac computers are both on your network? maybe your home internet connection for some reason has issues contacting whatever authentication service they are using. so you click the link and it fails to communicate to the backend and also fails to inform you of this failure.

Try it on a computer that is not connected to your home internet.
Ah I see. Works fine on my office computer. Yes, my Mac and PC at home are on the same network (Bell Fibe Gigabit). Note though it doesn't work on my iPhone either over LTE, and this is on Fido's own cellular network.

Fido's website has some kinks that need to be worked out. These types of issues don't need to happen. Another one I've noticed is that if I get a private message from a Fido mod (trying to troubleshoot something for me), and then I reply with a quote of that person's message, usually I can't send the reply. Why? Because the quotes include HTML links generated by Fido itself, but such HTML links are not allowed in messages from customers. Either I manually delete the links or else just don't quote anything.

You'd think they'd catch this sort of stuff during beta testing.

BTW, the reason I am in contact with the Fido mods is because I can't log into my Fido account from my phone. Works fine on the computer, but not on the phone through the dedicated app. It claims I am a Rogers customer so I should use the Rogers app, but I am not a Rogers customer. :facepalm:

Top