Computers & Electronics

Foscam & Xplornet Internet Issue

  • Last Updated:
  • Mar 7th, 2016 8:25 pm
Tags:
None
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON

Foscam & Xplornet Internet Issue

I bought a new Foscam FI9821Wv2. I have dyndns pro.

Camera IP: 192.168.1.130
Port: 8080

In my router (linksys e3200) I have ddns setup to my account. Under port forwarding I have 8080 / 8080 / TCP / 192.168.1.130.

I can log in to my camera fine using a browser and the IP address. But when I try to use my dyndns host name, it takes me to the Xplornet modem login page, what their employees would use to log in to troubleshoot the modem.

What am I doing wrong?! I have one set up at home the same way and it works perfectly (with Start Communications as my ISP)
23 replies
Sr. Member
Feb 2, 2014
500 posts
225 upvotes
Slawek wrote: I bought a new Foscam FI9821Wv2. I have dyndns pro.
Under port forwarding I have 8080 / 8080 / TCP / 192.168.1.130.
Set it to both UDP and TCP in the port forwarding rule.
Sr. Member
Feb 2, 2014
500 posts
225 upvotes
Slawek wrote: I bought a new Foscam FI9821Wv2. I have dyndns pro.
Under port forwarding I have 8080 / 8080 / TCP / 192.168.1.130.
Also is this a DSL modem and is it in gateway mode or bridge mode.
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
It's 4G fixed wireless, I'm not certain what "mode" it's in
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
technocar2 wrote: Set it to both UDP and TCP in the port forwarding rule.
I changed it to BOTH, same result
Sr. Member
Feb 2, 2014
500 posts
225 upvotes
Slawek wrote: It's 4G fixed wireless
I see. Basically what is happening is that your 4G modem is not forwarding the port 8080 to your router (most likely its reserved for remote modem configuration). So you will have to check if you 4G modem has port forwarding feature or better yet can it be put into bridge mode or something similar. Can you log into your 4G modem.
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
technocar2 wrote: I see. Basically what is happening is that your 4G modem is not forwarding the port 8080 to your router (most likely its reserved for remote modem configuration). So you will have to check if you 4G modem has port forwarding feature or better yet can it be put into bridge mode or something similar. Can you log into your 4G modem.
No I can't, I don't think that Xplornet will just give me that information.
Deal Addict
Nov 12, 2006
2006 posts
992 upvotes
London
I suspect you share a WAN IP among the other WISP subscribers.
You don't have a unique external IP.
It's like being behind a router and don't have access to the required port forwarding ability.

A similar thing happens with Windows remote desktop.
You can't port forward to get access.
You need to use a service such as Teamviewer.
Sr. Member
Feb 2, 2014
500 posts
225 upvotes
Ok, so since 8080 is reserved for 4g modem remote configuration and we have no way to acces the modem configuration page we will have assume that the modem is in bridge mode and thus will forward any other port that's not reserved. In that case you will have use a different port. Your camera is plugged into a DVR that connected to the router? Right? If so you will have to put DVR to a different port. 16854 is a good port you can use.

Edit: just looked at your camera, it has a built in DVR and it records to a SD card. So you will have to access its settings page and look for something that allows you to change its port.
Deal Addict
Nov 27, 2005
3160 posts
331 upvotes
arisk wrote: I suspect you share a WAN IP among the other WISP subscribers.
You don't have a unique external IP.
It's like being behind a router and don't have access to the required port forwarding ability.

A similar thing happens with Windows remote desktop.
You can't port forward to get access.
You need to use a service such as Teamviewer.
Double NAT? That would be quite horrible.
Sr. Member
Feb 2, 2014
500 posts
225 upvotes
If in fact its double NAT then its impossible to do what OP wants.
Deal Addict
Nov 27, 2005
3160 posts
331 upvotes
It's pretty easy to verify if you can see the IP that the modem has. Then just compare that with an external site such as this.
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
I've tried all that, yes. Including the hostname:8080. I tried various ports, same result. I manually set the IP of the camera to .130
Jr. Member
Sep 3, 2007
159 posts
33 upvotes
Slawek wrote: No I can't, I don't think that Xplornet will just give me that information.
I believe the following are fairly standard:

Username: admin
Password: xplornet4g

If not, you should be able to call and ask. They gave these to me during a service call and I've seen the same posted elsewhere. I don't believe this gives full access to the modem (it says
"Login as Enduser"), but it may have what you're after. I do seem to have access to Network > Port Management >Port Forwarding if that's what you need.
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
Uncle Chester wrote: I believe the following are fairly standard:

Username: admin
Password: xplornet4g

If not, you should be able to call and ask. They gave these to me during a service call and I've seen the same posted elsewhere. I don't believe this gives full access to the modem (it says
"Login as Enduser"), but it may have what you're after. I do seem to have access to Network > Port Management >Port Forwarding if that's what you need.
Yes! I got in.. now I am faced with this:

[IMG]http://i.imgur.com/2WyxWfQ.png[/IMG]

What do I do?
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
technocar2 wrote: Ok, so since 8080 is reserved for 4g modem remote configuration and we have no way to acces the modem configuration page we will have assume that the modem is in bridge mode and thus will forward any other port that's not reserved. In that case you will have use a different port. Your camera is plugged into a DVR that connected to the router? Right? If so you will have to put DVR to a different port. 16854 is a good port you can use.

Edit: just looked at your camera, it has a built in DVR and it records to a SD card. So you will have to access its settings page and look for something that allows you to change its port.
I'm so close to figuring this out look at what I posted, I got Into the modem and there is a port forwarding section but it gets into lock ports and stuff. Can you keep helping?

Do I need to change my camera IP settings to match what's in there?
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
So I found out I'm supposed to login to the modem, turn off the firewall, put in my router IP in to dmz and enable pnp. I tried and it still doesn't work
Deal Addict
User avatar
Oct 14, 2010
1407 posts
849 upvotes
Barrie ON
Slawek wrote: In my router (linksys e3200) I have ddns setup to my account. Under port forwarding I have 8080 / 8080 / TCP / 192.168.1.130.

I can log in to my camera fine using a browser and the IP address. But when I try to use my dyndns host name, it takes me to the Xplornet modem login page
Are you logging in from your own LAN, or from the WAN ( e.g. cell phone, or library computer) when performing your tests?

If you are testing from the WAN, and it works when you enter the public IP into your browser, then it should certainly work when you enter the DDNS name without requiring any additional port forwarding changes. The only thing that would prevent it from working is if the DDNS name was not being translated to your proper public IP. To test this simply start a ping to your DDNS name and verify it is trying to ping the same IP address that you had just manually entered in your browser.


If you are testing from within your own LAN, and you are connecting to 192.168.1.130:8080 successfully, but not when you enter the DDNS name, then I have found that is often normal in many situations. Although it is convenient to test things from your own LAN, you should really be doing your tests from a device on the WAN.
[OP]
Deal Addict
User avatar
Jan 8, 2007
3917 posts
878 upvotes
Kingston, ON
Rick007 wrote: Are you logging in from your own LAN, or from the WAN ( e.g. cell phone, or library computer) when performing your tests?

If you are testing from the WAN, and it works when you enter the public IP into your browser, then it should certainly work when you enter the DDNS name without requiring any additional port forwarding changes. The only thing that would prevent it from working is if the DDNS name was not being translated to your proper public IP. To test this simply start a ping to your DDNS name and verify it is trying to ping the same IP address that you had just manually entered in your browser.


If you are testing from within your own LAN, and you are connecting to 192.168.1.130:8080 successfully, but not when you enter the DDNS name, then I have found that is often normal in many situations. Although it is convenient to test things from your own LAN, you should really be doing your tests from a device on the WAN.
I can only access from Lan. Xplornet forces a double NAT

Top