Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Addict
User avatar
Apr 12, 2013
1263 posts
360 upvotes
Markham
bridonca wrote: The PAP2, in my not so humble opinion, is a piece of garbage. You would not have this problem if you used an Obihai device. I should add, with a properly configured network, the PAP2 works fine. The problem is that that is rare with consumer networking gear. Thus the hate for the PAP2.


What do you have for a router, and a modem? Some routers are just not cut out to handle VOIP packets, and modems that act as routers are usually awful.
i am leaving the country soon and it was the cheapest local voip adapter i could find. also i had great experiences with it when i was on italkbb. anyways i am stuck with it now. what to do?
Deal Addict
May 26, 2011
1802 posts
474 upvotes
Vancouver
adamm wrote: It's been a couple weeks now that incoming calls isn't working. Anyone have any ideas? Nothing has changed in my network. Incoming calls just stopped working one day. I've tried rebooting my ATA and Router (which usually fixes the problem 99% of the time), but still no worky.
In order to give useful advice, we need to know what ATA and router you use. I can give you some general troubleshooting:

- Be sure your ATA is configured as per the official guide at http://forum.fongo.com/viewforum.php?f=15
- Try to change the SIP port your ATA listens on to a random number between 20000 and 65535.
- If you're using voip.freephoneline.ca, change to voip2.freephoneline.ca or vice versa.

These may or may not solve the problem, as they are just guesses not based on your specific situation. Let us know how things go.
kangarooz wrote: ok guys i finally got my modem, which is a PAP2T. So i use the general guide to the linksys voip machines on the Freehomephone line website and now its setup. when i call my fake fongo number on my phone, everything works perfectly. However when i call any non fongo number, i do not get the ring after you dial the number, and also i cannot hear the audio from the other side.
1) Your PAP2T is an ATA, not a modem.
2) Your service provider is called Free Phone Line, not Freehomephone line.
3) Please confirm that you set the following on your ATA's SIP tab:

Handle VIA received: yes
Handle VIA rport: yes
Substitute VIA Addr: yes

4) Since you have Rogers, please double check that you're using the Rogers proxy voip4.freephoneline.ca:6060.
5) Please try to change your SIP Port (Line tab) to a random number between 20000 and 65535.
6) If your service still isn't working, let us know if your Netgear router receives a public IP address from Rogers, or if your Cisco modem is also doing NAT. From there we can troubleshoot further.
bridonca wrote: The PAP2, in my not so humble opinion, is a piece of garbage.
The PAP/SPA family of ATAs were an industry standard for many years until Linksys EOL'd them in 2012. Did you know that not only were Sipura and Obihai ATAs designed by the same engineers, those engineers also invented the ATA at Komodo technology 15+ years ago? OBi ATAs are really the latest versions of the PAP/SPA ATAs - granted, with more/better call routing features, better hardware, and better audio quality - but the hundreds of thousands of people who used PAP/SPA ATAs before Obihai went on the market would likely not call a genuine PAP/SPA garbage (with the possible exception of the SPA3xxx).

One difference in terms of NAT traversal between OBi ATAs and PAP/SPAs is that OBi ATAs have the X_DiscoverPublicAddress setting enabled by default. This does, as far as I am aware, the same thing as the settings I pasted to kangarooz above. This is why we don't see as many one-way audio complaints with the OBi ATAs.

May I suggest next time instead of calling his ATA garbage you offer him some advice for how to configure it to work with FPL's curiously-configured servers?
Deal Addict
User avatar
Nov 23, 2008
3430 posts
1684 upvotes
Halifax
PianoGuy wrote: The PAP/SPA family of ATAs were an industry standard for many years until Linksys EOL'd them in 2012. Did you know that not only were Sipura and Obihai ATAs designed by the same engineers, those engineers also invented the ATA at Komodo technology 15+ years ago? OBi ATAs are really the latest versions of the PAP/SPA ATAs - granted, with more/better call routing features, better hardware, and better audio quality - but the hundreds of thousands of people who used PAP/SPA ATAs before Obihai went on the market would likely not call a genuine PAP/SPA garbage (with the possible exception of the SPA3xxx).

One difference in terms of NAT traversal between OBi ATAs and PAP/SPAs is that OBi ATAs have the X_DiscoverPublicAddress setting enabled by default. This does, as far as I am aware, the same thing as the settings I pasted to kangarooz above. This is why we don't see as many one-way audio complaints with the OBi ATAs.

May I suggest next time instead of calling his ATA garbage you offer him some advice for how to configure it to work with FPL's curiously-configured servers?
I am well aware of history of the Cisco ATA devices. That the entire engineering team that made the device 9 years ago left the company so they could make a better ATA should speak volumes on how out of date this ATA is. Nothing of significance had been updated on this ATA for 10 years! That is why I strongly recommend no one buy this junk, especially when there are better, supported ATA devices out there that actually work! And I agree, I cannot help kangarooz as much anymore, but if I can stop someone else from buying this pile of dung, I will be happy!
kangarooz wrote: too add i am using the cisco rogers modem and the netgear wnr2000 (also not my purchase lool)
Hopefully the Cisco Rogers Modem is in bridge mode. Bridge mode disables the router in the modem, and lets the netgear wnr2000 do all the routing. You might have to forward RTP ports from the router to the ATA. By default, the PAP2 uses ports from 16384 to 16538 Forward those from the router to the ATA. Save everything, power down router. modem and ATA, then power them back up after 30 seconds. Hopefully that will solve your problem.

Rogers might not like the freephoneline server, check here for more and use that if what I have suggested does not work.

http://support.freephoneline.ca/entries ... redentials
Deal Addict
User avatar
Apr 12, 2013
1263 posts
360 upvotes
Markham
i changed the SIP ports to 60000 and i have done this

Handle VIA received: yes
Handle VIA rport: yes
Substitute VIA Addr: yes

I had done a separate wifi downstairs in the basement but i will be turning back on bridging mode so it works as a full time modem instead.

i have done all of the above but still it doesnt work. however when i call my fongo number everything works like butter. including the ringer, and the audio, really weird.

just to give you guys a clear outline:

To:Fongo everything is fine.
To/from any other number:
cant hear audio from the other side
cant hear the buzz after you dial the number.

ok i am gonna start over again from step 1. wish me luck.
Deal Addict
User avatar
Apr 12, 2013
1263 posts
360 upvotes
Markham
ok i got the solution here. like i said i had both my modem and router running as routers. therefore the ATA was running behind 2x routers. my previous experience with this same ATA when i was with iTalkbb was that the ATA had to be behind 1 modem. when i read the suggestions above you guys told me to do put the modem in bridge mode the ATA worked behind my main router. however i live in one of the those houses were the Ethernet ports were in every room, therefore i wanted to leave the ATA in the basement with my modem. therefore the setup i have is MODEM (with the router function on) >>> ATA in port 2 and MODEM >>>> router on port 1. anyways thanks guys. the quote that freephoneline gave me was tuesday for the port in from rogers, I hope its done by tomorrow as I will be flying on tuesday. anyways thanks alot guys. and if anyone has any questions on my setup please let me know. btw guys what codec are you guys using? which setting is the best sound quality/ most stable.

Thanks alot guys :) ))
Deal Addict
May 26, 2011
1802 posts
474 upvotes
Vancouver
G.711u. Glad to hear it's working. Double-NAT does indeed frequently cause issues with VoIP.
Deal Addict
User avatar
Apr 12, 2013
1263 posts
360 upvotes
Markham
PianoGuy wrote: G.711u. Glad to hear it's working. Double-NAT does indeed frequently cause issues with VoIP.
thanks for all you help man, couldnt have done it without you guys :)

also, is freephoneline generally on time with the port in time? just wondering as its gonna be tight with my flight schedule
Newbie
May 19, 2013
7 posts
1 upvote
kangarooz wrote: thanks for all you help man, couldnt have done it without you guys :)

also, is freephoneline generally on time with the port in time? just wondering as its gonna be tight with my flight schedule
for me yes, they said my number was suppose to be ported today and its was done about 30 min ago.
Deal Addict
User avatar
Nov 15, 2013
1738 posts
1416 upvotes
Toronto, ON
Webslinger wrote: I'd strongly recommend either an

Obi202

or

OBi200

Also, https://www.acrovoice.ca/obistore/





I'm not sure what you mean.

http://www.obihai.com/amzn/obimatrix (avoid the i302)

and

http://www.obihai.com/matrix
http://www.obihai.com/faq/About-the-OBi ... and-OBi110



I would just activate through the OBiTALK portal by selecting the Freephoneline profile (it depends on each person's situation). If you have problems, someone can probably assist you.
http://www.obitalk.com/obinet/

http://support.freephoneline.ca/entries ... redentials

(setup is similar, regardless of the OBi you get)
http://forum.fongo.com/viewtopic.php?f=15&t=16090
or
http://forum.fongo.com/viewtopic.php?f=15&t=16196
Wonderful!
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3296 upvotes
So, there's a new firmware update for OBi200 and OBi202s today (and the 300 series, but I doubt anyone here is using them):
http://www.obitalk.com/forum/index.php?topic=8982

Firmware release 4581

The only thing I cared about was "T.38 Faxing enhancements", which is pretty vague. I'm not sure what changes were made.

But for the first time with an OBi ATA, I successfully faxed 1-855-392-2666 (Canon fax test) and 1-888-473-2963 (HP fax test) using FPL with T.38 protocol enabled. Previously, all of my fax calls would not complete (drop pretty quickly) using FPL when T.38 was enabled.

I've been able to fax fine using G.711u codec only. But this is the first time I've managed to send faxes with T.38 protocol enabled using FPL.

In your call status page, during fax transmission, you'll see the following:
"Audio Codec = tx=; rx=G711U"
(which doesn't specifically state T.38, but this is the only indication OBi seems to provide)

If you're not using T.38, you'll see "Audio Codec = tx=G711U; rx=G711U" instead, which just means you're using the G.711u codec only.

T.38 is an unadvertised feature of FPL, and it's pretty nice given you'll only get this via fax portals when using VoIP.ms and Anveo.com (and have to pay more to use them).

Anyway, I was pleasantly surprised to see this working finally.
Deal Fanatic
User avatar
Sep 21, 2012
5065 posts
582 upvotes
Mississauga
Here's a good VoIP adapter for those who can't find a deal on the Obi

http://www.amazon.ca/Grandstream-GS-HT7 ... 007EYY3XU/

39.99 + free shipping


I bought one used a few months ago to replace a dead PAP2T. Setup was extremely easy. SIP address, user name, and password, and that is. It actually took me longer to find an online manual than to setup. Initially there was a problem with CallerID with my cordless Panasonic phones, but a f/w update fixed that.

No need for portforwarding or anything complicated.
Favourite Games: NieR (PS3), Catherine (PS3), Persona 3 FES/Portable (PS2/PSP), Final Fantasy IX (PSX), Persona 4 Golden (PSV), Witcher 1,2,3 (PC), Skyward Sword (Wii), Pokemon Colosseum (GC), Fire Emblem Awakening (3DS), Shin Megami Tensei IV (3DS), Majora's Mask (3DS), Bravely Default (3DS)
Jr. Member
Nov 25, 2002
123 posts
Burnaby
Have a Dlink DI524 router and Obi100 ATA. Used the obi website to provision the ata. For both outgoing and incoming calls, the other party can hear me, but I cannot hear them.

Also tried to manually set up the ATA using the fongo settings as posted by PianoGuy in message 3918 and some of the other settings such as voip2 instead of voip, but no change.

Any suggestions?

Top