Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: and I know you said to unplug the devices each time
Well, it's mostly the boot order I'm concerned about. That is, if you're going to reboot your router, also reboot your ATA afterwards.

But sometimes turning them off is just the only way.
I definitely will be making as minimal changes as possible as I don't feel like going downstairs every time to unplug the devices one by one.

You should be able to reboot the ATA via webui.
Dial ***1. Enter that IP address into a web browser. Then click "Reboot" in the upper right when you want to reboot the ATA.

So, you'd want to reboot your router. Wait a bit for it to be fully up. Then reboot the ATA.

Note that the only foolproof method for me, sometimes, is to actually do this: turn off both the router and the ATA. And then turn on the router. Wait. Turn on the ATA.

But maybe rebooting the ATA via the webui will work for you. I don't have a R7000 to test.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
I'm going to repost this, since it seems timely . . .

These instructions do not address "this account is not valid" messages (you would need to contact FPL/Fongo for that problem).
"If you’re getting an “invalid account” error messages, or if people trying to call you are hearing "invalid account" or a busy signal, please log in to your account online at https://www.freephoneline.ca/followMeSettings and reset your Follow Me settings. Please ensure your temporary FPL number is not listed as one of the Follow Me numbers."

If you have calls going straight to voicemail, login at https://www.freephoneline.ca/voicemailSettings and ensure "Rings before voicemail" is greater than 1. Also, check in your ATA to ensure you don't have "Do Not Disturb" enabled. This is found after logging into your ATA or at Obitalk.com under Voice Services-->SP(FPL) Service-->Calling Features-->DoNotDisturbEnable. Ensure there is no checkmark under "Value".


Getting one way audio issues with an OBi200/202 and Freephoneline? Are incoming calls not ringing?

Often the problem is due to RTP packets not reaching the ATA. Common causes involve poorly functioning SIP ALGs (especially true with certain Netgear routers) in routers or NAT firewalls.

Hardware Specific Issues

A. Netgear R7000 routers
Disable SIP ALG. If you have a Netgear R7000 router, you may need to install XWRT firmware. Afterwards, turn off the router and the ATA. Turn on the router. Wait for it to be fully up and running (including wi-fi). Then turn on the ATA. Download XWRT-Vortex here: http://xvtx.ru/xwrt/download.htm

B. Nettis 4422 modem from Carry Telecom (click the "Internet" tab)
http://www.carrytel.ca/support.aspx
Q : DSL - My VoIP phone does not work with Netis 4422 modem.
A : Please download the newest Netis firmware at www.carrytel.ca/download/netis1228.zip. Unzip the netis1228.zip file and update the firmware file netis1228.img for your modem. The new firmware has been tested and working with most of Voip phone providers





i. Before beginning the steps below make sure whatever modem/router combo your ISP gave you is in bridge mode if you are using your own router. Call/contact your ISP if you have to.


1. Disable any and all port forwarding and/or DMZ in your router. Port forwarding creates security issues and can open the door to SIP scanners and hackers. If you're having trouble with SIP scanners and/or telemarketers, visit newegg-ca-obi200-39-99cad-obi202-59-99c ... st24563087

2. If you used the Obitalk web portal (www.obitalk.com) to configure your ATA, keep in mind that you must continue using it to configure your ATA. Otherwise whatever settings you change will eventually be overwritten by what you previously entered at obitalk.com anyway. If you wish to disable this behaviour, dial ***1. Enter that IP address into a web browser. Navigate to System Management-->OBiTalk Provisioning-->select Disabled for the method. Save. Reboot ATA. Now obitalk.com won't overwrite whatever changes you make via the device's interface (via IP address).

Pick one method (obitalk.com) or the other (IP address of device) for changing device settings. But do not use both methods. Keep in mind that activating Google Voice requires using the Obitalk.com web portal.

(In Obitalk.com, you will need to enable and enter expert settings to do the following, if you want to use Obitalk.com.)

3. Ensure you're using 3.1.0 (Build: 5135): http://fw.obihai.com/OBi202-3-1-0-5135.fw
Yes, this firmware works on an OBi200/202.

Refer to manual firmware update instructions here: https://www.obitalk.com/forum/index.php?topic=9.0


Avoid 3-0-1-4972: http://www.obitalk.com/forum/index.php?topic=10520.0

4. In your Obihai ATA or at Obitalk.com, Navigate to Voice Services-->SP(FPL) Service-->X_UserAgentPort
Pick a random number between 30000 and 60000

(submit/save/reboot)

5. Navigate to Service Providers-->ITSP Profile (FPL)-->SIP

i) ensure X_DiscoverPublicAddress is enabled (it is by default)

ii) enable X_UsePublicAddressInVia (it's not by default)
You will need to uncheck default, device default, and Obitalk settings boxes. Then check the box to enable the feature

(submit/save/reboot ATA)

6. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

7. If that doesn't work, you can also try enabling X_DetectALG (Navigate to Service Providers-->ITSP Profile (FPL)-->SIP)

(submit/save/reboot ATA)

8. Retest
When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

9. If that still doesn't work, disable X_DetectALG. And submit/save/reboot ATA.

10. If there are still problems, try disabling the SIP ALG feature in whatever router or modem/router combo it is that you're using:
http://www.obihai.com/faq/sip-alg/calling-out
I'm of the opinion Apple routers don't offer this feature, but you might as well check. If you manage to disable SIP ALG in the router, then retest. If you received a modem/router combo, from your ISP ask your ISP. It is typically better to stick the modem/router combo from your ISP in bridge mode and use an external router.

See here for an example on how to disable SIP ALG in a router: http://www.obihai.com/faq/sip-alg/disable-alg

Image

Save settings.
Turn off both router and ATA. Turn on router. Wait for router to be fully up and transmitting data. Turn on ATA.
Then retest by calling your FPL phone number. If the problem is solved, don't continue.

11. Try Proxyserver voip4.freephoneline.ca:6060
visit http://forum.fongo.com/viewtopic.php?f=15&t=16196 (look at the .pdf)
(I'm of the opinion that step #7 makes this step redundant, but trying this is worth a shot anyway).
Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number. If the problem is solved, don't continue.

voip4.freephoneline.ca:6060 is a SIP server whose purpose is to help those with SIP ALG issues (can't disable it in the user's router, for example).

So steps #7, #10, and #11 are all related. They are attempts to address a problem created by SIP ALG.


12. Try this at your own risk: use voip3.freephoneline.ca as the proxyserver
voip3.freephoneline.ca is intended for testing purposes only--or for those who receive explicit permission to use it. Using it for an extended period may get your account banned. However, if using voip3.freephoneline.ca does work, you should open up a ticket with support and let them know that you can't get two-way audio any other way: https://support.fongo.com/anonymous_requests/new

If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

FPL configures its SIP servers differently than many other VoIP providers.
voip3.freephoneline.ca conforms more to the norm. But using it without permission can get your account banned.
If you'd like to avoid getting your account banned, use Proxyserver voip.freephoneline.ca, voip2.freephoneline.ca, or voip4.freephoneline.ca:6060 instead and skip to step #14.

13. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.

Then retest by calling your FPL phone number.

14. If none of that helps, then, unfortunately, you're pretty much stuck with port forwarding your RTP (UDP) port range 16660-16798 from your router to your ATA. For reference, that range can be found under ITSP Profile (FPL)-->RTP. Then look at LocalPortMin and LocalPortMax. RTP packets need to reach your ATA in order for you get incoming audio. Quite often, when the one way audio issue occurs, this is the problem. RTP packets are not reaching your ATA. Ideally, one should not have to port forward in order to achieve proper two-way audio, since port forwarding does create security issues. Port forwarding should only be done when everything else fails.

Refer to the port forwarding section of your router manual to learn how to port forward to your ATA. If a router was given to you by your ISP, call your ISP.

15. Retest. When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.


Then retest by calling your FPL phone number.

16. If all else fails, try posting at http://forum.fongo.com/viewtopic.php?f= ... &start=300 and/or open a support ticket at https://support.fongo.com/anonymous_requests/new
If no responds to your support ticket, provide the ticket number in a private message to Fongo Support: http://forum.fongo.com/ucp.php?i=pm&mode=compose&u=7852

When I say Retest, retest always includes the following: A. Turn off both router and ATA. B. Turn on router. Wait for router to be fully up and transmitting data. C. Turn on ATA.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: However I didn't want to take any chances so I unplugged everything and plugged them back in one by one. Everything is again up and running and seems to be fine. I am done with this tonight.
Thanks again.
Good stuff! I'm mostly just interested in the reboot order. If you're going to change stuff in your router and reboot, then after your router is back up and running, reboot the ATA as well.

But the foolproof method is to turn them both off.
Deal Expert
Jan 17, 2009
18366 posts
26209 upvotes
ONTARIO
Webslinger wrote: Good stuff! I'm mostly just interested in the reboot order. If you're going to change stuff in your router and reboot, then after your router is back up and running, reboot the ATA as well.

But the foolproof method is to turn them both off.
So I just decided to call one last time. It took like 10 seconds to connect and went right to voice mail. What a load of crap. I am so tired of this.
Sr. Member
Oct 30, 2012
994 posts
267 upvotes
Hamilton
Webslinger wrote: Good stuff! I'm mostly just interested in the reboot order. If you're going to change stuff in your router and reboot, then after your router is back up and running, reboot the ATA as well.

But the foolproof method is to turn them both off.
I usually just do reboot router than reboot Ata through Web gui without shutting it off. But then again it's on Asus which seems in harmony with obihai devices.

BobSaggert you moved shield to wifi? And I connected mine to ethernet. Wonder why you switch to wireless you can reply in shield thread not to hijack this.

But yeah since I was closely following obihai threads I knew netgear isn't working great with obihai. So I skipped boxing deal and actually ended up selling my ac66u and buying ac68u for same amount of money so was free upgrade except gas money.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: So I just decided to call one last time. It took like 10 seconds to connect and went right to voice mail. What a load of crap. I am so tired of this.
Are you using XWRT-Vortex? Or did you go back to some version of DD-WRT?

The thing is I've only got confirmation from people that XWRT works: http://xvtx.ru/xwrt/download.htm
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
puska83 wrote: But yeah since I was closely following obihai threads I knew netgear isn't working great with obihai.
Not Obihai. FPL

This compatibility issue is between R7000 and FPL.
Deal Expert
Jan 17, 2009
18366 posts
26209 upvotes
ONTARIO
Webslinger wrote: Are you using XWRT? Or did you go back to some version of DD-WRT?
Nah, I am still on XWRT. I have since rebooted the ATA again which seems to fix it temporarily. Have to see how it goes once again. Never have I had such issues setting up VOIP before.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: Nah, I am still on XWRT. I have since rebooted the ATA again which seems to fix it temporarily.
Are you still on voip4.freephoneline.ca: 6060?

And your modem is in bridge mode, right?
Have to see how it goes once again. Never have I had such issues setting up VOIP before.

Yeah, when people PM me about the R7000 and FPL, I cringe. Some people won't want to install XWRT.
Deal Expert
Jan 17, 2009
18366 posts
26209 upvotes
ONTARIO
Webslinger wrote: Are you still on voip4.freephoneline.ca: 6060?

And you're in bridge mode, right?
Yes I haven't changed any ATA settings since the time it was working for 50+ minutes. Then I had to change some router settings and rebooted. That's when the issue came back.
I have since rebooted the ATA (about 15 minutes ago) and so far incoming calls are still working. I will have to try tomorrow and make sure they are still getting through.

As for bridge mode, my cable modem is a Thomson DCM475 so it has no router functionality.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: Y I will have to try tomorrow and make sure they are still getting through.
You wouldn't, by chance, be running timed scripts on the router? Just curious

Anyway, when you make changes in the router, reboot it. Wait to ensure it's fully up (including wifi). And then reboot the ATA.
Alternatively, you may need to turn them off (and then keep in mind the turn on order).

I would, actually, re-enable SIP Passthrough, only because it's been quite some time since I disabled it and tested. In real ASUS routers, FPL works with SIP Passthrough enabled.

Other than that, sorry. I'm out of ideas. Or the ones that I do have aren't safe ideas since they involve port forwarding.
Deal Expert
Jan 17, 2009
18366 posts
26209 upvotes
ONTARIO
Webslinger wrote: You wouldn't, by chance, be running timed scripts on the router? Just curious

Anyway, when you make changes in the router, reboot it. Wait to ensure it's fully up (including wifi). And then reboot the ATA.
Alternatively, you may need to turn them off (and then keep in mind the turn on order).
No I am not running any scripts.
I also did follow that method. I unplugged the router and ata. Plugged in the router and let it fully boot up (wifi and everything). Then I plugged in the ATA.
The first time I did that, incoming calls were working for a good 50+ minutes(I was constantly phoning myself to test). Then I had to make changes to the router which needed a reboot. So after reboot, I unplugged everything and followed the same steps.. Thought it was working but incoming calls starting going right to voice mail after 5-10 minutes again.

I have since rebooted the ATA via the web ui and incoming calls have been working for the past 30 minutes (just tested a second ago).
I will have to test it tomorrow and hope calls are still coming through and hope that the router never goes down or has to be rebooted again (heh).

Thanks again for the help.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: and hope that the router never goes down or has to be rebooted again
Yeah, it's not fun. I got a UPS, in part, to help reduce the chances of a power outtage messing up my device boot order.
But I'm always testing inbound calls even when I notice an ISP outtage (after the service goes down and after my modem obtains an IP again).
With newer routers now, device boot order has become a pain.
Deal Addict
Jan 18, 2009
2524 posts
1103 upvotes
JonSnow wrote: Yeah I remember reading a post like that, but you are using an Android box if I'm not mistaken. I'll probably move to the Nvdia Shield TV once the prices drop a bit further.
some peoples bought the obi202 because of the second phone port (the obi202's router is a PoS.) While that simplicity is nice, not many peoples knew that you can use any android device as extra handset for the obi200. My minix x8 tv box and my galaxy S5 are extra handsets for the obi200.
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3302 upvotes
BobSagget wrote: I have since rebooted the ATA via the web ui and incoming calls have been working for the past 30 minutes (just tested a second ago).
I will have to test it tomorrow and hope calls are still coming through and hope that the router never goes down or has to be rebooted again (heh).
Someone on XWRT with a netgear R7000 got back to me a little earlier and wrote, "If my internet cuts out for an extended period of time (or I'm working on my router and making significant changes like IP ranges) I also need to reboot the ATA for incoming calls to work properly."

So, yeah, just keep in mind device boot order.

Top

Thread Information

There are currently 2 users viewing this thread. (1 member and 1 guest)

Jean-KristofD146