Freebies

freephoneline.ca - Free Local Soft Phone Line for lifetime VOIP

Deal Addict
User avatar
Apr 1, 2015
1174 posts
660 upvotes
NOYB
Dahlya wrote: He is, but he doesn't help on RFD anymore. I know him well. He eventually got a bit frustrated.



He does, but he's still alive and kicking.



Oh, that's good that FPL is working for you again. The problem did involve the router portion of the device Fido gave you. Enjoy the weekend!
Please forward my gratitude to him. His posts helped me a lot in setting up VoIP
And to you too. :)
Zoomer + VoIP.ms user

Stay away from OT/PRC and whoever acts like an xxxxxxx there.
Newbie
Oct 25, 2008
81 posts
23 upvotes
Hi Dahlya

Thanks for the detailed follow up. Generally keeping the udp timeout higher than the keep alive keeps the port open for replies. Which could result in no ring if closed when an incoming call comes in. But if it is somehow corrupted and not getting through keeping it alive will not allow it to reset.
A reboot of the router / gateway should clear that. Which it does for this recent issue. Or as you suggested changing the SIP port also.

This may be an issue with DD-WRT it is a recent build and has worked on other builds fairly well for years

It’s odd the commands do not work from admin or telnet no, double checked on the forums.
Maybe time for a default or just going back to a more stable build.
Jr. Member
Nov 23, 2012
189 posts
102 upvotes
Ontario
User451 wrote: A reboot of the router / gateway should clear that. Which it does for this recent issue. Or as you suggested changing the SIP port also.

That suggests a corrupted NAT connection developed in your router. In the event you experience the problem again, you can increase your ATA's Reg Retry Intvl to let the corrupted connection timeout before your ATA attempts another registration after a failed attempt.

For example, if your Assured UDP timeout is 120 or 180 seconds, it would be fine to increase Reg Retry Intvl in your ATA to 185 seconds.
I have never heard of a default Assured UDP timeout value in a DD-WRT build being higher than 180s, but I imagine what I haven't heard could fill several encyclopedias.


Which could result in no ring if closed when an incoming call comes in.
Related discussion on RFD can be located
here with an older DD-WRT version example using VoIP.ms.
Pianoguy wrote:The other problem was timeouts. When you register to VoIP.ms, your router "remembers" this connection for (as we discovered earlier) 120 seconds. That is why when you first plugged your cable in, you were able to receive calls for about two minutes.
The Assured UDP DD-WRT timeout is 120 seconds in this example using an older DD-WRT build.

Pianoguy wrote:We set up keep-alive every 75 seconds so that the connection would remain active permanently. Satisfying the following equation will make things work properly:

UDP Unreplied Timeout (65) < Keep-alive Interval (75) < UDP Assured Timeout (120) < SIP Registration Failure Retry Wait Time (180)



Also, the following discussions
here, here, here, and here may be of interest.

A number of Asterisk admins at dslreports have settled on using an Unreplied UDP timeout of 10 seconds. I use 18.

The common statement made is that if these conditions are satisfied, SIP services work:
UDP Unreplied Timeout < Keep-alive Interval (20) < UDP Assured Timeout < SIP Registration Failure Retry Wait Time.

My settings satisfy those conditions. I do not have to reboot anything, switch proxy servers, or change local sip port.
By the way, I'm told the reason Grandstream ATAs can randomize local SIP port is due to a recommendation made by Mango.

User451 wrote:It’s odd the commands do not work from admin or telnet
Sorry, I don't know why that would be.

It's not recommended to increase the 20 second NAT Keep Alive Interval in your ATA when using Freephoneline.
But you can increase Reg Retry Intvl in your ATA above 120s without causing a problem, to 185s, other than it will take longer for your ATA to attempt another registration in the event it fails to register.
If you decrease Reg Retry Intvl you run the risk of obtaining a temporary IP ban.

That only leaves you with possibly needing to reduce Unreplied UDP timeout at some point. Unfortunately, both UDP timeout setting changes are not available via DD-WRT Web-GUI.
Newbie
Oct 25, 2008
81 posts
23 upvotes
On older router DDWRT 42617 build Mar 2020, found these directories and values
Linux 3.10

cat /proc/sys/net/ipv4/netfilter/ip_conntrack_udp_timeout
120

cat /proc/sys/net/ipv4/netfilter/ip_conntrack_udp_timeout_stream
180

Newer build on mediatek router Oct 13 2020 build
Linux 4.14

There is no netfilter folder
stops here and nothing udp timeout related
/proc/sys/net/ipv4

Edit - Going back one more dir here they are

cat /proc/sys/net/netfilter/nf_conntrack_udp_timeout
3615
cat /proc/sys/net/netfilter/nf_conntrack_udp_timeout_stream
180

UPD timeout was set to 3615 playing with it yesterday
The stream timeout which I assume is Assured is not modified when adjusting the UDP timeout
Jr. Member
Nov 23, 2012
189 posts
102 upvotes
Ontario
User451 wrote:
UPD timeout was set to 3615 playing with it yesterday
If you login and navigate to Administration-->Management-->IP Filter Settings-->UDP Timeout (s),
do you see a value of 3615 seconds in Web-GUI? Is that the default value? If so, ouch. I wonder why they made that the default value.
Unreplied should never be greater than Assured at defaults.
The stream timeout which I assume is Assured
Yes, stream is Assured. Assured is the timeout that has seen packets in both directions. As such, Assured is always longer than Unreplied, which implies one direction.

It seems a bit tricky to find the values since location changes based on build. The locations you've provided are useful. Thank you.

At least now you can satisfy the conditions mentioned previously.
Newbie
Oct 25, 2008
81 posts
23 upvotes
The default upd timeout for ddwet is 120s, but because I was not able to change the udp assured timeout, I went the other way increasing it to 3615, which is longer than the registration timeout that I had increased to 3610 on the ata.
Also doubled then maximum ports to 8000 given the rather long timeout.

So far when using 3615 it has been stable. Putting it back to 120 or 19 it fails registration several times a day.

When I get a bit more time I’ll try figure out how to update the assured timeout
Jr. Member
Nov 23, 2012
189 posts
102 upvotes
Ontario
User451 wrote: I went the other way increasing it to 3615
Besides potential security concerns involved with increasing UDP timeouts to abnormally large values, there shouldn't be a need to do that, unless something different was introduced in router firmware. Although the registration interval with FPL doesn't help with keeping a NAT session alive, the keep-alive interval of 20 seconds in the ATA does.

Unreplied UDP shouldn't be set higher than Assured, given the relationship between them.

If the ATA is repeatedly failing registration, it's simple to increase Reg Retry Intvl to a higher value than the stream/Assured UDP timeout to allow the corrupted connection to timeout before your ATA attempts another registration after a failed attempt.

And to return to your older post...
Generally keeping the udp timeout higher than the keep alive keeps the port open for replies. Which could result in no ring if closed when an incoming call comes in.
That's for Assured UDP timeout and not Unreplied. If Assured UDP Timeout is smaller than the NAT Keep-alive interval, the ATA will not contact the server enough, and, as such, the NAT hole will close. In turn, incoming calls may not arrive.

Putting it back to 120 or 19 it fails registration several times a day.
Unreplied UDP Timeout needs to be several seconds less than the NAT Keep Alive Intvl.

As aleko states
aleko wrote: TL;DDWRT
Ensure your router's "/proc/sys/net/ipv4/netfilter/ip_conntrack_udp_timeout" value is always less
That's Unreplied UDP timeout. The location is just different depending on firmware build version.
aleko wrote: than keep-alive and re-register intervals on your phones/ATAs
And over here, we have hookie at dslreports repeating the same information years earlier.
hookie wrote:The NAT keepalive or registration message interval should be greater than the Tomato UDP Unreplied Timeout value but less than the Tomato UDP Assured Timeout value.
Mango wrote:Mango wrote:
Almost immediately after I did this my phone and ATA registered and started working again. Thank you very much for posting this!
Pianoguy repeats the same conditions to resolve a VoIP.ms user's issue involving DD-WRT
Pianoguy wrote:Satisfying the following equation will make things work properly:

UDP Unreplied Timeout < Keep-alive Interval < UDP Assured Timeout < SIP Registration Failure Retry Wait Time
monotious wrote:This seems to have done it. Now I can get incoming calls even after waiting a long time.



And so, we again, arrive at the following conditions:

UDP Unreplied Timeout (15) in router < NAT Keep-alive Interval (20) in ATA < UDP Assured Timeout (180) in router < Reg Retry Intvl in ATA (185)

That equation, which has been discussed in several forums, especially by Mango, works for me and on every FPL and SIP configuration I've seen, including those involving pfSense firewalls, as long as the modem issued by the ISP to the consumer is either a modem only or, instead, running in bridge mode. You are able to change Unreplied UDP Timeout, NAT Keep-Alive Interval, and Reg Retry Intvl to match those values, even if you are unable to adjust the UDP Assured Timeout value in your router.



I am busy with work and likely won't be able to respond for awhile. No matter what, I hope you find a solution that works consistently for you.
Sr. Member
Apr 29, 2014
934 posts
281 upvotes
Pickering, ON
Hi all,

Is there an Android app use this service?
Sr. Member
User avatar
Dec 29, 2001
912 posts
174 upvotes
Kitchener/Waterloo
I just switched from Rogers to Fido and nothing works now. I can not make outgoing phonecalls and incoming calls go directly to voicemail. Also when attempting to access voicemail I get a busy signal.

Using Obi202
SIP Status shows connected
Obi Dashboard shows SIP 1 (Freephoneline) registered using voip2.freephoneline.ca

Any help would be appreciated.
Deal Addict
User avatar
Feb 9, 2012
3761 posts
464 upvotes
Toronto
Is there an app you can use when away from home for calls and voicemail? I have freephoneline and use the obihai device. Thanks

Top