Computers & Electronics

Getting BSOD after recently adding RAM

  • Last Updated:
  • May 28th, 2021 11:44 pm
Tags:
[OP]
Deal Addict
Dec 24, 2008
3285 posts
994 upvotes
Belle River

Getting BSOD after recently adding RAM

Well I've also been running different software but I don't recall any BSOD or unattended reboots until after adding the RAM.

I have a stable system I've been using for quite awhile:
i7-8700
MSI Z370M MORTAR
G.Skill Ripjaws 2x16GB 3000Mhz F4-3000C15-16GVR
Radeon Rx 460 fanless
2 M.2 drives and a couple hard drives
Windows 10 Pro

I keep tonnes of tabs open in multiple browsers, various other software I like to keep running like Steam or Epic, not to game but just to communicate or do other tasks, server connections, email, just a bunch of stuff. Recently I started playing with some stuff that made me want more RAM, like virtual machines, so I decided to go up to 64GB total by adding another 32GB, XPG Z1 32GB (2 x 16GB) DDR4 3200MHz AX4U3200716G16A-DBZ.

I let it memtest completely, which does 4 passes by default, all OK. But as I started using the PC I've been having problems. Once it rebooted when I wasn't around, I kinda thought it might have been this math software I started using and had left running. But then twice since then it has BSOD while I've been using it, once without running that math software, in both cases I don't recall doing anything particularly intense, the one today I was just browsing RFD.

I don't think it's temperature related as adding 2 sticks of RAM shouldn't matter much, but I did install Open Hardware Monitor and have it logging, unfortunately I must have exited it at some point yesterday as it was not logging during today's BSOD.

Event Viewer shows nothing each time, no errors or anything obvious, to me at least, prior to the reboots. I believe each time I have had VMs running, at first it might have been through both Windows Hyper-V and VirtualBox, but today I was definitely only running a single Windows 10 VM on Hyper-V. I might try to not leave any VMs running for awhile and see if that makes any difference.

Does anyone think mixing RAM kits could lead to instability despite memtest passing OK? I'm assuming that the motherboard would just take the lower of the 2 XMP profiles and run it, but now I cannot recall if I verified that. If so I can also test for that and run 64GB of all the same RAM. And then of course I can remove the new RAM and see what happens for a couple weeks, though I'd rather not do that. Oh and I could lower the speed if anyone thinks that's a good way to test.

Does RAM speed matter much on an i7-8700? I know people say it does on Ryzen and less so on Intel, but I don't know to what extent. I've also read something at some point, I think it was related to Ryzen, but someone talking about stressing the motherboard when you fill all 4 slots, no idea if that could be at play here or if that's even true.

EDIT: Could the motherboard be picking timings that are not stable on the new RAM?
All according to CPU-Z:
Old RAM is 15-15-15-35 at 3000Mhz
New RAM is 16-20-20-38 at 3200Mhz
Board runs 15-19-19-35 at 3000Mhz
7 replies
Member
Feb 9, 2008
340 posts
280 upvotes
Vancouver, BC
Mixing RAM is usually a bad idea. There's lots of discussions on the internet on the reasons.
At the very least, you should get the same kit.
The best option is to replace all the RAM with a single kit.

Check your motherboard manual to verify that you are putting the same kit in the same channel.
E.g. old kit in A2,B2, new in A1,B1

Also try changing the timings to match the slowest RAM (new).
Deal Addict
User avatar
Nov 15, 2020
1734 posts
1220 upvotes
update bios, it might be incompatible ram. Then try loosening the ram timings, and/or increasing ram voltage slightly.

The thing is, because it bsod already, windows might continue to bsod even if your ram isnt acting up. You might need to reimage the drive with an OS that hasnt been corrupted yet.
Deal Addict
User avatar
Apr 29, 2018
1401 posts
971 upvotes
Vancouver
I would suggest trying taking out the new RAM and trying to see if it continues to BSOD. Also it might be a good idea to use an analyzer to go through the CrashDumps created. That will provide you with the real culprit.

Also, it looks you may be running the new RAM at faster latencies than rated for. Might be a good idea to disable XMP profiles and try.
Can't Stop. Won't Stop. Game Stop
[OP]
Deal Addict
Dec 24, 2008
3285 posts
994 upvotes
Belle River
Somehow I never thought about looking for software to analyze crash dumps, duh :). I found WinDbg and analyzed 2 dump files and both said the same thing:

Code: Select all

 *** Memory manager detected 3 instance(s) of page corruption, target is likely to have memory corruption.
 *** Memory manager detected 12 instance(s) of page corruption, target is likely to have memory corruption.
I've also pulled the 2 old sticks of G.Skill RAM and now I'm running all 4 sticks of the same new A-Data RAM from 2 identical 32GB (2x16GB) kits. Why I didn't run all 4 initially well I won't go into that as it's unrelated to the situation.

I did consider updating BIOS but then I thought nah, I know that's not a big deal nowadays but I figure there's still some risk involved so I'll try other things first.

When I look at the XMP profile in BIOS and the values on the "Memory" tab of CPU-Z, I expect small differences like maybe CPU-Z would 1534Mhz instead of 1600Mhz for 3200Mhz, but right now the difference is quite large.

CPU-Z has 1333Mhz 19-19-19-43 while BIOS/XMP has 3200Mhz 16-20-20-38

That would be 2666Mhz, seems too far from 3200Mhz? Maybe my BIOS is also set to adjust those automatically, but I figured if I enabled XMP it would just use the XMP values.
Deal Addict
User avatar
Dec 1, 2010
2086 posts
1126 upvotes
GTA
Did you have XMP OFF when you removed the old sticks and replaced with the new ones? If you had XMP on, then yea the BIOS is all screwed up. That's why you're getting an incorrect reading. CPU-Z would be giving the correct reading at 2666MHz because you probably didn't reset the BIOS to let the MB program the new memory.

Turn XMP OFF then reboot the machine or reset BIOS to defaults and reset. (I would reset all BIOS defaults and reboot) also if you have a newer BIOS on the website, update it. Don't use an older version. Updates have fixes and stability improvements.

Then after RESET go back into BIOS and enable XMP to on, to let the MB program and adjust to the new modules and new frequency. CPU-Z should be reporting 1600Mhz for DRAM Frequency. CPU-Z shows 1600.4MHz on my system for my 64GB kit of G-Skill 3200.

On my Gigabyte board, when I enable/disable XMP the computer reboots and the MB gives me 3 beeps (ram error code) as it disables/enables XMP.
[OP]
Deal Addict
Dec 24, 2008
3285 posts
994 upvotes
Belle River
Ok I guess my BIOS was super old so I updated it, and I did your suggestion of turn XMP off then reboot then back on, now CPU-Z shows the expected values. I guess now I go about my usual business and see if it still crashes.
Deal Addict
User avatar
Dec 1, 2010
2086 posts
1126 upvotes
GTA
hystavito wrote: Ok I guess my BIOS was super old so I updated it, and I did your suggestion of turn XMP off then reboot then back on, now CPU-Z shows the expected values. I guess now I go about my usual business and see if it still crashes.
Glad that fixed that. Seems all went well so you updated BIOS and reset, good move. Hopefully your BSOD memory issues go away (they should) if the kits are fine. But let us know.

Top