Expired Hot Deals

Google Home - $39.99 Multiple Retailers - CONTINUES

  • Last Updated:
  • Jun 6th, 2020 1:44 pm
Member
Jun 10, 2017
495 posts
681 upvotes
tesla216 wrote: Ordered from Lowes on May 15th morning and until now I have no shipping email. The order has been charged to my credit card for over 5 days already.
I ordered mine from Lowe's on the 16th, shipping confirmation and "picked up" by Canada post on the 19th.
Based on my tracking number, there's no updates since the pickup on the 19th.. I take it as Canada post being backlogged. For me as long as it's shipped, it's now just a matter of waiting for it to arrive.
For you, if it's not even shipped yet and you've been charged, I recommend you give them (Lowe's) a call to see what's up.
Newbie
Jan 31, 2013
22 posts
13 upvotes
Victoria
Found stock at "the source" online. also bought a promo smart bulb for $5.. downside, had to buy 2 google homes and 2 smart bulbs so total was over $50 for free shipping.
Deal Addict
Apr 10, 2011
1599 posts
1015 upvotes
GVRD
In researching this Google Home device, it seems the US started clearing theirs out several weeks ago at US$29. Even Google had sold it direct at that price for a short time. It now seems to be sold-out there and at other online US resellers. They now list it as "obsolete" or "sold-out".

This sure was a quick clear-out. A new version can't be far away, but it won't be $39.
Deal Addict
User avatar
Apr 2, 2007
1940 posts
144 upvotes
wealthdesigners wrote: Found stock at "the source" online. also bought a promo smart bulb for $5.. downside, had to buy 2 google homes and 2 smart bulbs so total was over $50 for free shipping.
One is cost $$40 ... how u get two for $$50????
With the add on stupid lights Electric Light Bulb ???Thinking FaceThinking Face
Chinese Food+MSG=Good Food :rolleyes:
Deal Addict
Mar 5, 2007
4751 posts
4364 upvotes
Turns out the WIFI on my unit is rubbish, places that my v1 mini works fine have trouble with the home. Maybe I have a dud, don't know, but I'm less and less impressed.
Deal Addict
Apr 10, 2011
1599 posts
1015 upvotes
GVRD
repatch wrote: Turns out the WIFI on my unit is rubbish, places that my v1 mini works fine have trouble with the home. Maybe I have a dud, don't know, but I'm less and less impressed.
Perhaps do some researching online for that. Check your home wifi router settings too. If you have split 5GHz channels, one for narrow band another for wider band, or whatever, one GH device might be connecting on a different band which could give the "appearance" of a worse connection. For me, I had some on the 20MHz band and another on a 80 MHz hand. It makes a difference when it comes to distance and interference.
Newbie
Oct 1, 2017
87 posts
7 upvotes
LarryT778370 wrote: Ordered from Lowes on the first day when the deal was posted.. now, filler is ready for pickup.. but no confirmation of GH.. :(
Lowes cancelled my two orders.
Deal Addict
Dec 8, 2006
1136 posts
66 upvotes
Ordered same day one from thesource and one from Best Buy. Both shipped out the same date but I received my best buy order on Tuesday (purolator). The one I ordered from the source (canadapost) is still at electronic information submitted by shipper.
Newbie
May 6, 2020
29 posts
12 upvotes
Google home app is useless. Tried to change bass and treble. it is not making any difference in sound and it goes back to medium again.
Deal Addict
Apr 10, 2011
1599 posts
1015 upvotes
GVRD
Innovac wrote: Google home app is useless. Tried to change bass and treble. it is not making any difference in sound and it goes back to medium again.
Something doesn't seem right there.
Mine makes a big difference on my minis.
Any others have advice for them?
Sr. Member
Jul 21, 2007
667 posts
230 upvotes
Winnipeg
Changing bass and treble in the app works for me. Try unplugging/replugging the Home and try again.
Newbie
May 6, 2020
29 posts
12 upvotes
silverjelly wrote: Changing bass and treble in the app works for me. Try unplugging/replugging the Home and try again.
No luck unplugged and replugged, and app resets
Bass and treble to medium.
Newbie
May 6, 2020
29 posts
12 upvotes
Uninstalled and reinstalled home app. It's working now. Smiling Face With Smiling Eyes

Top

Thread Information

There is currently 1 user viewing this thread. (1 member and 0 guests)

PEDRAM13