Computers & Electronics

Google Voice starts ending XMPP support in June '18 (Google Voice Gateway, Asterisk, Obihai users possibly affected)

  • Last Updated:
  • Jan 23rd, 2019 10:28 pm
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
georvu wrote: Great.

Thru IP address can now update fw.

Suggest do now or wait? Have Obi202
Obihai might decide to block the manual download in the future (so you might want to download the file now).

There are a couple of points to consider before installing the official firmware:

1. In the event you have problems with 3.2.2. (Build: 5859EX), you can't downgrade to a lower firmware version.

2. You can't apply the hacked firmware version of 3.2.2. (Build: 5859EX) that allows you to provision Google Voice without using Obitalk.com.

I'm not providing support for the hacked firmware version (use it at your own risk). Questions about it can asked at http://www.dslreports.com/forum/r317927 ... mware-mods.

Obviously, once Google Voice drops XMPP support after June 18th, you're going to need to make a decision. If you don't update firmware (either the official or hacked version), Google Voice is going to stop working for you.
Last edited by Guest1284983 on May 18th, 2018 9:37 am, edited 1 time in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
Webslinger wrote: Obihai might decide to block the manual download in the future (so you might want to download the file now).
Yep, that download link no longer works.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Fanatic
Feb 4, 2015
6295 posts
2738 upvotes
Canada, Eh!!
Webslinger wrote: Yep, that download link no longer works.
Yup, did download thanks to your suggestion :)
.......
July 13, 2017 to October 25, 2018: BOC raised rates 5 times and MCAP raised its prime rate next day each time.

2020: BOC dropped rates 3 times and MCAP waited and waited to drop its prime rate to include all 3 drops.
Deal Expert
User avatar
Feb 24, 2003
16971 posts
3183 upvotes
Toronto
Webslinger wrote: Yep, that download link no longer works.
Thanks for the update. Luckily, I downloaded the firmware before it was pulled. I still have an obi200 that's been unused for months.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
audit13 wrote: Thanks for the update. Luckily, I downloaded the firmware before it was pulled. I still have an obi200 that's been unused for months.
If the ATA has Obitalk Service and Obitalk Provisioning enabled, 3.2.2 (Build: 5898EX), at the time of this post, will be pushed to your OBi200 anyway.

The concern is whether you want that to happen. The hacked firmware version of 3.2.2. (Build: 5859EX) allows you to provision Google Voice without using Obitalk.com.
You can't apply the hacked firmware version of 3.2.2. (Build: 5859EX) if the official 3.2.2. (Build: 5859EX) firmware or a newer version, 3.2.2 (Build: 5898EX) for example, is installed. For those that are interested, questions about hacked firmware should be directed to http://www.dslreports.com/forum/r317927 ... mware-mods.

Also, I, personally, find it disconcerting that Obihai is hiding manual firmware downloads. To me, that seems like a desperate attempt to suck $10 USD per year out of people after devices are out their warranty period just to obtain firmware updates. AFAIK, consumers aren't made aware of that practice before buying Obihai ATAs and IP Phones. OTOH, Obihai is pushing firmware, regardless of warranty status or extended support status, that allows OBi2xx users to continue using Google Voice. However, there's no technical reason why OBi1xx owners can't still use GV either. Obihai introduced an end of life date for OBi1xx owners and told them them to update to OBi2xx ATAs in order to continue using Google Voice (which is one reason why hacked firmware exists for OBi1xx users). Anyway, I don't want to get into a huge debate. I like Obihai devices' features. But the support policies, in my opinion, are pretty obnoxious and focused on sucking money out of its existing customer base, which is a good way to annoy existing customers and discourage potential new customers from buying Obihai products.
Last edited by Guest1284983 on Jul 11th, 2018 9:53 am, edited 6 times in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Deal Expert
User avatar
Feb 24, 2003
16971 posts
3183 upvotes
Toronto
Thanks for the additional information.

My unit is probably out of warranty and was concerned that it may not get the update which is why I downloaded it for possible future use.
Deal Addict
Oct 30, 2012
1033 posts
356 upvotes
Hamilton
Anyone able to share the firmware with me?

Since obi removed it.
Jr. Member
Aug 29, 2011
153 posts
46 upvotes
Vancouver
ravinr wrote: Thanks Webslinger.
I will update my firmware as per your instructions and hopefully, things will work properly again.
And yes, you are right. I had a typo. My settings are SP1 (GV1), SP2 (freephoneline) and SP3 (GV2).
So, I now updated my firmware but it only auto-updated to 3.2.1 (Build: 5757EX), not 3.2.2. But my Google voice started working. Thanks.

Webslinger, in post #45 you wrote: "If the ATA has Obitalk Service, Obitalk Provisioning, and Auto Firmware Update enabled, 5.2.2. (Build: 5859EX), at the time of this post, will be pushed to your OBi200 anyway.." These are enabled for me, so any idea why I'm only being pushed to 3.2.1? And did you mean 3.2.2 or 5.2.2
Newbie
Apr 3, 2006
55 posts
10 upvotes
puska83 wrote: Anyone able to share the firmware with me?

Since obi removed it.
I would also love a copy of the firmware. I don't really want to pay them $10 just for the update. I guess they are trying to force everyone that is out of warranty to pay up.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
ravinr wrote:
Webslinger, in post #45 you wrote: "If the ATA has Obitalk Service, Obitalk Provisioning, and Auto Firmware Update enabled, 5.2.2. (Build: 5859EX), at the time of this post, will be pushed to your OBi200 anyway.." These are enabled for me, so any idea why I'm only being pushed to 3.2.1?
After enabling Obitalk Service and Obitalk Provisioning, login at Obitalk.com, navigate to System Management--> Auto Provisioning-->Auto Firmware Update
In the FirmwareURL field blank out (delete) whatever is there. Also double check that the FirmwareURL field is also blank in the ATA (via LAN IP).

Set Auto Firmware Update to "System Start" at Obitalk.com. Hopefully, the ATA will then reboot and update firmware.

Also, at Obitalk.com if you see a yellow triangle with a notification that a firmware update is available, you can try clicking on it to update firmware (follow the prompts).

Should you continue to have further issues, I suggest asking over here: https://www.obitalk.com/forum/index.php ... 6#msg89076.
And did you mean 3.2.2 or 5.2.2
3.2.2

Made a typo and copy and pasted it over and over and over again (I'm an idiot)
Last edited by Guest1284983 on May 25th, 2018 2:57 pm, edited 5 times in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
ironmikel wrote: I don't really want to pay them $10 just for the update.
You don't need to. 3.2.2 (Build: 5859EX) is being pushed to OBi2xx owners regardless of warranty or support status.
Refer to the first post in this thread.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Newbie
Apr 3, 2006
55 posts
10 upvotes
Webslinger wrote: You don't need to. 3.2.2 (Build: 5859EX) is being pushed to everyone regardless of warranty or support status.
Refer to the first post in this thread.
Thank you for the clarification.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
Someone posted the firmware link here: http://www.obitalk.com/forum/index.php? ... 0#msg91090.

Edit: The latest official firmware version is 3.2.2 (5898EX), at the time of this post.
Last edited by Guest1284983 on Jul 7th, 2018 7:38 pm, edited 3 times in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
Bill Simon posted this recently: https://www.dslreports.com/forum/r32019919-.

Bad news for Google Voice Gateway customers
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Member
User avatar
May 29, 2006
495 posts
56 upvotes
Toronto
ravinr wrote: So, I now updated my firmware but it only auto-updated to 3.2.1 (Build: 5757EX), not 3.2.2. But my Google voice started working. Thanks.

Webslinger, in post #45 you wrote: "If the ATA has Obitalk Service, Obitalk Provisioning, and Auto Firmware Update enabled, 5.2.2. (Build: 5859EX), at the time of this post, will be pushed to your OBi200 anyway.." These are enabled for me, so any idea why I'm only being pushed to 3.2.1? And did you mean 3.2.2 or 5.2.2
I believe 3.2.1 build 5757 is working as well. Unfortunately I have upgraded the firmware to 3.2.2 build 5859 a day later and Google Voice is no longer working. You cannot roll back to older firmware version after 3.2.2 build 5859.

You can still download the 3.2.1 firmware from Obihai and update it manually from Obi device.

http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

Note this firmware is only for Obi200 series devices and not the Obi100 series devices

Make sure you also disable the Obitalk Provisioning, and Auto Firmware Update options in the "Auto Provisioning" section to block Obihai pushing new firmware out to your device.
Deal Expert
User avatar
Feb 24, 2003
16971 posts
3183 upvotes
Toronto
I'm was upgraded to 3.2.2 (Build: 5898EX) on my obi200 when I enabled auto updating and GV is still working fine for me.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
sc888888 wrote: I believe 3.2.1 build 5757 is working as well.
No. Not for Google Voice anymore. The new SIP protocol for GV is not supported below firmware 3.2.2 (Build 5859EX).
GV XMPP is dead.
Unfortunately I have upgraded the firmware to 3.2.2 build 5859 a day later and Google Voice is no longer working.
3.2.2 (Build: 5898EX) works with Google Voice


newegg-obihai-obi200-ata-56-49-incl-ehf ... #p29551682

newegg-obihai-obi200-ata-56-49-incl-ehf ... #p29551737
Make sure you also disable the Obitalk Provisioning, and Auto Firmware Update options in the "Auto Provisioning" section to block Obihai pushing new firmware out to your device.
There's 4 things you need to disable: https://forums.redflagdeals.com/newegg- ... #p28508704, especially Obitalk Service. But if you want to use official firmware with Google Voice, you'll need Obitalk Service and Obitalk Provisioning enabled to receive official firmware updates and if you need to provision Google Voice again.


Old thread begins here: http://www.obitalk.com/forum/index.php?topic=3229.0 (it's an interesting read).
Last edited by Guest1284983 on Jul 29th, 2018 11:18 am, edited 6 times in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
audit13 wrote: I'm was upgraded to 3.2.2 (Build: 5898EX) on my obi200 when I enabled auto updating and GV is still working fine for me.
It does for most. Others may need to re-provision GV again after updating firmware.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.
Member
Apr 9, 2009
471 posts
504 upvotes
Calgary
So I take it that my obi 100 is useless now for Google voice? No updates available? It's a shame if it is
[OP]
Deal Fanatic
User avatar
Mar 3, 2002
9417 posts
3313 upvotes
Phlav wrote: So I take it that my obi 100 is useless now for Google voice?
Yes
https://www.obitalk.com/info/faq/About- ... nouncement.
The OBi2xx series continues to support GV at the time of this post.


This may be of interest (I have nothing to do with it; please ask questions over there): http://www.dslreports.com/forum/r320524 ... SIP-Future.
Same for this: http://www.obitalk.com/forum/index.php?topic=14632.0.
It's a shame
I agree.
Last edited by Guest1284983 on Jul 30th, 2018 7:53 pm, edited 1 time in total.
Please do not PM me for tech support. I help out on the forums when I can. Thank you.
OBi200/202 Freephonline PDF guide (version 1.60) can be found here. OBi200 info can be found here. For OBi202 info, click here.

Top

Thread Information

There is currently 1 user viewing this thread. (0 members and 1 guest)