Computers & Electronics

Help setup my mesh WIFI

  • Last Updated:
  • Jan 12th, 2022 11:39 pm
[OP]
Member
Mar 9, 2009
394 posts
231 upvotes

Help setup my mesh WIFI

I recently tried setting up my DECO M9 Plus that I got from B&H. I honestly thought it would be an easy plug and play. However after setting up two of the units, my speed is significantly lower than just connecting my device to the ROGERS WIFI modem.

Modem and M9 unit is upstairs at the back of the house.

I'm testing with my phone, standing in the same room as the unit. Connected via 5GHz. My speed is only 90 Mbps. However when connecting back to the ROGERS modem, I'm up to 400-500 Mbps.

Is there something wrong with my setting/setup?

TIA
5 replies
Deal Addict
Jul 26, 2004
4920 posts
1951 upvotes
In the Deco App you can turn 2.4ghz and 5ghz on/off. See what happens if you turn off your 2.4ghz. If speedtest improves when 2.4ghz is OFF and 5ghz ON, that means you weren't connecting to the 5ghz band that's needed for the 400-500mbps speeds.

Can also try a different ethernet cable when connecting the modem to the Deco M9 unit.
[OP]
Member
Mar 9, 2009
394 posts
231 upvotes
I tried turning off 2.4GHz. Speed was still sub 100mbps with 5GHz. I could try a different ethernet cable (currently using the one that came with the mesh unit.

Is it possible that I need to turn off my modem's WIFI radio?
Deal Addict
Feb 25, 2007
3027 posts
734 upvotes
altezza86 wrote: I tried turning off 2.4GHz. Speed was still sub 100mbps with 5GHz. I could try a different ethernet cable (currently using the one that came with the mesh unit.

Is it possible that I need to turn off my modem's WIFI radio?
yes, you need to put to bridge mode
Deal Addict
Jul 26, 2004
4920 posts
1951 upvotes
altezza86 wrote: I tried turning off 2.4GHz. Speed was still sub 100mbps with 5GHz. I could try a different ethernet cable (currently using the one that came with the mesh unit.

Is it possible that I need to turn off my modem's WIFI radio?
You could try turning off the modem's wifi just in case it's causing interference.

Bridge mode shouldn't really affect the speed that way. At least it never did for me under multiple routers/mesh systems setups that was done behind the ISP's modem without bridge mode.

I just got my Deco M9 setup going as well a few days ago. It's running fine with a similar setup as you. Mine is ISP Modem > Deco M9 > wireless back haul to 2 other Deco M9s.

My ISP modem wifi is ON, no bridge mode. Get 400+down and 350+ up on wifi with speedtest on my iphone and I have Gigabit Telus Fiber. When I do the speed test via the Deco App that comes back 911/921 which is about what gigabit should get i guess. Check the speed test on the deco app. That could see what speed your Deco M9 unit itself is getting from the modem.

Edit:... Can also make sure the modem's LAN ports are Gigabit ports. It should be.. but weirder things have happened.

Edit 2 : I use my own Cat6 cable from modem to Deco m9. Not using the cable that came with Decos.
[OP]
Member
Mar 9, 2009
394 posts
231 upvotes
Wow, thank you for your help guys.

I simply changed the ethernet cable as suggested and the speeds are back to 400-500mbps. Strange that they supply with a slow ethernet cable..??

Thank you again.

Top

Thread Information

There is currently 1 user viewing this thread. (0 members and 1 guest)