Computers & Electronics

Motherboard running at wrong frequency

  • Last Updated:
  • Jul 19th, 2020 1:50 pm
[OP]
Member
Oct 12, 2005
350 posts
144 upvotes
Markham, ON

Motherboard running at wrong frequency

Last week, for no apparent reason, I upgraded the BIOS on this PC that has a Gigabyte Z390 I AORUS motherboard. I had it running as a "Hackintosh" for the last few months and it was stable. Don't remember what motivated me to flash the BIOS... just plain stupidity. After the BIOS flash, everything went to hell. macOS wouldn't boot anymore. Tried updating the SSDT within OpenCore but couldn't get things back to a working state.

I tried re-imaging using Clonezilla, the Linux Mint image I took that was running before macOS on this PC, and it also wouldn't boot anymore. Tried a Linux Mint live USB and that also wouldn't boot saying something about a missing live image. The same USB boots fine on another PC. I then installed Windows on it. That seemed to work, but there was just something I couldn't get to work the way I hoped and I had to abandon it.

I finally got a fresh ISO of Linux Mint 20, used brand new, different brand of USB flash drive, and got the Live USB working, and hoped to install Linux Mint on this PC (again). But before doing that, I wanted to go back to the way it was and I flashed the original version of the BIOS back onto the motherhboard. It then reported something was wrong and asked me to reset BIOS back to optimized defaults. It was already reset, multiple times. I then found a "last known good" setting somewhere in the BIOS, which I can't find anymore, and loaded that. It finally came back to life and I installed Linux Mint and it's now working. I took a Clonezilla image of the boot disk again, just in case.

However, when I ran Geekbench, it reported that the CPU was running at 4GHz. I checked the System Information within Linux, and it did tell me it's at 3GHz, but I think that was only reporting the CPU, not the actual frequency it was running at. This is not the "K" version of the CPU and I have no intention of overclocking it. I went back into the BIOS and saw the CPU was running at over 3900 MHz, even though the CPU clock ratio is set to auto at 30, and the base clock is also set at auto at 100Mhz. Everything else was also set to Auto... (see images).

So, is there any way I can get the CPU back to normal, as in 3GHz? I Googled and found something about running at turbo, but I couldn't find the setting within the BIOS, and everything was "optimized" and set to Auto anyway. I hope someone can help. Thanks.
Images
  • 001.jpg
  • 002.jpg
  • 003.jpg
2 replies
Deal Addict
Jul 26, 2004
4908 posts
1945 upvotes
Turbo Boost is under " advanced CPU settings" , it's available for selection in your second picture. Select that and you'll get into the sub menu.

Most of Intel's desktop CPUs have a " normal" frequency and Turbo frequency. If you have never touched these settings before I'd assume Turbo was on in your original setup.

I pretty much have the same Aorus Z390 motherboard as you running a i7 8700 non K... I just leave everything in Auto. Only thing I manually changed is Activate Memory XMP profile and made sure Hyperthreading and Turboboost is on in my case. Everytime you flash the bios on first boot up it'll make you go verify the settings. Just remember to save and exit and you'll be fine. Cause if you just press ESC and exit it won't save the settings. Never really installed Hackintosh or Linux (besides on a raspberry Pi), so can't comment on how they react on Bios flash.
[OP]
Member
Oct 12, 2005
350 posts
144 upvotes
Markham, ON
Thanks for reading my long rambling post and replying. With your help, I found the setting under Advanced CPU Core Settings, and I have now disabled Intel Turbo Boost Technology. BIOS now shows 3000 MHz on the side panel. I prefer having turbo off. It will probably run cooler. I am not sure if it was enabled before or not as I never noticed the frequency being wrong.

Thanks again for your help.

Top