Automotive

Nissan Canada Leaf App (iOS) Issues - 2018 Nissan Leaf

  • Last Updated:
  • Nov 2nd, 2018 10:59 am
[OP]
Newbie
Aug 21, 2011
84 posts
15 upvotes
BC

Nissan Canada Leaf App (iOS) Issues - 2018 Nissan Leaf

Hello All,

I wanted to start a new thread about Nissan Canada Leaf App. This app hasn't worked as expected for me or all of us as far as my research has found. I searched few times on Google to get more information or find other users who might be experiencing the same thing. I have called Nissan Canada to get some assistant but don't get anywhere. I have gone to my local dealership after I was told by Nissan to get the TCU checked but no problems/updates found.

Link to App: https://itunes.apple.com/ca/app/nissan- ... 31231?mt=8
Location for me BC (Lower Mainland Area - Vancouver to Chilliwack, BC)

Issues:
1. App is very slow and usually fails on getting the battery status updates. I usually wait 2 to 4 minutes before I get my battery status or have to close the app and open it up to show the status update.
2. Push notification on iOS 12.0.1 iPhone 7 don't work at all. **Today all of the sudden they started to work but for each update i get 11 to 19 push notifications.
3. Email notifications from Nissan sometimes are delayed by 2 to 4 hours. I have also gotten them within few minutes too so not consistent.
4. Text notification work but I don't get a text message. I get a email sent to my Rogers wireless phone so I always have to reply with the work "Read" before I get the content of the message. I.e. "Climate Control Turn On"

Nissan now telling me that my phone is not compatible (what they really mean is iOS12 is not compatible, I said it was the same issue on iOS 11. They said that is also not compatible LOL) and they can't do anything until they update the app. In the last month i have received two app updates but everything is the same. Current app version is 6.2.7.

Why start is thread if you know this is a known problem. Well i thought if we can track it here or share information thoughts maybe this information can be seen/brought to Nissan Canada's attention so they can prioritize fix this problem going forward.

What are you thought? Anyone else using iOS 11/12 and have the app working other than the slowness?
4 replies
Jr. Member
May 24, 2018
137 posts
26 upvotes
Only parts of the app work for me. I will get battery updates slowly after 2-3 refresh attempts which take roughly 90s each attempt. My car Finder works although the GPS is accurate to within a couple of blocks. Climate control and climate control timer work relatively well. However I've never been able to see my history, flash lights, unlock doors or any of the other car controls. I didn't buy the car for the app so have never bothered tracking these issues down. The things I find useful do work for me - that is the climate control and battery status updates. It would be nice if if they could get it all working well, but not critical for me. Anyway just adding a data point to this.
[OP]
Newbie
Aug 21, 2011
84 posts
15 upvotes
BC
Just another update..

Since yesterday I don't get multiple push notifications. However, I don't get all push notification.

These are the two that work at the moment for push notifications for iOS 12.01 using iPhone 7
Battery status when manually refreshed works now
Climate Control when manually turned on works now
[OP]
Newbie
Aug 21, 2011
84 posts
15 upvotes
BC
What can i say.. my payers have been answered or at least timing was just right as soon i post this thread things are improving.

Current status..
All push notifications are working on iOS 12.0.1 on iPhone 7.

Things to improve or fix Nissan
1. Speed up updates (battery status) - might be related to just cell service. Someone told me it works better in states. I will test this if/when i go across no plans yet.
2. Text message to Rogers/Fido wireless should be a true text message not an email to text. (See attached screenshot)
Images
  • notificaitons.png
[OP]
Newbie
Aug 21, 2011
84 posts
15 upvotes
BC
I just noticed that when the push notification come there is no sound. I have checked/double checked the sound settings and tested and no sound/vibration for any notification.

Anyone else experiencing this?

Top