Computers & Electronics

Official Sony XBRXxx900H TV Owners Thread

  • Last Updated:
  • Apr 22nd, 2021 6:15 pm
[OP]
Deal Fanatic
User avatar
Jul 5, 2001
6778 posts
5222 upvotes
Toronto

Official Sony XBRXxx900H TV Owners Thread

Last edited by 9394 on Nov 29th, 2020 10:45 am, edited 1 time in total.
559 replies
Deal Addict
User avatar
Jun 16, 2009
3529 posts
3757 upvotes
GTA
Will have to look at these links when I get a chance, thanks OP. Right now just enjoying my set and letting it burn in a bit before worrying too much about settings, really enjoying it so far.

A couple of questions for other owners:
-Does anyone with this model know of any reason to keep an Nvidia Shield attached to it? I removed mine since it has included Android TV, I don't use the gaming features much and have a PS4 Pro hooked up so good enough for me. I'm just going to hook the Shield up to a TV with no smart features.

-I still use optical output to this TV (old Sony 5.1 DTS HTIB solution) and have followed the guides online to enable it. But Disney+ for example, won't recognize it as DTS. When I switch to my OTA signal, no problem there. Anyone know of a solution? My quick findings seem to indicate that Disney+ only supports Dolby Digital Plus, but not Dolby Digital. I have no issues with the speakers so I don't want to chuck them for an HDMI version, besides 2.1 HDMI ones seem to have issues anyway.
c'mon get happy!
Newbie
Jun 2, 2015
67 posts
56 upvotes
Toronto
Hey folks currently on my 3rd day on this tv and it’s perfect. Only one issue I’m having and curious if anyone else experiencing the same thing. I’ve attached my LG sound bar to it via ARC HDMI. I have the sound set to external speakers NOT tv speakers. It works great but every once and awaile it kicks in with the TV speakers and not the sound bar speakers. I go back and change it to external speakers and again it kicks me off after awaile. Timing of the speaker switch varies but has done it like over a dozen times.
Deal Addict
Aug 15, 2009
1452 posts
1121 upvotes
Montreal
416Tom wrote: Hey folks currently on my 3rd day on this tv and it’s perfect. Only one issue I’m having and curious if anyone else experiencing the same thing. I’ve attached my LG sound bar to it via ARC HDMI. I have the sound set to external speakers NOT tv speakers. It works great but every once and awaile it kicks in with the TV speakers and not the sound bar speakers. I go back and change it to external speakers and again it kicks me off after awaile. Timing of the speaker switch varies but has done it like over a dozen times.
Well it also happens on my 900f with a AVR once in a while.
Sr. Member
User avatar
Nov 29, 2011
968 posts
342 upvotes
Milton
416Tom wrote: Hey folks currently on my 3rd day on this tv and it’s perfect. Only one issue I’m having and curious if anyone else experiencing the same thing. I’ve attached my LG sound bar to it via ARC HDMI. I have the sound set to external speakers NOT tv speakers. It works great but every once and awaile it kicks in with the TV speakers and not the sound bar speakers. I go back and change it to external speakers and again it kicks me off after awaile. Timing of the speaker switch varies but has done it like over a dozen times.
Yeah, mine does this sporadically with a receiver. Normally when I turn the TV on it turns the receiver on and sends audio via the receiver, but the odd the audio will remain through the TV speakers. I just turn the receiver off, then on again, and it fixes it.

But mine isn't doing it as often as your situation (if you're saying a dozen times in 3 days). Mine might do it a few times a week, sometimes not at all in that span.
Moderator
User avatar
Aug 20, 2009
8262 posts
3203 upvotes
Grimsby
Thanks for making the thread OP.
-Does anyone with this model know of any reason to keep an Nvidia Shield attached to it? I removed mine since it has included Android TV, I don't use the gaming features much and have a PS4 Pro hooked up so good enough for me. I'm just going to hook the Shield up to a TV with no smart features.
The Shield is a better media player in some respects and has more internal storage if you need that but otherwise the SoC in the X900H does a pretty good job. You can still sideload apps with the X900H so it can do 99% of what the Shield can.

I am really wanting that VRR update soon, I'm playing AC: Valhalla on the Series X and there is insane screen tearing in some areas post-patch and even with Performance mode turned on instead of Quality. I know they're trying to fix the 120hz/4k stuff but I'm not even sure how important that is as so few titles will be able to hit those numbers. Give me VRR now please, I got so spoiled by this on the PC that it's impossible to go back.
Sr. Member
User avatar
Jan 13, 2005
725 posts
239 upvotes
Toronto, ON
Has anyone purchased this TV as open box from best buy? Is it worth the 10% savings to buy open box?
Deal Addict
User avatar
Mar 17, 2006
4839 posts
2871 upvotes
9394 wrote: So for bias lighting, I bought the following product only to find out Sony doesn't have an option to turn off power to the USB: https://www.amazon.ca/gp/product/B07RP1 ... UTF8&psc=1

I ended up buying this add-on: https://www.amazon.ca/gp/product/B06XXM ... UTF8&psc=1

Together, they work great. No complaints except for the dongle being a bit long.
Is there no way to go into service menu and change the USB power mode or under the regular TV menu?

Found this over at AVS Forums:
Also, here the link to AVS forums for Sony X900h/X90 talk.
CPU: Intel i7-7700K @4.5GHz | GPU: GeForce GTX 1080 | RAM: ADATA XPG DDR4 3000MHz 24GB | SSD: WD Black 512GB NVMe | Mobo: ASUS STRIX Z270E | Case: COUGAR PANZER | Cooler: CORSAIR Hydro Series H110 |Monitor: 2 x HP 27es 27" IPS LCD
[OP]
Deal Fanatic
User avatar
Jul 5, 2001
6778 posts
5222 upvotes
Toronto
Sejad wrote: Is there no way to go into service menu and change the USB power mode or under the regular TV menu?

Found this over at AVS Forums:



Also, here the link to AVS forums for Sony X900h/X90 talk.
Thanks but it just turns on again afterwards. It's apparently a known issue with newer Bravia TVs.
Deal Addict
User avatar
Mar 17, 2006
4839 posts
2871 upvotes
9394 wrote: Thanks but it just turns on again afterwards. It's apparently a known issue with newer Bravia TVs.
No worries. Can we maybe post on the official Sony forums to ask them to add an option to power off after turning the TV off?
CPU: Intel i7-7700K @4.5GHz | GPU: GeForce GTX 1080 | RAM: ADATA XPG DDR4 3000MHz 24GB | SSD: WD Black 512GB NVMe | Mobo: ASUS STRIX Z270E | Case: COUGAR PANZER | Cooler: CORSAIR Hydro Series H110 |Monitor: 2 x HP 27es 27" IPS LCD
[OP]
Deal Fanatic
User avatar
Jul 5, 2001
6778 posts
5222 upvotes
Toronto
So I just got off the chat with Sony.ca and the CSR told me since the TV was purchased at Costco, there is a 5 year warranty (I have the chat saved and screenshots of it).
Deal Addict
User avatar
Mar 17, 2006
4839 posts
2871 upvotes
9394 wrote: So I just got off the chat with Sony.ca and the CSR told me since the TV was purchased at Costco, there is a 5 year warranty (I have the chat saved and screenshots of it).
Only the 90H has warranty 5 years warranty, not the 900H.
CPU: Intel i7-7700K @4.5GHz | GPU: GeForce GTX 1080 | RAM: ADATA XPG DDR4 3000MHz 24GB | SSD: WD Black 512GB NVMe | Mobo: ASUS STRIX Z270E | Case: COUGAR PANZER | Cooler: CORSAIR Hydro Series H110 |Monitor: 2 x HP 27es 27" IPS LCD
[OP]
Deal Fanatic
User avatar
Jul 5, 2001
6778 posts
5222 upvotes
Toronto
Sejad wrote: Only the 90H has warranty 5 years warranty, not the 900H.
I specifically typed XBR65X900H and the CSR said it qualified for 5 years warranty. :rolleyes:
Sr. Member
User avatar
Jan 13, 2005
725 posts
239 upvotes
Toronto, ON
9394 wrote: I specifically typed XBR65X900H and the CSR said it qualified for 5 years warranty. :rolleyes:
Likely a mistake on the csr's part. You know what the actual warranty the x900h is she everybody here does as well.
Deal Addict
Jul 23, 2008
1112 posts
297 upvotes
Montréal
Some (dumb?) questions :

I will receive my x900h tomorrow and want to hook it my ps5.
1) We know that 4k120hz, Alllm and vv are not working now, so anyhdmi will be fine ?
2) Is there a game mode that I must activate everytime or it's something that is done one time only for the specific hdmi in which my ps5 will be plugged ?
3) I plan to use my ps5 for netflix, will game mode change something about movies and series ?
4) I also have a 4k xbox one, since it will not do 4k 120 hz, can I use hdmi 1 or 2 and have 4k and 60hz ?
5) My audio receiver (with 2 bookshelf speaker and a central) only have one Optical input. Should I plug the Tv or the ps5 in it ?

Thanks !
Deal Addict
User avatar
Mar 17, 2006
4839 posts
2871 upvotes
tostaky wrote: Some (dumb?) questions :

I will receive my x900h tomorrow and want to hook it my ps5.
1) We know that 4k120hz, Alllm and vv are not working now, so anyhdmi will be fine ?
2) Is there a game mode that I must activate everytime or it's something that is done one time only for the specific hdmi in which my ps5 will be plugged ?
3) I plan to use my ps5 for netflix, will game mode change something about movies and series ?
4) I also have a 4k xbox one, since it will not do 4k 120 hz, can I use hdmi 1 or 2 and have 4k and 60hz ?
5) My audio receiver (with 2 bookshelf speaker and a central) only have one Optical input. Should I plug the Tv or the ps5 in it ?

Thanks !
I’m curious where you’re getting your information from?
1) 120hz HAS been enabled for the TV. VRR and ALLM has NOT been enabled yet.

Do you have a proper HDMI 2.1 cable yet to try it when you get the TV?

Also, there’s is rumours that all HDMI inputs will be 120hz, not sure how true that rumour is though.

5) Plug the optical directly into your TV from the receiver, that way anything coming from the TV when you select an input will go to the receiver/speakers.
CPU: Intel i7-7700K @4.5GHz | GPU: GeForce GTX 1080 | RAM: ADATA XPG DDR4 3000MHz 24GB | SSD: WD Black 512GB NVMe | Mobo: ASUS STRIX Z270E | Case: COUGAR PANZER | Cooler: CORSAIR Hydro Series H110 |Monitor: 2 x HP 27es 27" IPS LCD
Newbie
Jun 2, 2015
67 posts
56 upvotes
Toronto
Am I the only one experiencing audio issues? Always kicking me off sound bar and back to TV speakers? Few clicks on remote and i set it back on sound bar but frustrating. Ive tried various HDMI cables and optical cable and even plugged them both in at the same time. I have it plugged into ARC on my TV. Also when i turn my TV off and on it kicks me back off sound bar? I have switched "Audio system prioritization" in audio output settings both On and Off. Last I checked it has the latest firmware. Its an LG sound bar but was working flawlessly on my old TV.
Deal Addict
Feb 14, 2016
1754 posts
1175 upvotes
416Tom wrote: Am I the only one experiencing audio issues? Always kicking me off sound bar and back to TV speakers? Few clicks on remote and i set it back on sound bar but frustrating. Ive tried various HDMI cables and optical cable and even plugged them both in at the same time. I have it plugged into ARC on my TV. Also when i turn my TV off and on it kicks me back off sound bar? I have switched "Audio system prioritization" in audio output settings both On and Off. Last I checked it has the latest firmware. Its an LG sound bar but was working flawlessly on my old TV.
known issue along with wifi issue

Top