Computers & Electronics

PIA Disconnected - Connected constantly Win10 over the past couple days

  • Last Updated:
  • Feb 9th, 2017 1:49 pm
[OP]
Deal Fanatic
User avatar
Mar 17, 2006
6884 posts
5797 upvotes
Burlington

PIA Disconnected - Connected constantly Win10 over the past couple days

Just wondering if anyone is experiencing this.
This is happening a lot these past couple days to both of my laptops, windows 10 with PIA v66 (it was 65) program installed.

It'll get logged on, connected for 2-5 mins, then the PIA windows at bottom right pop up, "disconnected" - "connecting" - "connected" CONSTANTLY .
Only started to happened since 2 days ago.
4 replies
Deal Expert
User avatar
May 22, 2005
20098 posts
5529 upvotes
Good Morning
I've had some issues with Win10 and PIA's software, I've since switched to OpenVPN and its been fine.
[OP]
Deal Fanatic
User avatar
Mar 17, 2006
6884 posts
5797 upvotes
Burlington
coriolis wrote: I've had some issues with Win10 and PIA's software, I've since switched to OpenVPN and its been fine.
I didn't have any issue with win10 and the PIA software until 2 days ago.
But thanks, I am going the OpenVPN way and see if it stays connected
Deal Expert
User avatar
May 22, 2005
20098 posts
5529 upvotes
Good Morning
konsensei wrote: I didn't have any issue with win10 and the PIA software until 2 days ago.
But thanks, I am going the OpenVPN way and see if it stays connected
Sorry, should clarify my issues, it would sometimes cut off all internet, as it kept creating new duplicates of the same ethernet connection.

Does your problem occur with all their servers?
[OP]
Deal Fanatic
User avatar
Mar 17, 2006
6884 posts
5797 upvotes
Burlington
coriolis wrote: Sorry, should clarify my issues, it would sometimes cut off all internet, as it kept creating new duplicates of the same ethernet connection.

Does your problem occur with all their servers?
I am not sure if it's "all' servers. I've only tried a couple US east, a couple US west, CA toronto, and Montreal.
I'm using openVPN and it seems okay so far, almost 10 mins now with no disconnection

Top