Shopping Discussion

Printing Coupons - how to disable duplex for *.fdf (e.g., Websaver coupons)

  • Last Updated:
  • May 7th, 2022 8:02 pm
[OP]
Deal Addict
User avatar
Jun 20, 2009
1273 posts
632 upvotes
Edmonton

Printing Coupons - how to disable duplex for *.fdf (e.g., Websaver coupons)

I can't figure out how to get my printer not to print coupons in duplex. My duplex (Brother) printer is my default printer. I can't figure out a way to disable duplex besides doing it in the print dialog. However, when printing out coupons from like Websaver, the .fdf file that you download opens immediately in Adobe Acrobat with the "Do you want to Print" dialog. There is no way to go into settings to prevent the printer from printing coupons on both sides. I just tried and my 6 coupons are back to back, so I can only use half of them. :( You can't print fdf files twice.
11 replies
Sr. Member
Nov 5, 2018
556 posts
643 upvotes
This might not be the answer you're looking for, but does your printer scan and copy as well? If it does, make a copy of each side of the coupon separately. Copying coupons isn't great in general, but you aren't duplicating them in spirit. The .fdf coupons are a pain.
Newbie
Aug 4, 2014
26 posts
90 upvotes
Toronto
I keep on telling myself one day I will build a web page to strip out the garbage that prevents these coupons from being viewed and printed properly. fdf are basically PDF with multiple layers with a bit of code that forces you to print the hidden coupon layer and checks with a server to prevent users from printing multiple. However, the coupon itself is in the file itself.

You can extract the hidden coupon using Firefox or Foxit PDF (presumably other tools too, but I don't use them). Open the fdf in one of those tools and click the layer icon:
firefox.png
In Firefox
foxit.png
Foxit PDF

Then uncheck everything except couponimg. The coupon will appear:
final.png
Then you can print using the system print dialog :)

Hope this helps!
Deal Fanatic
Dec 26, 2014
6488 posts
6771 upvotes
Winnipeg, MB
Idk if this is the best place to ask but does anyone know how to fix this issue?

Image

It used to work in the past without any issues, but my only option is to hit "Okay" in that pop-up window and then it just automatically closes the file.
Deal Fanatic
Dec 26, 2014
6488 posts
6771 upvotes
Winnipeg, MB
idontknow915 wrote: I keep on telling myself one day I will build a web page to strip out the garbage that prevents these coupons from being viewed and printed properly. fdf are basically PDF with multiple layers with a bit of code that forces you to print the hidden coupon layer and checks with a server to prevent users from printing multiple. However, the coupon itself is in the file itself.

You can extract the hidden coupon using Firefox or Foxit PDF (presumably other tools too, but I don't use them). Open the fdf in one of those tools and click the layer icon:

Then uncheck everything except couponimg. The coupon will appear:

Then you can print using the system print dialog :)

Hope this helps!
I can't open .fdf files in Firefox - when I do it just automatically gives me the "Open With" or "Save File" pop-up that you see with normal downloads.
Newbie
Aug 4, 2014
26 posts
90 upvotes
Toronto
chemicalxv wrote: I can't open .fdf files in Firefox - when I do it just automatically gives me the "Open With" or "Save File" pop-up that you see with normal downloads.
Go here https://mozilla.github.io/pdf.js/web/viewer.html, it's the same pdf engine as the one in Firefox, click upload (4th icon from top right), select file. Then click the sidebar button (first icon top left), then the layer button from my earlier screenshot. Hope that helps!
Sr. Member
Apr 2, 2016
505 posts
511 upvotes
idontknow915 wrote: I keep on telling myself one day I will build a web page to strip out the garbage that prevents these coupons from being viewed and printed properly. fdf are basically PDF with multiple layers with a bit of code that forces you to print the hidden coupon layer and checks with a server to prevent users from printing multiple. However, the coupon itself is in the file itself.

You can extract the hidden coupon using Firefox or Foxit PDF (presumably other tools too, but I don't use them). Open the fdf in one of those tools and click the layer icon:

firefox.png In Firefox
foxit.png Foxit PDF

Then uncheck everything except couponimg. The coupon will appear:
final.png

Then you can print using the system print dialog :)

Hope this helps!

This is great! Thanks for sharing!

(There's another more complicated work-around with chrome, but your method is much easier.)
[OP]
Deal Addict
User avatar
Jun 20, 2009
1273 posts
632 upvotes
Edmonton
idontknow915 wrote: Go here https://mozilla.github.io/pdf.js/web/viewer.html, it's the same pdf engine as the one in Firefox, click upload (4th icon from top right), select file. Then click the sidebar button (first icon top left), then the layer button from my earlier screenshot. Hope that helps!
When I try to open that github link, I just get a pdf scientific paper rather than an app. That happens in both Firefox and Chrome. Safari gives gobbeldygook.
Member
Jan 21, 2007
280 posts
251 upvotes
kreisleriana wrote: When I try to open that github link, I just get a pdf scientific paper rather than an app. That happens in both Firefox and Chrome. Safari gives gobbeldygook.
You need to open the FDF file following the instructions mentioned, and then view the layers to disable the offending one(s).
[OP]
Deal Addict
User avatar
Jun 20, 2009
1273 posts
632 upvotes
Edmonton
I can't open the FDF file. The poster says you can open in Firefox. File...Open just opens up the dialog to open up in a PDF program. If I load up the console I don't see anything to open it either.
Deal Fanatic
User avatar
Sep 1, 2004
5920 posts
3881 upvotes
Victoria
kreisleriana wrote: I can't open the FDF file. The poster says you can open in Firefox. File...Open just opens up the dialog to open up in a PDF program. If I load up the console I don't see anything to open it either.
I'll clarify those instructions:

1. Go to https://mozilla.github.io/pdf.js/web/viewer.html (this just sets up Firefox for the next steps)
2. File > Open File > select your FDF document
3. Click the toggle sidebar button (left of the up/down arrows)
4. Click the show layers button (4th button)
5. Uncheck everything but couponimg
6. Print

As for your duplexing problem, if you installed the Brother printer driver (from Brother.ca) there should be an option to disable duplex printing in Devices & Printers > printer preferences on the specific printer

Top

Thread Information

There is currently 1 user viewing this thread. (0 members and 1 guest)