Cell Phones

Randomly, calls get auto forwarded to voicemail (Virgin Mobile)

  • Last Updated:
  • May 24th, 2019 11:07 pm
[OP]
Deal Addict
User avatar
Jul 18, 2004
1809 posts
145 upvotes
Toronto

Randomly, calls get auto forwarded to voicemail (Virgin Mobile)

Curious if anyone has experienced this and has a fix. I did a search on google and on here and saw cases where ALL calls were not ringing/straight to voicemail but that's not the case for me.

It's happened at least 3 times where the person calling, while it's showing LTE and I'm connected to wifi, it doesn't ring at all but it goes straight to voicemail without even showing up in the call logs. Could happen a few times and then eventually they get through and my phone finally rings. I tested it yesterday with a friend calling me and calling from my fongo account, both times it rang fine so it's very random.

It's just really annoying because right now I'm job interviewing and happened twice already with interview calls.

I used to never have this issue with Rogers, same exact iPhone 8 and same exact settings.
I called Virgin Mobile and they gave me a code to type in and I got this message setting activation failed voice call forwarding when unanswered but not sure what that means....

Is this a Virgin Mobile specific problem? Is there anything they can do? Anything I can do? I've already 1) rebooted 2) remove the Truecaller app (which I've always had even when I was with Rogers) 3) ensured call forwarding is off
Last edited by rockthecasbah on May 17th, 2019 3:27 pm, edited 1 time in total.
6 replies
Deal Expert
User avatar
Nov 28, 2013
16273 posts
6263 upvotes
Oakville
Could be an issue with your sim card not being seated fully correctly (resulting in a sporadic connection to the network). Try removing/reinserting it? Are you in an area of weak signal?
Lucky Koodo $40/6GB (with $15/10GB add-on) recipient
[OP]
Deal Addict
User avatar
Jul 18, 2004
1809 posts
145 upvotes
Toronto
wearysky wrote:
May 17th, 2019 2:44 pm
Could be an issue with your sim card not being seated fully correctly (resulting in a sporadic connection to the network). Try removing/reinserting it? Are you in an area of weak signal?
Thanks! I’ll try removing and reinserting my SIM card to see if that does anything.

And nope, the signal is strong when this has happened with it being connected to LTE and full bars.

Hopefully the reinserting the SIM will fix it but so hard to tell with these things until you need the calls to come through and realize something is wrong :/
Deal Expert
User avatar
Nov 28, 2013
16273 posts
6263 upvotes
Oakville
Yeah, if you have an inconsistent connection, it may have full bars when you look at it, but that doesn't mean necessarily that at the exact moment that somebody tried to call you, you were actually connected. If it's still happening after reseating the sim, you might want to try calling Virgin. Maybe there's just a problem with your sim.
Lucky Koodo $40/6GB (with $15/10GB add-on) recipient
[OP]
Deal Addict
User avatar
Jul 18, 2004
1809 posts
145 upvotes
Toronto
Thanks wearysky and CanadianSpruce!

I also have turned off voice over LTE in the meantime, after reseating the SIM the other day. Also tried resetting network settings.
And a bunch of other stuff from here https://appletoolbox.com/2014/02/incomi ... t-ringing/

I think because this doesn't happen all the time but worrisome that it happens in the most inopportune times (and got me a frustrated interviewer that definitely didn't help), I might just see if I can swap the SIM card. Hopefully free and without disruption to service....
[OP]
Deal Addict
User avatar
Jul 18, 2004
1809 posts
145 upvotes
Toronto
Update to my thread: maybe it was due to the iOS software. The newest update says:
Patch note is listed below: Fixes an issue that could prevent making or receiving VoLTE calls
https://www.macrumors.com/2019/05/24/ap ... os-12-3-1/

Maybe that was it. It did start recently and maybe coincidentally coincided with me switching to Virgin Mobile. *shrug*

Top