Computers & Electronics

Rear speakers stopped working??

  • Last Updated:
  • Jan 18th, 2015 6:47 pm
Tags:
None
[OP]
Deal Addict
User avatar
Jan 7, 2005
1753 posts
50 upvotes

Rear speakers stopped working??

hey guys, for some strange reason. My 5.1 set up's rear speakers just stopped working out of blue. The receiver still says 5.1 set up DST but I hear no sound from the rear. Anyone knows why? The rear speakers are still pretty new (only been using for 2 years) and it doesn't make a lot of sense that they would go out.

very puzzled.
5 replies
Deal Addict
Feb 26, 2012
2124 posts
455 upvotes
MISSISSAUGA
Check the wiring? That is the most likely culprit.

Go through the speaker setup where it plays a signal through each speaker.
Deal Expert
User avatar
Feb 24, 2003
18440 posts
5388 upvotes
Toronto
It may be the receiver that is the problem. Check for blown fuses too.
Deal Fanatic
User avatar
Mar 20, 2009
8862 posts
2687 upvotes
Vancouver
What's the source? Maybe the problem lies with your source.

Your receiver undoubtedly has a Test function or at least a simulated-surround mode that outputs from all channels to verify that your rear speakers and amplifier channels still work.
Deal Addict
User avatar
Aug 12, 2007
4685 posts
818 upvotes
Waterloo
I dunno what receiver you have, but in mine you can select if you want the audio to be 2.1 or 5.1.
Deal Fanatic
Sep 23, 2013
5047 posts
635 upvotes
NORTH YORK
CJJ25 wrote: hey guys, for some strange reason. My 5.1 set up's rear speakers just stopped working out of blue. The receiver still says 5.1 set up DST but I hear no sound from the rear. Anyone knows why? The rear speakers are still pretty new (only been using for 2 years) and it doesn't make a lot of sense that they would go out.

very puzzled.
Reverse the amp's speaker connection front to back and back to front. See what happens.
Daniel

Fido $0 3Gb LTE + overage plan until Feb 2019

Top

Thread Information

There is currently 1 user viewing this thread. (0 members and 1 guest)