Computers & Electronics

Rogers internet acting weird

  • Last Updated:
  • Jun 5th, 2016 5:00 pm
Tags:
None
[OP]
Member
Nov 24, 2009
396 posts
47 upvotes
Ottawa

Rogers internet acting weird

Anybody having issue accessing facebook, yahoo and youtube on Rogers network? Starting from a week ago, I cannot see any images or video preview on facebook. In place of images and video players, it just shows blank boxes. Video does play when I click on the box though. That goes same for yahoo and youtube. It's not happening on just one computer, it's happening on all android devices, ios devices, pcs and macs. The reason why I'm faulting Rogers network is because I've connected different computers to Roger's modem directly and the problem still exists. So it can't be my network. The weirdest thing is when I use proxy client, like hidemyass or proxyweb, the problem goes away. I've spoken with Rogers tech support and spent couple of hours trying to fix the issue. But they couldn't tell what's going on, and at the end, insisted me to talk to rogers online support. But Rogers online support couldn't figure out either and suggested me to use their paid tech support service(I don't know how's that gonna help). Now, I'm really frustrated and very close to dumping rogers.
3 replies
Deal Guru
User avatar
Mar 9, 2007
13905 posts
9001 upvotes
Think of the Childre…
You try another web browser?

WOULD SOMEBODY THINK OF THE CHILDREN!!!
Deal Guru
Dec 10, 2004
12317 posts
1867 upvotes
Kanata
What is your DNS setting in your router or your computers? Try using google's dns servers, 8.8.8.8 and 8.8.4.4
[OP]
Member
Nov 24, 2009
396 posts
47 upvotes
Ottawa
goofball wrote: What is your DNS setting in your router or your computers? Try using google's dns servers, 8.8.8.8 and 8.8.4.4

I've tried that. But anyway, I went to Rogers outlet and exchange the modem. Voila, no more issue.

Top