Computers & Electronics

Router - 5ghz dropping on Smart Connect

  • Last Updated:
  • Jun 27th, 2019 2:54 pm
[OP]
Jr. Member
Oct 19, 2016
187 posts
60 upvotes

Router - 5ghz dropping on Smart Connect

I am really hoping someone can help me out with this and at least explain to me how "Smart Connect" works. I assumed it would broadcast both 2.4 ghz and 5 ghz bands at the same time and certain devices would switch between the bands depending on the proximity to router/connection etc..

I have a c2300 router and I am on "Smart Connect", however; the 5ghz band always drops off about a minute after a reboot. I have put a few devices within 6 inches of the router and still they only connect to 2.4ghz. For reference my network has 16 wireless devices and every single one of them are on 2.4ghz. In fact, using wifi analyzers there is no broadcast of the 5ghz band at all - despite the TPLink tether app (and web broswer) saying that it is enabled, and the LED light on the router saying it is active too.

I don't understand why ithe 5ghz band isn't visible to wifi analyzers and no devices are capable of connecting to it when in "smart connect". It is only visible with wifi analyzers for a short time (a minute or two) after I do a clean reboot.

With that said, if I enable ONLY the 5ghz band (ie. disable smart connect and 2.4 ghz) devices do connect fine. The 5ghz band does not seem to drop in this instance, as I have been connected for hours at a time.



For reference, when doing speed tests on the 5ghz band (when it is the only band broadcasted) I get 120+ mbps. Using the same device in the same location using the 2.4ghz band I get about 50 mbps, which is less than half. So this begs the question, why won't smart connect even broadcast the 5 ghz band or change my devices to a faster band to get the best connection? It certainly feels like a glitch in my opinion based on the firmware.

Why is this occurring? Has anyone else experienced this? Is this just a glitch with the firmware, or do I have a faulty unit?


For visual reference, here are pictures of the Tether app to show that both bands are configured (SSID = The Cottage Lounge) as well as WIFI analyzers. The Wifi analyzer is able to see the 2.4ghz band, but it is not visible in 5ghz. The wifi analyzer can only pick-up my neighbors 5ghz band (ie. Bell809)

https://photos.app.goo.gl/iyxR36fJNFMmb9CdA


For visual reference, here is a picture of my phone literally sitting on-top of the router (only connects to 2.4ghz)

https://photos.app.goo.gl/G3UXos1PAa6bFPdA8
Top