• Last Updated:
  • Feb 2nd, 2018 6:30 pm
Tags:
[OP]
Member
Dec 7, 2015
479 posts
104 upvotes
Ottawa, ON

RPi USB boot device

I recently set up my RPi3 to boot from USB, but find that none of the devices I have work (I've confirmed that the settings change worked). Two are USB flash card readers with the Raspbian microSD card in them, one is a 16GB thumb drive and the other is a USB HDD adaptor. According to the Pi web site, USB boot is finicky and not all devices work - set-up/power-up times are too slow or devices need a specific protocol that the Pi doesn't handle.

Does anyone use USB boot and can tell me the make and model of thumb drive or HDD/SSD adaptor that works for them?
3 replies
Deal Fanatic
User avatar
Oct 8, 2006
5585 posts
574 upvotes
Toronto
I've used a kingston usb before it was old model though. How did you confirm the settings changed worked if you have no devices that work?
[OP]
Member
Dec 7, 2015
479 posts
104 upvotes
Ottawa, ON
I only checked the setting as per the raspberrypi.org web page:
check that the OTP has been programmed with:

$ vcgencmd otp_dump | grep 17:
17:3020000a

Ensure the output 0x3020000a is shown. If it is not, then the OTP bit has not been successfully programmed.
This morning, I tried it with a SATA dock and hard drive. It boots up to the point of recognizing the drive, then sits for a long time and quits at:

115.5021531 random: crng init done

After that, the screen blanks. I'm not sure if the boot sequence is incredibly s_l_o_w or there's another problem.

Edit to add:

I searched the web and found a forum where they suggest it is a badly burned OS image - apparently this occurs with other OS versions than just Raspbian. I'll try burning a new image.
[OP]
Member
Dec 7, 2015
479 posts
104 upvotes
Ottawa, ON
Downloaded Raspbian from the Pi site and now everything works fine. I guess it's not as finicky about USB devices as they claimed.

I compared the old uSD (supplied by Buyapi) to the new uSD I just set up and they have completely different partitions etc. Maybe the version I got and have been using is an old one. No worries, I'll zap it and use the new download. I just have to reconfigure everything the way I had it :(

Top