Cell Phones

Sony Xperia C5 Unlocked from Wind to Rogers, No LTE

  • Last Updated:
  • Dec 3rd, 2016 9:05 am
Tags:
None
[OP]
Newbie
User avatar
Jan 1, 2009
4 posts
Scarborough

Sony Xperia C5 Unlocked from Wind to Rogers, No LTE

Hey guys,

I am looking for some help. I just got a brand new Sony Xperia C5 Ultra from Wind Mobile. I had the phone unlocked and am now using it with Rogers.

Everything went fine, and phone works very well. My only gripe right now is that under Network Mode, there is no LTE setting, I only have 3 options:

WCDMA/GSM (auto connect)
WCDMA ONLY
GSM ONLY

So I checked my screen, it is 4G only. When switch back to my old Rogers Galaxy S4 with same SIM card, it is LTE. So I am pretty sure my service is LTE. I also did some research from the forum, looks like Wind has locked the LTE figure for all the devices that originally sold by them. So is there any way to change it? I tried *#272*IMEI# to force my phone to enter CSC menu but it is not working...

Thanks for any suggestion!

Regards
9 replies
Deal Addict
User avatar
Sep 23, 2009
3483 posts
972 upvotes
Oshawa, ON
Generally speaking, phones from Wind do not support LTE to begin with unless it's a Nexus phone. About 95% of the phones from Wind are the international variation as they use a different frequency from the big 3 and do not support LTE. It would help if you posted the continental version (North American, European, International, Asian etc) of the phone you have.

EG: A Samsung Galaxy S4 i9505 (international) will not have LTE but the i337 (North American) variation will on the big 3 carriers.
[OP]
Newbie
User avatar
Jan 1, 2009
4 posts
Scarborough
EnyCe wrote: Generally speaking, phones from Wind do not support LTE to begin with unless it's a Nexus phone. About 95% of the phones from Wind are the international variation as they use a different frequency from the big 3 and do not support LTE. It would help if you posted the continental version (North American, European, International, Asian etc) of the phone you have.

EG: A Samsung Galaxy S4 i9505 (international) will not have LTE but the i337 (North American) variation will on the big 3 carriers.
Thanks for the info, my cell phone is Sony Xperia C5 E5506, I heard that there is some thing we can do to force the wind phone into LTE mode.
Deal Guru
User avatar
Jun 27, 2004
13118 posts
2366 upvotes
Vancouver.bc.ca
Have you tried loading generic firmware?
Deal Addict
User avatar
Oct 2, 2010
3395 posts
1295 upvotes
Brampton
Oldcat wrote: Hey guys,

I am looking for some help. I just got a brand new Sony Xperia C5 Ultra from Wind Mobile. I had the phone unlocked and am now using it with Rogers.

Everything went fine, and phone works very well. My only gripe right now is that under Network Mode, there is no LTE setting, I only have 3 options:

WCDMA/GSM (auto connect)
WCDMA ONLY
GSM ONLY
late response but just in case someone else needs it

1. enter service menu with code *#*#7378423#*#*

2. choose service settings from menu
Image

3. on network mode choose 'gsm/wcdma/lte
Image

* when you press back and check again, it will always revert back to 'gsm/wcdma'. that's ok. just exit out or press home button

4. go to settings > more > mobile networks > preferred network type > choose lte
Image

5. when you go back to service settings and check again, the lte setting should now stick and you have corresponding icon on info bar
Image

Grinning Face With Smiling Eyes
Member
Aug 29, 2015
206 posts
51 upvotes
According to B&H Photo, Sony Xperia C5 E5506 is a North American variant and is 4G LTE capable.

Image
Sr. Member
User avatar
Nov 9, 2014
574 posts
260 upvotes
Vancouver, BC
If all else doesn't work, the right variant (Canadian variant) should work with Rogers.
Virgin Mobile $75 | 10GB Unl.| Unl. Canada Wide | Unlimited Text/Pic Msg | 75.00

Don't forget to hit the THANKS button if I've helped. Have a Great Day!
Deal Addict
User avatar
Oct 2, 2010
3395 posts
1295 upvotes
Brampton
the one I posted is from a E5506, it's just that when you get a phone from wind (freedom), the lte is gimped
I had same issue with a samsung and LG, I think both required a change of csc
this sony phone was the easiest to get lte 'unlocked'

Top