Cell Phones

voip.ms SMS trouble

  • Last Updated:
  • May 26th, 2020 12:01 pm
[OP]
Member
Dec 4, 2017
487 posts
196 upvotes

voip.ms SMS trouble

Has anyone else had trouble with SMS on the voip.ms service? I experienced delayed texts (usually by hours or more) in late December 2019, and it's happened again in the last few days (late January and early February 2020). The more recent experience also includes some repeated texts, sometime rolling in during the wee hours of the night (and I can't turn off my ringer due to being an important contact for several people).

It's a common experience for both the "voip.ms SMS" and Acrobits Groundwire apps, so I expect that this is a server problem. I haven't changed any server or app settings lately.

I'd like to hear about any similar experiences before I log a ticket. Someone might suggest useful information to check first, or to include in the report.
16 replies
Deal Guru
User avatar
Oct 24, 2012
11536 posts
2525 upvotes
Montreal
I am with voip.ms and I use Groundwire. Groundwire has been 100% reliable for both calls and SMS for many months now.

Things you can try (to match how I'm setup):

- In Groundwire's account advanced settings, make sure that Delivery notification and composing notification are turned off.

- In voip.ms's DID SMS configuration, ONLY enable SMS SIP Account.

- *Uninstall voip.ms SMS app, only use Groundwire

*I think voip.ms SMS might fight Groundwire on whoever gets the SMS SIP transmission first. I know voip.ms SMS app uses URL Callback, but I seem to remember that it would still try to get SIP transmissions as well. It might be spamming the voip.ms server with double connections as well and getting you "blocked" for a while. I haven't really made many tests of having both applications at the same time, once Groundwire proved itself to be 100% reliable, I uninstalled voip.ms SMS as it became redundant and adds up to the battery drain


If all else fails:

- Uninstall Groundwire and reinstall it

- Change server (don't forget to change it both in Groundwire and in your subaccount in voip.ms)



Since you're a Groundwire user as well, tell me if you have these 2 issues and if you found a fix:

1- When I call using car bluetooth, the phone will initiate the call, but the audio option remains to "Phone". I have to manually switch to "bluetooth", which is annoying to do while driving. If I switch it for 1 call, all the next calls will remain on bluetooth. If I leave the car and come back, I have to repeat the manual switch over.

2 - When I reboot my phone, the native dialer application switches back to "SIM" for the default calling account, so I have to go change it back to Groundwire.
Member
Jul 16, 2008
247 posts
64 upvotes
ON
alkizmo wrote: I am with voip.ms and I use Groundwire. Groundwire has been 100% reliable for both calls and SMS for many months now.

Things you can try (to match how I'm setup):

- In Groundwire's account advanced settings, make sure that Delivery notification and composing notification are turned off.

- In voip.ms's DID SMS configuration, ONLY enable SMS SIP Account.

- *Uninstall voip.ms SMS app, only use Groundwire

*I think voip.ms SMS might fight Groundwire on whoever gets the SMS SIP transmission first. I know voip.ms SMS app uses URL Callback, but I seem to remember that it would still try to get SIP transmissions as well. It might be spamming the voip.ms server with double connections as well and getting you "blocked" for a while. I haven't really made many tests of having both applications at the same time, once Groundwire proved itself to be 100% reliable, I uninstalled voip.ms SMS as it became redundant and adds up to the battery drain


If all else fails:

- Uninstall Groundwire and reinstall it

- Change server (don't forget to change it both in Groundwire and in your subaccount in voip.ms)



Since you're a Groundwire user as well, tell me if you have these 2 issues and if you found a fix:

1- When I call using car bluetooth, the phone will initiate the call, but the audio option remains to "Phone". I have to manually switch to "bluetooth", which is annoying to do while driving. If I switch it for 1 call, all the next calls will remain on bluetooth. If I leave the car and come back, I have to repeat the manual switch over.

2 - When I reboot my phone, the native dialer application switches back to "SIM" for the default calling account, so I have to go change it back to Groundwire.
I am having trouble sending out sms from groundwire. Receiving sms is no problem. I tried switching server. If I only enable "SMS SIP account" without enabling "SMS", I couldn't receive anything at all. Need to configure caller ID?
[OP]
Member
Dec 4, 2017
487 posts
196 upvotes
j3390659 wrote: I am having trouble sending out sms from groundwire. Receiving sms is no problem. I tried switching server. If I only enable "SMS SIP account" without enabling "SMS", I couldn't receive anything at all. Need to configure caller ID?
Yes, your caller ID must match the DID.
Member
Jul 16, 2008
247 posts
64 upvotes
ON
IanBrantford wrote: Yes, your caller ID must match the DID.
I did but still can't send.

Any other options I need to setup? Outgoing calls need registration? Display Name? Auth User Name?
Sr. Member
Feb 28, 2012
784 posts
930 upvotes
It would be helpful to specify iOS or Android when reporting issues or success.

There are 5 ways to receive SMS from VoIP.ms.
- sent to an email address (reply to email will generate SMS reply; desktop receiving, permanent record)
- SMS Forward, to a SIM cell number (very few SMS options allow forwarding)
- SMS over SIP SIMPLE to a registered SIP client (CSipSimple, Groundwire?)
- SMS URL Callback (used by the VoIP.ms SMS Android app)
- the online SMS portal: sms.voip.ms (send/receive; 90d history)

You can setup more than one delivery channel.
The portal is always available and reliable, but somewhat awkward to use.

I've found the email option to be reliable, functional, and fast with a good email client/app.
SMS Forward is reliable, unless using the Fido data SIM.
I've had good experience with the VoIP.ms SMS dedicated app.

SMS over SIP SIMPLE is fast with a properly configured SIP client, and reliable since VoIP.ms put in place delivery queuing.
I can understand SIP SIMPLE being problematic with a push service, it's an IM (page mode) protocol written for SIP endpoints with direct connections.
Newbie
User avatar
May 12, 2020
4 posts
Brantford, ON
I know I'm late to the party but looking for some help...I'm with voip.ms, have been for years, love it. Using SMS from iPhone --> Portal and Portal --> iPhone works 100% as does email and forwarding to another number but I thought I'd give Groundwire a try. I've always used Acrobits Softphone up until now but it lacks SMS.

Anyway, I've configured a DID successfully and tried to send/receive SMS. Nada, nothing, zip. Everything's still working between phone and portal and email but I'm not able to send or receive on Groundwire. Any advice beyond what's already in this thread ?

Thx
Yo!Adrian
~~~~~~~~~
Yo!Adrian
[OP]
Member
Dec 4, 2017
487 posts
196 upvotes
yoadrian wrote: Anyway, I've configured a DID successfully and tried to send/receive SMS. Nada, nothing, zip. Everything's still working between phone and portal and email but I'm not able to send or receive on Groundwire. Any advice beyond what's already in this thread ?
Howdy and welcome to the party!

Did you to into the settings to enable SMS SIP Account? It's a subsetting and separate from the Portal.

https://wiki.voip.ms/article/SMS
Newbie
User avatar
May 12, 2020
4 posts
Brantford, ON
IanBrantford wrote: Howdy and welcome to the party!

Did you to into the settings to enable SMS SIP Account? It's a subsetting and separate from the Portal.

https://wiki.voip.ms/article/SMS
Thank you ! I've been with voip.ms for 8-10yrs now, love what they offer....

- SMS SIP Account = Enabled and set to associated sub-account
- DID configured to toronto5.voip.ms (haven't changed this)

Digging around I found the following settings posted by "alkizmo" in another thread. Are these still valid ?


In VoIP.ms' subaccount settings:
Protocol : SIP
Authentication type : User/Password authentication
Device type : ATA Device
Advanced options / Allowed Codecs : G.711U only
Advanced options / DTMF mode : AUTO
Advanced options / NAT : Yes
Advanced options / Encrypted SIP traffic : No
Advanced options / Max expiry : 90
Advanced options / RTP Time Out : 90
Advanced options / RTP Hold Time Out : 600

In VoIP.ms' DID settings:

Routing : SIP/IAX (select your subaccount)

"Settings / Preferences" menu:

Sound / Echo cancellation : Disabled (might be better or worse depending on your phone, you test it)
Sound / Noise suppression : Disabled (might be better or worse depending on your phone, you test it)
Sound / Audio processing configuration / Select "System audio processing" (might be better or worse depending on your phone, you test system audio and in-app audio)
Sound / Advanced sound settings / Samping Rate : 16000hz
Sound / Advanced sound settings / Playback block size : 8 ms
Sound / Advanced sound settings / Playback buffer size : 20 ms
Controls / Call Integration / Call Intagration mode / Select "Use system dialer integration"
Controls / Call Integration / System calling accounts / Enable "Groundwire"
Controls / Call Integration / System dialer configuration / Make sure Groundwire is there

"Settings / Accounts "

Add your VoIP.ms account, using the same server you chose in your DID Point of Presence in the VoIP.ms' DID settings.

"Settings / Accounts / Advanced settings "
Incoming calls / Select "Push notifications"
Send media back : Enabled
Send keep-alives : Enabled
Keep alive period : 30
Audio Codecs for Wifi (and mobile data) : G.711 u-law enabled (everything else disabled)
Audio Codecs for Wifi (and mobile data) / Packet time : 10ms
Outgoing calls need registration : Enabled
Transport Protocol : tcp
Push ptions / Simulate NAT : Enabled
Expires : 30
Messaging / SIMPLE : Enabled
Messaging / Composing notification : Disabled
Messaging / Delivery notification : Disabled
~~~~~~~~~
Yo!Adrian
Deal Addict
May 5, 2008
1850 posts
582 upvotes
yoadrian wrote: Thank you ! I've been with voip.ms for 8-10yrs now, love what they offer....

- SMS SIP Account = Enabled and set to associated sub-account
- DID configured to toronto5.voip.ms (haven't changed this)

Digging around I found the following settings posted by "alkizmo" in another thread. Are these still valid ?


In VoIP.ms' subaccount settings:
Protocol : SIP
Authentication type : User/Password authentication
Device type : ATA Device
Advanced options / Allowed Codecs : G.711U only
Advanced options / DTMF mode : AUTO
Advanced options / NAT : Yes
Advanced options / Encrypted SIP traffic : No
Advanced options / Max expiry : 90
Advanced options / RTP Time Out : 90
Advanced options / RTP Hold Time Out : 600

In VoIP.ms' DID settings:

Routing : SIP/IAX (select your subaccount)

"Settings / Preferences" menu:

Sound / Echo cancellation : Disabled (might be better or worse depending on your phone, you test it)
Sound / Noise suppression : Disabled (might be better or worse depending on your phone, you test it)
Sound / Audio processing configuration / Select "System audio processing" (might be better or worse depending on your phone, you test system audio and in-app audio)
Sound / Advanced sound settings / Samping Rate : 16000hz
Sound / Advanced sound settings / Playback block size : 8 ms
Sound / Advanced sound settings / Playback buffer size : 20 ms
Controls / Call Integration / Call Intagration mode / Select "Use system dialer integration"
Controls / Call Integration / System calling accounts / Enable "Groundwire"
Controls / Call Integration / System dialer configuration / Make sure Groundwire is there

"Settings / Accounts "

Add your VoIP.ms account, using the same server you chose in your DID Point of Presence in the VoIP.ms' DID settings.

"Settings / Accounts / Advanced settings "
Incoming calls / Select "Push notifications"
Send media back : Enabled
Send keep-alives : Enabled
Keep alive period : 30
Audio Codecs for Wifi (and mobile data) : G.711 u-law enabled (everything else disabled)
Audio Codecs for Wifi (and mobile data) / Packet time : 10ms
Outgoing calls need registration : Enabled
Transport Protocol : tcp
Push ptions / Simulate NAT : Enabled
Expires : 30
Messaging / SIMPLE : Enabled
Messaging / Composing notification : Disabled
Messaging / Delivery notification : Disabled
Try to change to montrealX.voip.ms server.
Strangely, traceroute from ON to torontoX.voip.ms goes via US which may bring problems, but to montrealX it stays within CA.
Newbie
User avatar
May 12, 2020
4 posts
Brantford, ON
Tichi wrote: Try to change to montrealX.voip.ms server.
OK, partial success, switched to Montreal-5 and can now receive texts (Yay!) but no love sending them...

I made all the changes suggested by “alkizmo”, seeing as nobody confirmed them I’ll delete the acct and try with default settings. Outside of that I’m stumped so feel free to chime in on resolving outbound messaging.
~~~~~~~~~
Yo!Adrian
Deal Addict
May 5, 2008
1850 posts
582 upvotes
yoadrian wrote: OK, partial success, switched to Montreal-5 and can now receive texts (Yay!) but no love sending them...

I made all the changes suggested by “alkizmo”, seeing as nobody confirmed them I’ll delete the acct and try with default settings. Outside of that I’m stumped so feel free to chime in on resolving outbound messaging.
Compared to your settings above, my only difference is

Messaging / Composing notification : Enabled

(I have no idea what it does tho ... :)
Deal Addict
May 5, 2008
1850 posts
582 upvotes
N.B. also I vaguely remember that outgoing SMS needs properlu set Caller ID (if it is wrong or spoofed it won't go through).
Might be worth checking in voip.ms settings
Newbie
User avatar
May 12, 2020
4 posts
Brantford, ON
Thx for those notes...i've sent several msgs , one each after changing settings, I figured it's something right in front of my nose that I've missed.

Sure enough...

I did all these things in a default acct:
- Default acct settings receive OK, send still nothing
- Groundwire Push/Standard settings didn't affect anything, no change
(also tested push notifications, worked 100%)
- Messaging / Composing notification : Enabled
- Caller ID is set same as caller ID on voip.ms (10 digit DID)

So I went back to "alkizmo''s post and noticed something in Sub-Account --> Advanced Settings
- Advanced options / Max expiry : 90

Yup, that one change was it, none of the other settings were changed, just the expiry from 3600 --> 90

To sum it all up, I only made one change on the voip.ms portal.
- Advanced options / Max expiry : 90

No other changes were required and none in Groundwire, I'm using default acct settings.

Thanks everyone for your patience...
~~~~~~~~~
Yo!Adrian
Deal Addict
May 5, 2008
1850 posts
582 upvotes
yoadrian wrote: Thx for those notes...i've sent several msgs , one each after changing settings, I figured it's something right in front of my nose that I've missed.

Sure enough...

I did all these things in a default acct:
- Default acct settings receive OK, send still nothing
- Groundwire Push/Standard settings didn't affect anything, no change
(also tested push notifications, worked 100%)
- Messaging / Composing notification : Enabled
- Caller ID is set same as caller ID on voip.ms (10 digit DID)

So I went back to "alkizmo''s post and noticed something in Sub-Account --> Advanced Settings
- Advanced options / Max expiry : 90

Yup, that one change was it, none of the other settings were changed, just the expiry from 3600 --> 90

To sum it all up, I only made one change on the voip.ms portal.
- Advanced options / Max expiry : 90

No other changes were required and none in Groundwire, I'm using default acct settings.

Thanks everyone for your patience...
I still have max_expiry = 3600, and SMS works for me. Curious :) Well, it happens...

Top